Update WISO MB 2008 Build 7.00.003 -> 7.00.00.10

  • Ich hatte MB2008 auf einem anderen Laufwerk installiert.


    Das neue (automatische) Update hat sich nun jedoch ungefragt parallel auf C:\Programme\Buhl\ neu installiert.


    Was soll das denn für ein Update sein, das die alte Version garnicht updatet, sondern sich einfach in einen von Buhl vorgegebenen Standardordner installiert? Ich will das nicht auf C haben...


    Weiß da jemand Abhilfe?

  • Hallo Lukator,


    installiere bitte das Programm einmal vollständig neu. Sichere deine Daten, deinstalliere das Programm und lösche anschließend das Installationsverzeichnis.


    Installiere nun erneut und versuche einmal das Update zu laden. Was geschieht?


    Hattest du Mein Büro vielleicht mehrfach in verschiedene Pfade installiert?

  • Vielen Dank, hat geholfen.


    Vermutlich lag es an einer Systemwiederherstellung. Das ist zwar ein tolles Feature in Vista und XP, kann aber zur Folge haben, dass die Installationsdaten der Programme, die seit dem Systemherstellungspunkt installiert wurden, gelöscht werden.


    Habe beide Versionen deinstalliert, die Programmordner und alle Windows Temp Dateien gelöscht, auch die im Perönlichen Ordner (AppData/Local/Temp), dann Programm neu installiert. Nun geht es wieder.

  • Tja - was soll ich dazu sagen!?!?


    Das neue Update hat sich schon wieder in C:\Programme\Buhl (program files) installiert, obwohl das Programm auf einem andern LW installiert ist. Nun habe ich schon wieder 2 Versionen drauf.


    Ich habe wirklich zurzeit keine Zeit, mich stundenlang mit solchen Sachen zu beschäftigen. Hat dieses Problem sonst niemand???


    Diesmal hatte ich seit der Neuinstallation definitiv keine Systemwiederherstellung.


    Könnte das mal eventuell jemand an die Programmer weiterleiten?


    Mein System: Windows Vista Home Premium 32bit / Avira Premium Security Suite mit Firewall.


    Das Update wurde direkt aus der Update-Funktion des Programmes gestartet. Ist mir wirklich unverständlch, warum der Installationspfad nicht mit übernommen wird.

  • Hallo Lukator,


    in jedem Fall gibt es wieder Relikte auf deinem System in einem anderen Verzeichnis. Wie du hier im Forum merkst, gibt es solch einen Sachverhalt ansonsten nicht.


    Wir haben diesen Sachverhalt geprüft und er kommt ausschließlich dann vor, wenn zwei verschiedene Mein Büro Verzeichnisse vorhanden sind.


    Vielleicht solltest du deinen Rechner einmal anständig warten und die Installationen prüfen. EINE Installation des Programms auf dem Rechner, nicht mehrere Verzeichnisse oder Installationen.

  • Ja, genau das hatte ich vor der letzten Neu-Installation getan - erstmal alle beiden Installationen gelöscht, dann die Verzeichnisse entfernt, die temporären Dateien gelöscht, auch die versteckten im persönlichen Ordner. Erst dann das Programm noch einmal installiert und das letzte Update geholt, da hat es auch wieder funktioniert.


    Seitdem dürfte sich am System nicht viel verändert haben, trotzdem hat sich das neue Update wieder in den Standard Ordner gepackt.


    Wahrscheinlich haben es die meisten im Standard Verzeichnis installiert, da tritt der Fehler natürlich nicht auf.

  • Was soll ich nun machen?


    Es ist nunmal so und ich kann auch nichts dafür, dass es nicht so funktioniert wie es soll. Wo holt sich denn die Update Routine den Installationspfad her? Vielleicht könnte man da mal ansetzen.

  • Hallo Lukator,


    die Updateroutine schaut zuerst in dem Pfad, von dem das Update aus ausgeführt wird. Installierst du also auf D:\, dann wird das Update auch dorthin kopiert und von dort aus installiert werden.


    Ansonsten wird das Programm in den Standardpfad C:\Programme\Buhl\Mein Büro installiert. Generell wird das Programm mit dem Update vollständig neu installiert und die Installationsroutine durchlaufen.


    Prüfen also wirklich noch einmal dein System nach Relikten älterer Installationen und entferne diese. Weiterhin achte im INstallationsverlauf des Updates auf den korrekten Pfad.

  • Hallo kleines Helferlein,


    kann es vielleicht daran liegen, dass ich das Programm normalerweise mit einem Tastendruck von der Tastatur aus starte?


    Ich habe nun das neue Update wieder deinstalliert, die Ordner gelöscht. Dann das Programm direkt aus dem Programmordner über die MB.exe gestartet und siehe da --- es ging.


    Aber das kann es ja nicht sein, dass man das zwingend auf diese Weise starten muss um vernünftig ein Update installieren zu können. Vielleicht wäre es sinnvoll zumindest eine Kopie der ini Datei in einem Systemordner zu hinterlegen, damit das Update Programm diese auf jeden Fall finden kann, auch wenn das Hauptprogramm nicht im Startordner läuft. Vista arbeitet ja teilweise mit virtuellen Ordnern und Arbeitsumgebungen.


    Achso ... Nachtrag: Man kann beim Update keinen Ordner festlegen, das läuft durch ohne jegliche Möglichkeit zum Eingreifen.

  • Hallo kleines Helferlein,


    ich benutze das "Wireless Laser Keyboard 6000" von Microsoft. Hier kann man verschiedene Tasten mit Funktionen belegen, z.B. mit Shortcuts, um ein Programm zu starten. Mit diesen Tasten starte ich häufig benötigte Programme, darunter auch Mein Büro.


    Beim Einrichten dieser Shortcuts sucht man im Konfigurationsprogramm einfach das zu startende Programm auf der Festplatte und speichert das Ganze. Ich kenne natürlich die interne Funktion nicht, aber es kann möglich sein, dass dadurch das Programm z.B. in einem anderen (virtuellen?) Ordner läuft.

  • Hallo Lukator,


    ich kenne leider das Keyboard nicht, aber generell ist diese Vorgehensweise nicht problematisch. In einem virtuellen Systembereich läuft das Programm daher nicht, es wird nur eine simple Verknüpfung im Tastatuttreiber angelegt. Zumindest bei anderen gängigen Tastaturen.


    In Vista gibt es aber ein anderes Feature, welches unter bestimmten Bedingungen das geschilderte Programmverhalten herbeiführen könnte. (Ich bleibe jetzt einmal bewusst im Konjunktiv, weil es nur eine Vermutung ist.)


    Vista setzt erstmalig als Windows Betriebssystem sogenannte NTFS Links ein. Unter Linux sind diese gang und gäbe. Hierbei wird ein Hardlink für ein Verzeichnis gesetzt. Bestimmte Programme legen beispielsweise Daten unter C:\Dokumente und Einstellungen\%User%\ ab. Dieses Verzeichnis gibt es unter Windows Vista nicht mehr. Statt dessen werden die Daten unter Vista im Verzeichnis C:\Benutzer\%User% abgelegt.


    Um Abwärtskompatibilität zu erreichen, wird nun ein NTFS Link C:\Dokumente und Einstellungen\%User%\ auf C:\Benutzer\%User% gelegt.


    Das Verzeichnis C:\Dokumente und Einstellungen\%User%\ existiert also eigentlich nicht, aber für einige Programme ist es existent.


    Detailliertere Informationen finden sich beispielsweise unter <!-- m --><a class="postlink" href="http://de.wikipedia.org/wiki/Harter_Link">http://de.wikipedia.org/wiki/Harter_Link</a><!-- m -->


    Von daher kann es eine solche Funktion sein, die hier als Ursache in Frage kommt. Doch kann ich davon auch bei noch so intensiven Tests hier nichts nachvollziehen, weder mit Hardlinks noch mit Installationen auf anderen Systempartitionen.


    In diesem Fall scheint deine Systemkonfiguration dafür verantwortlich zu sein und da kann ich kaum reinschauen.

  • Schon wieder Schwierigkeiten mit dem Update!


    Es ist tatsächlich so: wenn ich MB mittels Shortcut von der Tastatur aus starte (Microsoft Wirless Laser Keyboard 6000 v2.0) installiert sich das Update als völlig neue unabhängige Version unter C:\Programme\Buhl mit jungfräulicher Firma. Dagegen kann man absolut nichts machen.


    Starte ich das Programm jedoch direkt im Programmordner, funktioniert das anschließende Update so wie es soll.


    :idea: Das heißt logischerweise, über den Shortcut gestartet findet das Installprogramm den Installationsordner nicht und und installiert das Update ungefragt in den Standardordner.


    :!: Ich denke, dass sich derartige Probleme leicht lösen lassen, indem man z.B. das Installations-Log dort speichert wo es in jedem Fall gefunden werden kann, oder kleiner Eintrag in der Registry...