Gemeinsame Aktualisierung Konto und Depot Dresdner Bank

  • Bei gemeinsamer Aktualisierung des Girokontos, des Geldmarktkontos (das auch als Depotverrechnungskonto fungiert, aber eine eigene Kontonummer hat) und des Depots bei der Dresdner Bank funktioniert jeweils die Depot-Abfrage nicht. Fehlermeldung: "Benutzer führt bereits aktiven Dialog - Doppelanmeldung unzulässing (9210)"
    Alle 3 Konten haben separate Nummern. Bei Einzelaufruf des Depot-Kontos funktioniert die Datenübertragung problemlos. Der Online-Zugriff ist als Fin/TS (HBCI) PIN/TAN konfiguriert.


    (habe die Frage nochmals eingestellt. Sorry, ich war zuerst im falschen Forum)

  • Zitat von "martin57"

    Fehlermeldung: "Benutzer führt bereits aktiven Dialog - Doppelanmeldung unzulässing (9210)"


    Die Meldung kommt vom HBCI-Server der Bank und deutet auf einen noch offenen Dialog für die Zugangsdaten des jeweiligen Benutzers. Es genügt eigentlich, ein paar Minuten zu warten. Der HBCI-Server wird den Dialog nach kurzer Zeit von alleine schließen.


    Zitat von "martin57"

    (habe die Frage nochmals eingestellt. Sorry, ich war zuerst im falschen Forum)


    Den Doppelpost habe ich bereits umweltfreundlich entsorgt. Hättest ihn aber auch selber löschen können. :wink:


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

  • Warten alleine reicht nicht. Ich muß schon die Abfrage der anderen Konten der Dresdner Bank deaktivieren und dann das Depot einzeln abfragen. Meines Erachtens gibt es zwei mögliche Gründe: 1) MG schließt die Kontoabfrage programmtechnsich nicht richtig, oder 2) bei der Dresdner Bank entsteht ein Problem dadurch, dass das Geldmarktkonto gleichzeitig das Refeernzkonto des Depots ist und technisch möglicherweise einfach einen Link auf das Depotkonto darstellt. Standardmäßig gibt die Dresdner nur eine Kontonummer für Depot und Referenzkonto aus. Um den Zugriff aus MG realisieren zu können, mußte ich diese gemeinsame Referenz- udn Depotnummer nachträglich auf zwei Nummern aufteilen lassen.
    Aber auch im Falle eines Links müßte MG eigentlich problemlos alle Konten abarbeiten können, wenn es den HBCI-Zugriff nach jedem Kontoabruf korrekt schließen würde und nicht einfach auf einen time-out Abbruch wartet. Programmtechnisch wäre dies zumindest ein unsauberes Vorgehen.

  • Zitat von "martin57"

    Warten alleine reicht nicht. Ich muß schon die Abfrage der anderen Konten der Dresdner Bank deaktivieren und dann das Depot einzeln abfragen. Meines Erachtens gibt es zwei mögliche Gründe: 1) MG schließt die Kontoabfrage programmtechnsich nicht richtig, oder 2) bei der Dresdner Bank entsteht ein Problem dadurch, dass das Geldmarktkonto gleichzeitig das Refeernzkonto des Depots ist und technisch möglicherweise einfach einen Link auf das Depotkonto darstellt.


    Der HBCI-Dialog wird durch die HBCI-Schnittstelle (DDBAC) der Firma Datadesign abgewickelt. Durch Anlegen eines Registrywerts lässt sich dieser Dialog bis zu einem gewissen Grad beeinflussen. Gut möglich, dass das Problem damit behoben wird.


    ____________________________
    REGEDIT4


    [HKEY_CURRENT_USER\Software\Wiso\LetsTrade\HBCI]
    "SingleTransactionMode"=dword:00000001


    ____________________________


    Der Parameter bewirkt, dass die Aufträge nicht wie sonst üblich in einem Prozess und nacheinander an die Bank übertragen sondern diese in vollständig getrennten Prozessen übermittelt werden. Also jeweils mit Anmeldung/Abmeldung/ --> erneute Anmeldung /...


    Du kannst den Wert entweder selbst in die Registry eintragen oder die im Anhang befindliche Registrierungsdatei (gezippt) herunterladen und per Doppelklick ausführen.


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

  • Ich habe ebenfalls das Problem bei WISO MEIN GELD 2009 PROFESSIONAL, dass sich das Depot der Dresdner Bank nicht abrufen lässt. Ein getrennte Abfrage scheint auch nicht zu funktionieren. Zumindest bekomme ich auch eine Fehlermeldung wenn ich versuche das Depot allein abzufragen.
    Die Fehlermeldung lautet: "Der Auftrag HKWPD für das Konto XXX nicht verfügbar"


    Ich habe über das Forum schon gesehen, dass das Problem daran liegt, dass Depot und Girokonto die gleiche Kontonummer haben, aber gibt es dazu nun eine Lösung?