Probleme mit Splittbuchungen seit letztem Update

  • Hallo,


    seit dem letzten Update, ich denke das sind jetzt etwa 3 Wochen her, habe ich ein Problem beim Eingeben von Splittbuchungen im Haushaltsbuch.
    Im Fenster " neuen Beleg erstellen" gebe ich erstmal nur das Belegdatum und den Gesamtbetrag des Belegs ein. Dann klicke ich auf "Betrag splitten". In dem neuen Fenster gebe ich die Splittbeträge ein, die Software errechnet automatisch den fehlenden Restbetrag damit die Summe der Splittbeträge dem Gesamtbetrag entspricht. Danach beende ich die Eingabe mit "OK". Danach wähle ich nur noch den Zahlungsweg "Bar" und gebe den Verwendungszweck an und beende auch diese Eingabe mit "OK". Daraufhin erhalte ich folgende Meldung von MG: "Die Summe der Splitt-Beträge unterscheidet sich von dem Buchungsbetrag ! "


    Das Problem tritt nicht bei jeder Splitt-Buchung auf, aber ich hatte es schon sehr oft. Ich ändere dann einfach in der Gesamtsumme den Betrag um einen Cent wodurch auch bei den Splitt-Buchungen eine zusätzliche Buchung von 1 Cent zugefügt wird und dann klappt es. Das kann aber ja keine Dauerlösung sein, dass ich meine Unterlagen verfälsche nur damit das Programm die Daten annimmt. Vor dem besagten letzten Update trat dieses Problem nicht auf. Hat da evtl. jemand eine Lösung ?


    schönen Tag noch
    Matthias

  • Hallo,


    gleiches Problem habe ich auch schon beobachtet.
    Ich lösche dann immer alle Zeilen aus der Splitbuchen, trage die Buchung ohne Split ein, und spitte danach. Dann wir nichts verfälscht, aber ich muss die Beträge für den Split doppelt eingeben.
    Auch nicht so schön.


    Gruß, Thomas

  • Zitat von "charly0303"

    Sind wir die einzigen bei denen das Problem auftritt ???


    Keine Ahnung. Kann den Fehler anhand Deiner Angaben nicht reproduzieren.

    Zitat

    Oder nutzen alle anderen keine Splittbuchungen ???


    Nee nee, laufend.


    Zusatzfragen:
    Welches Formular nutzt Du für die Belegerfassung (altes oder neues)?
    Über welches Menü von welcher Seite aus?
    Wann trägst Du den Empfänger ein?


    Gruß
    Dirk

  • also gut dann mal mit Daten:


    Es handelt sich um das Haushaltsbuch somit also um das einbuchen eines Kaufbelegs z.B. von einem Supermarkt und die Ausgaben sollen lediglich verschiedenen Kategorien zugewiesen werden.


    Buchungsbetrag: 26,35 €


    Splittbeträge :
    1. Kategorie Reinigungsmittel: 4,95 €
    2. Kategorie Nahrungsmittel: 21,40 €


    Das sind wenn ich das mal im Kopf überschlage ... 26,35 € Diesen Wert errechnet auch das Fenster "Betrag splitten".
    Den Empfänger gebe ich im Hauptfenster der Buchung ein ... aber der Fehler tritt auch auf wenn kein Empfänger eingegeben wird.


    Ich denke ich verwende das alte Formular für die Belegerfassung ... es ist das kompaktere Formular.


    Die Buchung rufe ich aus dem Konto "Haushaltsbuch" über den Menüpunkt "neue Buchung" auf der linken Seite auf.


    Ich hoffe ich konnte jetzt alle Fragen beantworten


    schönen Tag noch
    Matthias


  • Hallo Sandro,


    das ist ja schön und gut aber das Problem war ja vor dem Update auch nicht da und wer sagt denn eigentlich, daß ich einen Updatevertrag habe und die 2008er Version überhaupt bekomme ?


    andere Frage:
    Wo kann ich denn auf den neuen Beleg umschalten um es zu testen ? Das hab ich schon gesucht und kann es einfach nicht finden :?

  • Extras --> Optionen --> Buchungen, ganz nach unten scrollen und ein Häckchen rein bei "Belegerfassung für Offline-Konten verwenden".


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •


  • Ja, das konntest Du und ich konnte mit deren Hilfe den Fehler nachstellen. Entscheidend waren die konkreten Zahlen. Nehme ich Deine Werte und Anzahl der Splits, so bekomme ich den Fehler in der alten Belegerfassung auch.
    Mache ich aus Deinen 26.35€ z.B. drei Splits, so geht es ohne Probleme zu speichern. Splitte ich wiederum einen anderen, willkürlich gewählten Betrag in zwei Splits, so läßt sich der speichern. Den Empfänger braucht man nicht eintragen, auch keine Kategorien. Ist offensichtlich ein reines Rechenproblem.
    Daran sieht man
    a) wie wichtig die Details zu Fehlerreproduktion sind und
    b) wie schwer es mitunter ist, einen Bug zu reproduzieren.


    Wie vom Sandro schon erwähnt, tritt dieser Fehler nicht in der Beta der 2008er Version auf. Auch nicht im alten Formular.
    Gruß
    Dirk