Fehler beim update der datenbank

  • Hi, ich habe das Haushaltsbuch 2008. Wenn ich das öffne, kommt:


    "Fehler beim update der Datenbank". Wenn ich auf OK klicke, dann kommt "Die Datenbank konnte nicht erstellt werden".


    Was ist das?? Habe ganz normal installiert. Das Programm blockiert dann und ich kann es nur über den Task Manager schließen.


    danke!



    p.s.: hab erst jetzt gesehen, daß das Haushaltsbuch eine eigene Gruppe hat... aber da sind keine Fehlerreports drin...

    • Offizieller Beitrag

    Dein Fehlerreport ist hier gut aufgehoben, da das Problem auch mit anderen Versionen von WISO Mein Geld auftreten kann. Mögliche Ursache ist eine Beschädigung der lokal installierten Microsoft Jet-Datenbank-Engine oder MDAC-Installation (Microsoft Data Access Components).


    Hast du vielleicht kürzlich eine Software installiert, aktualisiert oder deinstalliert? Wenn ja, welche? Welches Betriebssystem verwendest du?


    Gruß
    Jürgen

  • habe Win XP SP2. Natürlich installiere ich ab und zu neue Software usw. Habe aber auch den MDAC-Reapair.exe ausgeführt, dieser sagt mir, daß ein paar Dateien "zu neu" sind, alles andere ist ok. Beim MDAC-Jet-Repair.vbs erhalte ich einen Fehler, wenn ich den ausführe...


    Hab auch mal ein Tool benutzt, welches im Verzeichnis zum Haushaltsbuch war, das sagt mir, daß "Mein Geld" nicht installiert ist (klar, ich hab ja auch nur Haushaltsbuch installiert) und daß Letstrade nicht installiert ist. ABER.. Letstrade wird am Anfang der Installation installiert und ausserdem hab ich die neue Version vom Site runtergeladen und die auch noch mal installiert.


    Mit dem MDAC hab ich schon mehrmals die Datenbank repariert, aber klappt trotzdem nicht...


    sonst noch eine Idee?
    danke, marc

    • Offizieller Beitrag
    Zitat von "cramsmreh"

    Beim MDAC-Jet-Repair.vbs erhalte ich einen Fehler, wenn ich den ausführe...


    Welchen?


    Zitat von "cramsmreh"

    Mit dem MDAC hab ich schon mehrmals die Datenbank repariert, aber klappt trotzdem nicht...


    Gib mal im Windows Startmenü unter Ausführen nachfolgende Befehle jeweils einzeln ein und drücke auf ok.


    regsvr32 "%CommonProgramFiles%\Microsoft Shared\DAO\dao360.dll"
    regsvr32 msjetoledb40.dll
    regsvr32 Msjet40.dll
    regsvr32 Msjtes40.dll


    Nach erfolgreicher Ausführung erscheint die Meldung "DLLRegisterServer in *.dll erfolgreich durchgeführt".


    Gruß
    Jürgen

  • alles gemacht und alles erfolgreich durchgeführt, aber OHNE Ergebnis!! Erscheint immer noch die Fehlermeldung mit der Datenbank!!!


    Ich hatte das übrigens auch schon vorher versucht mit diesen Befehlen, denn das gleiche hab ich schonmal gelesen...


    Was nun?

    • Offizieller Beitrag

    Gib unter Start --> Ausführen ein: %appdata%\Buhl Data Service GmbH\log\


    Der Ordner enthält die Datei dbupdate.log. Öffne diese Datei, kopiere alle Einträge unterhalb der letzten Datumsangabe [tt.mm.jjj hh:mm:ss] in die Zwischenablage und füge sie in deine Antwort ein.


    Gruß
    Jürgen

  • Zitat von "Jürgen"

    Gib unter Start --> Ausführen ein: %appdata%\Buhl Data Service GmbH\log\


    Der Ordner enthält die Datei dbupdate.log. Öffne diese Datei, kopiere alle Einträge unterhalb der letzten Datumsangabe [tt.mm.jjj hh:mm:ss] in die Zwischenablage und füge sie in deine Antwort ein.


    Hi Jürgen,


    ich habe ZWEI Verzeichnisse, eins mit und eins OHNE "GmbH". In dem Verzeichns \Buhl Data Service GmbH ist \Letstrade drin, dann \log und \WISO Haushaltsbuch 2008, aber das ist LEER !!
    Im Verzeichnis \Buhl Data Service\ hab ich nur \on4u3 und plugins.


    Ich habe auch im Programm Verzeichnis ZWEI Einträge, einmal "WISO Haushaltsbuch" und einmal "Wiso-Haushaltsbuch", in jedem ist was anderes drin... Ich hatte die schon alle gelöscht und neu installiert, aber irgendwas klappt da wohl nicht...
    :-((

  • Hallo zusammen!!


    Hatte dasselbe Problem mit dem Haushaltsbuch 2008.


    Bei mir schlug allerdings schon die Ausführung der "msjtes40.dll" fehl.
    Hatte auch das MDAC-Repair-Programm von Macropool benutzt, um zu schauen woran es hängen könnte.
    Den Bereich MDAC hat es geschafft, aber im Bereich von JET war es dann aus mit der Regsamkeit.


    Habe mir nach verschiedenen Versuchen dann über <!-- m --><a class="postlink" href="http://de.nodevice.com">http://de.nodevice.com</a><!-- m --> eine ältere Version von der Datei "msjtes40.dll" heruntergeladen und siehe da es funktionierte.


    Mal sehen wie lange. :)


    Gruß
    Sascha

  • Hallo,


    ich hänge mich mal an diesen Thread, denn er trifft genau meinen Fehler.


    Neuer PC (XP, SP3) Wiso MG 2009 Neuinstallation (auf meinem bisherigen PC läuft es zum Glück noch..) und dann kam es zu den o.g. Fehlern:


    Fehler beim Öffnen der Datenbank
    und
    Die Datenbank konnte nicht erstellt werden.


    Anwendung hängt sich auf. Also genau wie oben schon von anderen geschildert.


    Habe mittlerweile 4x komplett Die Software de- und wieder installliert, zuletzt gem. des Neuinstallationsleitfadens, den ich hier unter den FAQs fand. Habe jeden Registry-Eintrag gesucht, gelöscht, AntiViren-SW ausgeschaltet, Systemwiederherstellung aus, etc.: Keinerlei Änderung. Auch egal, ob ich die Original DB (aus meiner laufenden Installation des Alt-PCs) schon in das Ziel Datenbankverzeichnis kopiere oder nicht.
    Dann habe ich das Hotfix3 installiert: Kein Änderung.


    Die in den obigen Beiträgen erwähnte MDAC-Repair und %appdata%\Buhl Data Service GmbH\log\ finde ich nicht. Auch eine man. Suche nach dbupdate.log brachte keine Datei zutage.


    Wie kann ich weiter verfahren?


    Gruß
    Michael

    EDIT:

    Habe mir jetzt MDAC-Repair und MDAC-JET-Repair geladen und ausgefüht. MDAC-Repair meldete nach Reparatur noch ein paar unterschiedliche Versionen (alle angemerkten Versionen sind in neuerer Version vorhanden, als erforderlich), war aber sonst zufrieden. WMG 2009-Start danach lief wieder vor die o.g. Fehler und blieb hängen.
    Auch MDAC-Jet-Repair meldete Vollzug, brachte aber keinerlei Änderung.
    :S



    EDIT 16:05 Uhr:
    Habe nun auch die o.g. Schritte
    regsvr32 "%CommonProgramFiles%\Microsoft Shared\DAO\dao360.dll"
    regsvr32 msjetoledb40.dll
    regsvr32 Msjet40.dll
    regsvr32 Msjtes40.dll
    alle durchgeführt:


    Fehler besteht weiterhin.
    Ich wüsste gerne, wo der Fehler nun noch liegen kann, bevor ich auf Verdacht jetzt weiter suche.

    Ich verwende WMG Professional 365, HBCI inkl. Schlüsseldatei mit Volksbank Münster eG, BLZ 401 600 50 (GAD)

    7 Mal editiert, zuletzt von WMG_Benutzer ()

  • Neuer Versuch, gleicher Status:


    MDAC und JET-Reparaturprogramm Version 1.0.0.0 von Buhl Data Service als Admin/mit Admin-Rechten ausgeführt. Und wieder sagte mir die Software am Ende: "Reparatur abgeschlossen".


    Vorhandene Dateien: 19
    Vorh. Dat in anderer Version: 49
    Fehlende Dateien: 0
    Korrekte Reg.Einträge: 121
    alles andere: 0


    > Fehler besteht unverändert weiter


    Ich denke nicht, dass es daran noch liegt.

    Ich verwende WMG Professional 365, HBCI inkl. Schlüsseldatei mit Volksbank Münster eG, BLZ 401 600 50 (GAD)

    • Offizieller Beitrag

    Auch egal, ob ich die Original DB (aus meiner laufenden Installation des Alt-PCs) schon in das Ziel Datenbankverzeichnis kopiere oder nicht.


    Welche Dateierweiterung hat diese Datenbank - .mgd oder .mgz? Sind im Programmpfad oder dem Pfad zum Datenbankverzeichnis Sonderzeichen, z.B. Klammern ( ) enthalten?


    Gruß
    Jürgen

  • Hallo Jürgen,


    - Pfad enthält das Sonderzeichen ''. Das dumme ist nur, dass ich ja gar nicht mehr in die Anwendung komme, um diesen Pfad ggf. anzupassen. Gibt es ne Datei, in der ich den Pfad händisch anpassen kann?
    - wenn ich meine .mgZ in diesen Pfad kopiere (oder den Pfad komplett leer, also ohne Datei, lasse) dann kommt es zu den o.g. Fehlern und zum Hängen der Anwendung.


    > Ich werde jetzt mal in der Registry nach dem WISO-Datenpfad suchen, vielleicht kann ich es damit ändern..


    Gruß
    Michael


    EDIT 14:15 Uhr:


    Habe jetzt in der REG den Datenpfad geändert und plötzlich startet WMG 2009 durch. Hurra! Muss jetzt nur noch prüfen, ob er meine alte Datei genommen oder sich selbst ne neue angelegt hat. Hätte nie gedacht, dass der Pfadname hier ein Problem darstellen könnte.


    EDIT 14:20 Uhr:


    Nachdem ich nun alle .mgZ und .mgB wie aus meinem Originalpfad in den neuen Datenpfad kopiert habe, werde ich zwar wie gewohnt nach meinem Kennwort gefragt, aber danach kommt die Meldung


    Die Datei ....MeinGeld.mgd wurde nicht gefunden.


    Habe dann meine Default.mgd in MeinGeld.mgd umbenannt (warum auch immer?!?) und nun bin ich 'drin'. :)


    EDIT 14:25 Uhr:


    Musste jetzt für die Online-Kontenabfrage noch meinen Datensafe registrieren, auch das hat geklappt. Sieht so aus, als wäre nun alles ok.



    Danke für Eure Tipps
    ! Wie gesagt: Das mit dem Datenpfad hätte ich wohl sonst nie ausprobiert. Sollte (falls nicht schon drin) in die FAQ!

    Ich verwende WMG Professional 365, HBCI inkl. Schlüsseldatei mit Volksbank Münster eG, BLZ 401 600 50 (GAD)

    3 Mal editiert, zuletzt von WMG_Benutzer ()

    • Offizieller Beitrag

    - Pfad enthält das Sonderzeichen '€'.


    Das war keine gute Idee. Auch wenn das €-Zeichen nett aussieht und es ja auch irgendwie zum Programm passt - verzichte unter Windows grundsätzlich auf Sonderzeichen in Ordner- und Dokumentnamen.


    Natürlich freue ich mich aber darüber, dass du das Programm endlich wieder nutzen kannst. :thumbsup:


    Gruß
    Jürgen