Kursaktualisierung meldet "Fehlerhafter WKN = oder ISI = "

  • Hallo zusammen,


    MG2009 liefert mir bei jeder Wertpapier-Kursaktualisierung den Hinweistext "Fehlerhafter WKN = oder ISI = ".
    Ich habe das Buhl Kursabo von 12 Euro im Jahr und frage 16 von 100 moeglichen Kursen ab.
    Die 16 Wertpapiere, die ich abfrage, scheinen immer aktualisiert zu werden.
    Trotzdem kommt immer die Meldung mit dem Hinweistext "Fehlerhafter WKN = oder ISI = "?


    In welchem Log-File und wonach sollte man in den teils riesigen Log-Files suchen, um dem Fehler auf die Spur zu kommen?
    Hat jemand einen Idee?



    Vielen Dank



    Gruss Juergen

  • In welchem Log-File und wonach sollte man in den teils riesigen Log-Files suchen, um dem Fehler auf die Spur zu kommen?
    Hat jemand einen Idee?

    Wie ist der Status der Checkbox "Kurse nur für momentan gehaltene Wertpapiere und Devisen aktualieren" unter Extras- Optionen - Online - Onlinecenter (weit unten)?
    Normalerweise kommt ja der Hinweis auf WKN oder ISIN im Onlineprotokoll (via Onlinecenter), wenn da etwas nicht stimmt. Wenn beides fehlt, würde darauf tippen, daß es die Papiere nicht mehr gibt. Ich würde da mal die Kurse der Papier durchgehen, da dürfte es ja keine aktuellen Werte geben.


    Gruß
    Dirk

  • Hallo Dirk,



    der Hinweis im Onlineprotokoll kommt mit oder ohne Haken in den von dir erwaehnten Optionen.
    Die Kurse, die ich abfrage, haben alle aktuelle Werte.
    Bei der Analyse der Log-Datei BCManager2.log habe ich festgestellt, dass er insgesamt Daten von 17 Wertpapiere abfragt. Ich habe aber nur 16 eingetragen.
    Unter BC_REQUEST werden 16 Wertpapiere gelistet.
    Unter BC_RESPONSE werden dann aber 17 Wertpapiere gelistet, wobei das 12 so aussieht:
    <item wkn="" isin="" currency=""><error id="2000"><![CDATA[Keine Daten, Wkn/Isin moeglicherweise inkorrekt]]></error></item>
    Jetzt frage ich mich, warum 16 Wertpapiere angefragt werden und dann von 17 Wertpapieren die Daten geliefert werden.
    Gibt es beim Kursabfragesystem Kommunikationsprobleme oder werden Variable falsch hochgezaehlt?



    Gruss Juergen

  • Gibt es beim Kursabfragesystem Kommunikationsprobleme oder werden Variable falsch hochgezaehlt?

    Das kann ich Dir nicht beantworten - mir ist aber nichts deartiges aufgefallen/bekannt. Ich könnte mir aber vorstellen, daß es bei Dir eventuell einen Zusammenhang mit Deinem anderen Problem gibt. Ich würde mal eine Datenbankkomplettwartung/-bereinigung durchführen und wenn das Problem immer noch besteht, mal den Support kontaktieren. Das scheint(!) mir insgesamt ein Datenbankproblem zu sein, welches man aus der Ferne nicht reparieren kann.


    Gruß
    Dirk

  • Hi,


    in MG09 hab ich genau diesen Eintrag auch gehabt. Da aber keine Fehlermeldung aufgeploppt ist, hab ich das einfach ignoriert.



    Seitdem ich MG10 benutzte wird zumindest ein derartiger Eintrag nicht mehr generiert oder angezeigt.


    In der Hoffnung, dass da jetzt nicht noch was schwieriges an der Datenbank kaputt gegangen ist, arbeite ich in MG10 weiter.
    Falls du dich aber nochmal an den Support wendest, dann poste hier bitte die Antwort, an der bin ich dann auch sehr interessiert.


    LG
    Thorben

  • in MG09 hab ich genau diesen Eintrag auch gehabt. Da aber keine Fehlermeldung aufgeploppt ist, hab ich das einfach ignoriert.

    Kann man vermutlich auch. Habe das mal bei mir weiter untersucht (hatte drei solcher anonymer Einträge) und bin den Verursachern auf die Schliche gekommen, und zwar so: habe mir zuerst mal den Aktualiserungsstand der Wertpapiere angesehen und auf die Verdächtigen eingeengt. Dann noch mal gekuckt, ob sie im Log drin waren, und dabei die aussortiert, für die es wirklich keine aktuellen Kurse gab/geliefert wurden. Die restlichen Drei fehlten im Log und die Gegenprobe = Löschen der WP aus einer Testdatenbank brachten ein fehlerloses Onlineprotokoll. Das waren dann zwei alte Bundesschatzbriefe und ein WP, welches es nicht mehr gibt (wurde mit einem anderen zusammengeführt). Also drei der Kursdatenbank bei Buhl vermutlich unbekannte WP.

    Seitdem ich MG10 benutzte wird zumindest ein derartiger Eintrag nicht mehr generiert oder angezeigt.

    Ja, MG2010 scheint damit besser umgehen zu können und schlägt keinen blinden Arlarm.

    n der Hoffnung, dass da jetzt nicht noch was schwieriges an der Datenbank kaputt gegangen ist, arbeite ich in MG10 weiter.

    Nein, das glaube ich nicht. Schau einfach mal, ob Du auch solche WP drin hast.

    Falls du dich aber nochmal an den Support wendest, dann poste hier bitte die Antwort, an der bin ich dann auch sehr interessiert.

    Bei ihm war der Fall ja etwas anders, wobei ich das jetzt in Bezug auf die WP-Anzahl nicht mehr so eng sehe. Ich würde an seiner Stelle mal die WKN und ISIN durchgehen, ob die zueinander passen (bei 16 bzw. 17 kein großer Aufwand).
    Gruß
    Dirk

  • Hallo Dirk,


    ich hab jetzt nochmal alles durchgesehen. Ich habe da insgesamt 63 Papiere (inkl. der damaligen Dax Titel) und wie man an dem Screen sehen konnte Fehler.
    Einmal zu Schering, ok die schmeiß ich raus.
    Dann noch mein Lehmann Müll...
    Aber das 3. find ich nicht. Ich hab da jedoch 2 Papiere die ich beobachte, bei denen bis heute erst die Freitagskurse da sind, aber kann das der Grund sein?


    Nochmal zu MG10:
    Zu früh gefreut. Vorgestern tauchten die Meldungen dort auch auf.


    Naja ich bleib einfach mal bei der Hoffnung, dass das keine Auswirkungen hat.


    LG
    Thorben

  • Zu früh gefreut. Vorgestern tauchten die Meldungen dort auch auf.

    Ja, nach meiner Theorie kann das auch nicht anders sein, denn die Daten, die für MG2010 geliefert werden sind ja dieselben wie für MG2009 bzw. derselbe Kursdienst.

    Naja ich bleib einfach mal bei der Hoffnung, dass das keine Auswirkungen hat.

    Das glaube ich nicht.
    Drei Punkte stören mich aber ein wenig daran:
    a) in der Meldung "Es wurden Kurse für xxx Wertpapiere abgerufen. (Limit=100)" sind auch offensichtlich die mit der Fehlermeldung "Fehlerhafte WKN = oder ISIN =" enthalten, für die keine nichts geliefert wurde bzw. geliefert werde konnte (habe ich noch eimal nachgezählt, ist bei mir so).
    b) Ich frage mich, ob die Meldung "Fehlerhafte WKN = oder ISIN =" nicht genauer geht (anscheinend geht in die Meldung nur ISIN bzw. WKN ein, wenn sie dem Serverseitigen Dienst bekannt ist)
    c) Wenn diese drei nicht mehr existierenden WP nicht gelöscht werden sollen (wegen der Historie), zählen die dann trotzdem zu den max. 100 WP, die man abrufen kann? Da wird doch nichts mehr geliefert?
    Da werde ich mal nachhaken.


    Gruß
    Dirk

  • Wenn du eh schon das Thema anschneidest, frag ich doch auch mal nach:


    Gibt es in MG (09 oder 10) die Möglichkeit das Abfragen einzelner Kurse gezielt ein- oder auszuschalten?
    Ich hab bislang nur die Möglichkeit gefunden alle abzufragen oder auf alle gehaltenen zu beschränken.


    Klar kann ich mir auch ein "Beobachtungedepot" basteln, in dem ich einige Positionen z.B. mit 0,00001 Stück einbuche, damit die über die option alle gehaltenen Kurse abrufen nicht alle sondern nur die, die ich will, damit meine 100 Kurse nicht gesprengt werden, aber eine reguläre Möglichkeit wäre mir lieber.


    Und wenn ich schon mal schreiben...
    Bei mir sind die Dax Titel von September 08 eingepflegt (da hab ich die Datenbank und MG begonnen). Gibt es eine Möglichkeit die aktuellen 30 Dax Titel z.B. per Import o.ä. nachzupflegen?


    LG
    Thorben

  • Wenn du eh schon das Thema anschneidest, frag ich doch auch mal nach:

    Brauch ich nicht ;)
    Wurde alles schon mal hier im Forum diskutiert und an der Sachlage hat sich meiner Wissens nach nichts geändert (deshalb kann ich sofort antworten).

    Gibt es in MG (09 oder 10) die Möglichkeit das Abfragen einzelner Kurse gezielt ein- oder auszuschalten?

    Nein, die gibt es nicht (nur über Deinen Workaround). Wenn's das gäbe, könnte man ja die 100er Grenze austricksen.

    Bei mir sind die Dax Titel von September 08 eingepflegt (da hab ich die Datenbank und MG begonnen). Gibt es eine Möglichkeit die aktuellen 30 Dax Titel z.B. per Import o.ä. nachzupflegen?

    Nein, nur manuell.
    Gruß
    Dirk