Signatur Issuer falsch - Nachricht wird abgelehnt (9380) + Elektronische Signatur noch nicht Freigeschaltet (9320)

  • Hallo,


    gestern versuchte ich von MG2008 auf MG2010 zu wechseln -- den damaligen Versuch auf MG2009 habe ich nach Stunden voller Problemen abgebrochen und es gleich bleiben lassen -- und nun kann ich meine Kontenstaende nicht mehr aktualisieren.


    Nach der Installation von MG2010 verlief der Import der alten Datenbank erfolgreich, nur konnte ich dann nicht mehr die Kontenstaende aktualisieren. Der Kartenleser wurde anscheinend nie angesprochen, es kam halt eine Fehlermeldung das es nicht ging.


    Ich ueberpruefte ob MG2008 noch ging, und das tat es auch. Ich wollte mich naemlich vergewissern ob der Zugang nicht gesperrt wurde, da die Dresdner Bank Commerzbank das Konto nach einen einmaligen Fehlschlag fuer einen Tag sperrt.


    Also wechselte ich wieder in MG2010, schaute bei HBCI im Menue nach, und landete dort wo man landet wenn man Control Panel -> Homebanking Kontakte anklickt. Da im Forum immer etwas stand von Kontakt loeschen und neu erstellen, tat ich das, ein paar male, auf verschiedenen Speicherslots auf der Karte, da es nie was gebracht hatte, und dannach ging auch MG 2008 nicht mehr.


    Nun, wenn ich versuche die Kontostaende in MG2008 aufzurufen (MG2010 ist mir, wie MG2009, nun auch egal), bekomme ich die folgende Fehlermeldung:
    Signatur Issuer falsch - Nachricht wird abgelehnt (9380)Elektronische Signatur noch nicht Freigeschaltet (9320)


    Nur verstehe ich nicht genau was die Bedeutet. Ist da auf der Karte etwa die Signatur veraendert worden und ich kann die so nicht mehr benutzen, oder wurde mein Konto einfach nur blockiert (dann haette es heute wohl schon wieder freigeschaltet sein sollen)? Was soll ich nun machen?


    MfG,
    Daniel

  • Welche Version der DDBAC ist denn aktuell installiert?


    Systemsteuerung -> Homebanking Kontakte und dann unten links auf "Über DataDesign Banking (DDBAC)" klicken.


    Wird das Konto bei der DreBa oder direkt bei der Commerzbank geführt?


    MfG
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

  • DDBAC 4, 3, 19, 0


    Das wird bei der Dresdner Bank gefuehrt, also also ich das 2006 eingerichtet habe, wars bei der Dresdner Bank. Bin zwar BLZ 60080000, aber in den Daten stand drin, dass man die 50080000 verwenden muss.


    Ich habe bei denen heute Nachmittag angerufen, und die sagten mir, der Schluessel wurde gestern neu erstellt und ich muss den INI-Brief wieder unterschrieben zu denen schicken. Der liegt nun im Briefkasten.


    Komisch ist aber dass ich den Kontakt im Speicher 1 der Karte, der einzige Kontakt der auf der Karte war, niemals geloescht habe.


    Etwas was ich vergessen hatte: nachdem ich MG2010 installiert hatte, und in diesen Homebanking Kontakte rein bin, da war ein Ausrufezeichen vor den einzigen Kontakt, es solle doch bitte synchronisiert werden. Als ich das versuchte, kam immer eine Fehlermeldung, also anscheinend wurde da der Chipkartenleser nie gefunden, obwohl er Minuten zuvor bei der MG 2008 einwandfrei funktioniert hatte.


    Beim DDBAC gitb es ja zwei GUI-Versionen, die alte klassische sagt, wenn man einen neuen Kontakt im gleichen Slot anlegt, also quasi den alten ueberschreibt, alle Daten erstmal uebernommen werden, und als Standardwerte angezeigt. Beim Punkt wo ein neuer Schluessel generiert werden soll, kann man bei der alten GUI (grau, nicht weiss) den vorhandenen Schluessel beibehalten (wird auch empfohlen). Und ich denke ich habe beim neuen GUI wohl ausversehen den alten ueberschrieben (ohne Warnung, Epfehlung den alten beizubehalten und sonst auch keine Warnung, auch obwohl ich immer Abbgechen gedrueckt habe und nie Fertigstellen).


    Wuerde das Sinn machen, dass ich dann deswegen diese Fehlermeldung bekomme?


    MfG,
    Daniel


    -------------------


    PS: Als ich die Hashes (RIPEMD-160) im INI-Brief verglich, also die von 2006 und die von den neuen den ich heute in den Briefkasten warf, bemerkte ich, dass die identisch waren. Ist das Normal? Ich dachte, das sind Hashes ueber den generierten Schluessel, und wenn der Schluessel nun ein anderer ist, muesste dann nciht der Hasch auch ein anderer sein?
    Der Exponent und der Modulus sind auch genau gleich wie im 2006.

  • DDBAC 4, 3, 19, 0


    Aktuell ist 4.3.26.0
    Zum Download gehts hier lang.


    Wuerde das Sinn machen, dass ich dann deswegen diese Fehlermeldung bekomme?


    In Sachen Chipkarte kann ich leider nur selten helfen. Da fehlt mir einfach die praktische Erfahrung. :(


    In Anbetracht deiner Fehlermeldung hatte ich zunächst ein Problem vermutet, das im Forum nebenan beschrieben ist. Daher meine Frage nach der DDBAC Version.


    Siehe http://www.onlinebanking-forum…ewtopic.php?p=59785#59785


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

  • Hallo,


    ich versuch mal dir zu helfen. Leider finde ich - um ehrlich zu sein - deine Beschreibung oben etwas konfus um da den Fehler zu finden:


    1. Die DDBAC Komponenten in MG 2008 und 2010 sind unterschiedliche, d.h. die Homebankingkontakte und Chipkartenleser einrichten in der Systemsteuerung funktionieren nur bis MG 2008, ab 2009 musst du die Funktionen über die Kontoverwaltung aufrufen
    2. Dort (Homebankingkontakte in der Kontoverwaltung) müsstest du den Kontakt synchronisieren können bzw. neu anlegen. Wichtig beim neu anlegen: DIe Schlüssel sollten übernommen und nicht neu eingereicht werden. Außerdem sollten alle Updates installiert sein.
    3. Die Fehlermeldung die du jetzt bekommst ist eindeutig: Bankseitig ist deine (er)neu(t) eingereichte Signatur noch nicht freigeschaltet - d.h. der unterschrieben INI-Brief liegt noch nicht bei der Bank vor.
    4. Das die Hashwerte identischsind deutet darauf hin, dass du den selben Schlüssel wie 2006 eingereicht hast. (den gleichen Hashwert mit einem neuen Schlüssel nochmal hinzubekommen ist faktisch ausgeschlossen, falls du das schaffst, solltest du sofort Lotto spielen gehen, die Wahrscheinlichkeit das du da gewinnst ist wesentlich höher)
    5. Die DDBAC auf die aktuelle Version zu bringen ist immer eine gute Idee, aber ich glaube in deinem Fall nicht die Lösung ;)


    Sollte es weiterhin nicht klappen, dann melde dich nochmal. Evtl. dann auch mit Screenshots und/oder einer genaueren Fehlerbeschreibung.


    Viele Grüße


    Sandro

  • Hallo, Danke fuer die Hilfe.


    Heute kam eine Absage von der Bank, die sagen der INI-Brief ist nicht korrekt.


    Normalerweise ist es nicht möglich, eine bei der Bank einmal angemeldete Signatur durch eine neue zu ersetzen. D.h. der von mir in 2006 generierte Schluessel kann nicht durch einen neuen ersetzt werden.


    Dazu bietet die Software ja auch einen Schutz: wenn man einen neuen Kontakt anlegen möchte, dann kann man keinen mit der gleichen Benutzerkennung anlegen. Das bei mir dann, nach dem ganzen Chaos vom Samstag, der INI-Brief noch den gleichen Hash-Wert wie von 2006 hat, bewiest ja, dass der Schluessel, der zu der Benutzerkennung gehoert, nicht neu generiert oder gelöscht wurde. Also eigentlich alles in Ordnung. Nur: Die Bank hat seit Samstag einen anderen Schlüssel! Und das, obwohl die sagen, dass eine einmal verifizierte Benutzerkennung keinen Schlüsselwechsel haben kann. Der Mann vom Kundendienst sagte mir, die Software habe es aber dennoch geschafft. Ich meinte nur, ich wuerde da eher von ausgehen das die Bank selbst einen Schutz vor solchen Fehlern hat. So was kann doch nicht einer Software frei überlassen werden ob die solche bankinterne Regeln bricht oder nciht. Es gibt Dinge, die schaffe ich einfach nciht zu verstehen.


    Ich solle bei meinem Berater eine neue Benutzerkennung beantragen, bekomme die zugeschickt, muss den INI-Brief wieder zurückschicken... alles nur wegen dem Upgrade auf 2010...


    Als letzten Kamikazeversuch vereinbarte ich mit dem Kundendienst am Telefon den einzigen Schlüssel von der Karte (der vom INI-Brief von 2006) zu löschen, dann unter der gleichen Benutzerkennung einen neuen Schlüssel zu generieren. Als ich ihm dann den Hashwert des neuen INI-Briefes vorlas (der auch effektiv anders war), meinte er, dass die Haschwerte der Signatur die er empfangen hatte nicht mit den vorgelesenen übereinstimmten.


    Das hört sich fast nach einem Softwareproblem an, quasi das lokal auf meinem Rechner der Schlüssel schon in verfälschter Form die Netzwerkkarte verlässt. Aber dann, anderseits, dürfte die Bank ja nicht seit Samstag einen neuen Schlüssel vorliegen haben.


    Ist alles irgendwie merkwürdig.


    Was ich hätte ausprobieren sollen, waere gewesen mit einem 2 Wochen alten Backup von meinem c:\ Laufwerk zu schauen ob das irgendwas mit neu installierter Software zu tun hat. Dafuer ists aber schon zu spät, und zweitens meinen die von der Bank ja dass der ein neu generierter Schlüssel bei der Bank abgespeichert verändert wurde (obwohl die mir sagen das so was nicht möglich ist!!!! Ich kanns einfach nicht verstehen. Die sagten mir auch mein Software habe den alten Schlüssel gelöscht und durch einen neuen ersetzt, obwohl die mir sagen das die so etwas nicht machen können! Verzweiflung)


    Das erste Kommentar: "Sie rufen genau am Ende der Kette an, wenn schon alles schief gelaufen ist."


    Ist schon wahnsinnig wie schnell (UND OHNE WARNUNGEN!!!) so was passieren kann. Nicht das erste Problem das ich mit WisoMG habe...


    Ich hatte mal meine Datenbank mit ein 32 Zeichen langem Passwort geschützt. Dann ging die Datenbank nicht wieder auf. Grund: das Passwort wurde auf 29 Zeichen begrenzt (OHNE WARNUNG!!!) und das war dann das gültige. 1 Woche hats gedauert bis ich das rausgefunden habe, fast hätte ich alle meine Daten verloren! Kundendienst: nicht nur unnütz, sondern auch extremst UNDANKBAR für meinen Hinweis über den Fehler in deren ihrer Software.