Buchungswerteingabe wird nicht korrekt übernommen

  • Seit ein paar Tagen habe ich das HHB 2017. Das Update von 2013 ging ohne Probleme, aber jetzt beim Eintragen der neuen Rechnungen stoße ich auf ein ungewöhnliches Problem:
    Wenn ich einen Betrag eingebe, wird er nicht korrekt erfasst.


    Ich gebe ein "-15,23" und wenn ich bestätige steht da "-1.523.00".


    wird zu


    Jedes Mal. Ich habe auch schon versucht, Beträge von älteren Buchungen zu kopieren, aber da passiert das gleiche. "-4,34" wird zu "-434.00" etc.


    Was kann ich tun?
    Danke!


    ----
    Edit: Ach ja, meine Mutter hat das gleiche Update gemacht, sie kann die Beträge normal eingeben.
    Edit 2: OS ist bei uns beiden Windows 10.

  • Hast du unter Umständen die Ländereinstellungen verstellt? Sieht so aus, als ob du nicht mehr mit Dezimalkomma, sondern mit Dezimalpunkt (englisches Format) arbeitest.

    Die besten Grüße aus dem tiefen Süden (wo es fast immer schön ist, auch bei Regen)
    nesciens



    WISO Steuersparbuch seit 1994, Windows 7

  • Danke für die Antwort! Das würde Sinn machen, wenn ich den Punkt benutzen könnte, aber wenn ich es versuche, passiert gar nichts ich kann also nur das Komma benutzen.
    Sagst du mir trotzdem, wo ich die Ländereinstellung finde? Vielleicht bewirkt eine Einstellungsänderung ja doch was. (In den Programmeinstellungen ist die Option nicht.)

  • Ah ok, das meinst du!
    Nein, ihr Windows läuft auf Deutsch, meins auf Englisch. Daran würde ich auch ungern was ändern. Es muss doch eine andere Möglichkeit geben, dass das Programm den Wert korrekt übernimmt, oder? Kann man den Punkt nicht irgendwie aktivieren, damit es klappt?

  • Daran würde ich auch ungern was ändern.


    Und wie wäre es, nur für die Zeit in der Du mit dem Programm arbeitest, das Tastaturlayout zu ändern?


    Ist noch mehr als eine Sprache installiert, erscheint im Infobereich der Taskleiste ein Symbol, das die aktive Sprache anzeigt.(Bei mir DEU=deutsche Tastatur)
    Ein Klick darauf blendet eine Liste ein, in der die gewünschte Sprache/Tastaturlayout gewählt werden kann.
    Bist Du mit der Arbeit fertig, kannst Du ja wieder auf ENG umstellen.
    (Ich habe es versucht, geht ohne Zeitverzögerung einwandfrei)
    Ohne DEU/ENG Umstellen, könntest Du einmal versuchen das Komma mittels Unicode "Alt+44" einzugeben.(Alt halten und dabei 44 eingeben) geht bei mir auch.

  • Ah ok, das meinst du!
    Nein, ihr Windows läuft auf Deutsch, meins auf Englisch. Daran würde ich auch ungern was ändern. Es muss doch eine andere Möglichkeit geben, dass das Programm den Wert korrekt übernimmt, oder? Kann man den Punkt nicht irgendwie aktivieren, damit es klappt?

    Nein. Denn das Programm übernimmt die Landeseinstellungen des OS. Dir bleibt also wohl nichts übrig, als das Eingabegebietsschema jeweils wie oben beschrieben, durch parallele Installation auswählbar, zu nutzen

  • Danke für eure Antworten!
    Aber ich glaube, das ist ein Bug. Meine Spracheinstellung mag US sein, aber mein Keyboard war immer auf deutsch gestellt. Ich hab gerade US als zweite Option entfernt, damit wirklich nur Deutsch benutzt wird, aber auch das hat nichts genützt. Unicode "Alt+46" (weil ich ja in dieser Konstellation den Punkt brauchen würde und nicht das Komma) klappt auch nicht.


    Gibt es einen Platz, wo man Bug-Reports loswerden kann?

  • Ich nicht.

    Dem stimme ich zu - ein Programm, das für den deutschen Markt konzipiert ist, geht in der Regel auch von einem Betriebssystem mit der Ländereinstellung deutsch aus. Aber versuchen kann es Wyrd Sister ja - es wird ausgehen wie das Hornberger Schießen.

    Die besten Grüße aus dem tiefen Süden (wo es fast immer schön ist, auch bei Regen)
    nesciens



    WISO Steuersparbuch seit 1994, Windows 7