Verhindern, dass Kundenart etc. zurückgesetzt wird

  • Hallo zusammen,


    ich wüsste gern, wie man verhindern kann, dass eine einmal eingestellte Kundenart (Privatkunde) immer wieder zurückgesetzt wird auf Firmenkunde. Es ist ein bisschen anstrengend, dass immer und immer wieder zurückändern zu müssen. Gleiches gilt für das Häkchen bei Serienbrief und E-Mail-Newsletter.


    Ich wollte gerade Rechnungen an Kunden versenden und musste feststellen, dass mal wieder alle Privatkunden zu Firmenkunden umgewandelt wurden, obwohl ich das nicht veranlasst habe. Also habe ich eine Excel exportiert mit den Kundennummern und der Kundenart. Diese beiden Spalten habe ich importiert. Nun wurden wieder alle Newsletter und Serienbriefe auf 1 gesetzt, sodass ich die Kunden nicht mehr anschreiben kann, obwohl ich diese Daten überhaupt nicht importiert habe. Also importiere ich auch das wieder. Daraufhin wurden dann alle Kunden wieder als Firmenkunden angelegt, obwohl ich diese Spalte gar nicht importiert habe. Das nervt unglaublich und es passiert in regelmäßigen Abständen.


    Wie kann ich das verhindern?

  • Habe ich bisher noch nie gehört, dass sich Daten selbständig ändern. Hört sich so an, als ob das nur beim Datenimport passiert? Sollte zwar auch nicht passieren, insofern sollte vielleicht ein Ticket an den Support geschrieben werden, aber ansonsten wäre der Weg sicher immer auch diese Daten mit zu exportieren und mit zu importieren.

  • Es passiert nicht nur beim Datenimport, sondern auch ohne. An einem Tag öffne ich das Programm und es ist alles gut, am nächsten Tag sind auf einmal alle Privatkunden Geschäftskunden. Und dann muss ich diese Import-Sache x-mal wiederholen, bis es wieder ok ist.

  • Hallo amafinode,

    ich bin nicht ganz neu hier.

    Fragen richten sich generell immer an die Person, die denThread erstellt hat, wenn nicht anders adressiert.

    Aus verschiedenen Erfahrungen weiß ich, dass es sinnvoll ist, sich zu vergewissern, dass die Frage im richtigen Forum gestellt worden ist.


    In diesem konkreten Fall wird ein Systemverhalten beschrieben, das sehr untypisch ist.

    Da ist es sinnvoll, sich dem Sachverhalt systematisch und Schritt für Schritt auzunähern.


    @ Mia:

    bitte beschreibe bitte genau, was du beobachtest.

    Eine Veränderung der Datenbank-Inhalte (die Eigenschaft "Firma" oder "Privat") erfolgt gewöhnlich nicht ohne Eingriff eines Benutzers, schon gar nicht in der von dir beschriebenen Weise ("Privat" zu "Firma").

    Wie ist dein System aufgesetzt? Standard oder gibt es individuelle Abweichungen bzgl. Speicherplatz o.ä.?

    Finden Datensicherungen / Rücksicherungen statt?

  • Wie heist denn beim gemachten Export das Feld für die "Kundenart" ? (Da kann ich kein Feld finden)

    Und wie (mit welchen Bezeichnungen) sind die Datenfelder beim Import jeweils gefüllt ?

    Man findet es im Export nicht, nur beim Import. Also das vor einiger Zeit zum ersten Mal vorkam, dass plötzlich alle 200 Privatkunden in meiner Datenbank Firmenkunden waren und es mir zu aufwändig war, das händisch zu ändern, fand ich auf einer Webseite den Hinweis, dass man Kundenart importieren könne und für Privatkunden eine 1 einsetzt. Die Spalte habe ich mit "Kundenart" bezeichnet, aber das spielt ja keine Rolle, weil ich die erste Zeile nicht mit importierte und einfach die Spalte einzeln zuweise. Das habe ich gemacht und siehe da, die Privatkunden waren wieder korrekt so hinterlegt. Nur setzt sich das immer mal wieder in unregelmäßigen Abständen zurück.


    Ebenso verschwindet gern mal das Häkchen bei "Newsletter" und "Seriendruck". Das muss ich dann auch importieren, exportieren kann man es nicht. Hier muss man eine 0 importieren, wenn man möchte, dass ein Häkchen auftaucht. Diese Info hatte ich vom Support bekommen.


    Zitat

    bitte beschreibe bitte genau, was du beobachtest.

    Eine Veränderung der Datenbank-Inhalte (die Eigenschaft "Firma" oder "Privat") erfolgt gewöhnlich nicht ohne Eingriff eines Benutzers, schon gar nicht in der von dir beschriebenen Weise ("Privat" zu "Firma").

    Wie ist dein System aufgesetzt? Standard oder gibt es individuelle Abweichungen bzgl. Speicherplatz o.ä.?


    Finden Datensicherungen / Rücksicherungen statt?

    Was ich genau beobachte, ist folgendes: Ich nutze Mein Büro ganz normal, importiere also die Online-Konten, weise Zahlungseingänge als Buchungen zu, mache die USt-Voranmeldung usw. Und natürlich erstelle ich Rechnungen. Manchmal werden alle Kunden als Firmenkunden zurückgesetzt, obwohl sie nie so erfasst wurden. Das bemerke ich dann, wenn ich dem Kunden mal wieder eine Rechnung schicken will und da nicht mehr "Sehr geehrte Frau Müller" steht, weil bei Privatkunden ja kein Ansprechpartner hinterlegt ist. Dann schaue ich in die Kundenliste, um zu prüfen, ob das zufällig nur diesen einen Kunden betrifft, stelle dann aber fest, dass mal wieder alle Kunden Firmenkunden geworden sind, obwohl ich nichts in den Stammdaten etwas geändert habe, außer, neue Kunden zu erfassen. Ich exportiere danach alle Kunden, füge eine Spalte ein für Kundenart, gebe eine 1 für jeden Privatkunden ein, lasse bei Firmenkunden das Feld frei und importiere dann die Tabelle, allerdings nur zwei Spalten, nämlich Kundennummer (als eindeutige Zuordnung) und dann Kundenart. Danach sind dann wieder alle Privatkunden ordnungsgemäß so dargestellt wie ich es mal erfasst hatte. Manchmal ist es dann so, dass bei diesem Import leider auch das Häkchen für Newsletter und Seriendruck verschwindet, obwohl ich die Spalte gar nicht zugewiesen habe. Das fällt mir auf, weil ich nach dem Import einige Kundenkonten öffne, um zu schauen, ob wirklich alle wieder Privatkunden sind. Das ist dann auch so, aber ich kann keinem Kunden mehr einen Newsletter schicken, alle Häkchen sind weg. Also importiere ich im Anschluss eine Excel, bei der nur Kundennummer und "Newsletter deaktiviert" und "Seriendruck deaktiviert" - für jeden Kunden mit einer 0 hinterlegt, importiert wird. Dann ist wieder eine Zeit lang alles in Ordnung, bis das Problem wieder auftritt.


    Das Problem ist nicht an den Import von Daten geknüpft. Es taucht auch auf, wenn ich wochenlang gar nichts importiert habe. Ich konnte keinen Zusammenhang zu irgendeiner Handlung feststellen.


    Ich habe einen Windows-Rechner, 64-Bit-Version, Intel Core i7, 16 GB, alles standardmäßig.


    Die Daten werden regelmäßig gesichert, allerdings nicht täglich. Vor Updates sichere ich natürlich immer. Bisher musste ich nur einmal eine Rücksicherung machen. Ich hatte ein Update installiert und Mein Büro ließ sich danach nicht mehr starten. Ich rief in der Hotline an und der Mitarbeiter half mir bei der Rücksicherung. Aber damals wurden die Kunden nicht auf Firmenkunden umgestellt. Das passiert im ganz normalen Geschäftsbetrieb, ohne besondere Ereignisse. Heute ist es in Ordnung, alle die Privatkunden sind noch korrekt. Letztmalig musste ich gestern alles neu importieren.


    Was mir noch aufgefallen ist: Manchmal funktioniert die Hauptnavi im Programm nicht. Ich klicke sie an, aber das Menü klappt nicht auf. Dann starte ich MB neu und es geht wieder. Das hat vermutlich gar nichts damit zu tun, aber ich wollte es nicht unerwähnt lassen, weil das auch komisch ist.

  • Danke für die ausführliche Antwort!


    Das mit dem Re-Import ist richtig so, allerdings solltest du darauf achten, dass wirklich alle anderen Spalten in der Tabelle leer bzw. gelöscht sind.

    Auch ist es empfehlenswert, die Tabelle als .xls (nicht .xlsx) zu formatieren und den Importassistenten im sog. Expertenmodus zu verwenden.

    Vielleicht kannst du damit die Änderung im Bereich Newsletter und Seriendruck verhindern.


    Das hilft aber nicht gegen die eigentliche Ursache des Problems.

    Eine Veränderung in der Datenbank findet nur durch einen externen Eingriff statt.

    Bitte kontrolliere regelmäßig - gerade, wenn du das Programm zeitweilig nicht nutzen solltest, das Datum der Datei DB1.DB im Datenpfad (ProgramData\Buhl Data Service GmbH\Mein Büro\DB).

    Benutzt du irgend eine Backup-Software, die im Hintergrund läuft?


    Das Problem mit der Hauptnavi deutet darauf hin, dass vielleicht dann und wann ein System-Neustart fällig sein könnte.


    Dann fällt mir noch ein:

    Sieh mal nach, was unter "Stammdaten | Meine Firma | Einstellungen" bei den Grundeinstellungen für eine Standard-Kundenart aktiviert ist. Vielleicht änderst du mal die Einstellung und beobachtest, ob die Macke bleibt.


    Grüße,

    Hamich

  • Das Problem mit der Hauptnavi ist schon lange bekannt und kommt offensichtlich sehr häufig vor; sollte also nichts mit dem eigentlichen Problem zu tun haben.


    Der richtige (nicht AD-verseuchte) Link zur angegebenen Doku ist:

    https://www.deltra.com/fileadm…t/how_to/Kundenimport.pdf


    Die einzigen Tipps, die ich noch geben kann: Datenbank reorganisieren und Suche indexieren.

    Eventuell hilft noch eine Neuinstallation des Programms mit anschliessenden Sicherungsimport.

    Nochmal den Support nerven mit Hinweis auf dieses Forum.

  • Ich importiere die Dateien tatsächlich immer als xls, weil ich sie auch nur so exportiere. Außerdem nehme ich den Import immer im Expertenmodus vor. So weise ich die notwendige Spalte zu, das geht im einfachen Modus ja gar nicht. Ehrlich gesagt, habe ich den einfachen Modus heute zum ersten Mal gesehen, da ich aufgrund des Hinweises danach suchte. Die Änderung beim Newsletter/Serienbrief vollzieht sich also im Expertenmodus.


    Ich benutze eine Backup-Software, allerdings macht die nur von D ein Backup, nicht von C mit Programm-Data. Es werden nur meine eigenen Dateien etc. gesichert. Die Sicherungen, die ich von MB mache, speichere ich auch auf D. Aber den letzten Reimport hatte ich mittels Daten vom Laufwerk gemacht. Es war nicht nötig, die externe Festplatte dafür zu nutzen.


    Bei den Einstellungen ist bei mir Firmenkunde hinterlegt. Die meisten Kunden sind Firmenkunden, daher hatte ich das so eingestellt. Meinst Du, ich solle das einstellen und dann wieder zurückstellen?


    Zitat

    Datenbank reorganisieren und Suche indexieren.

    Eventuell hilft noch eine Neuinstallation des Programms mit anschliessenden Sicherungsimport.

    Das hatten wir gemacht als das vorletzte Update dazu geführt hat, dass das Programm nicht mehr lief. Da mussten wir alles deinstallieren, neu installieren und die Daten importieren. Dabei hat mir allerdings ein Support-Mitarbeiter per Fernwartung geholfen. Ich gehe mal davon aus, dass der das richtig gemacht hat.


    Mich wundert halt, dass es vermeintlich "einfach so" zurückgesetzt wird. Ich könnte ja verstehen, wenn das mit einem Import zusammenhängen würde. Dass dabei etwas schief läuft. Aber es taucht eben ohne Importe auf. Die sind eigentlich nur dann erforderlich, wenn man wieder alle Kundenarten verändert werden.

  • Die Änderung beim Newsletter/Serienbrief vollzieht sich also im Expertenmodus.

    Und in der Import-Datei gibt es sicher bei dir auch nur die beiden Spalten (Adressnummer und Kundenart)?

    Konkret: eine Excel-Tabelle mit genau zwei Spalten.


    Bei den Einstellungen ist bei mir Firmenkunde hinterlegt. Die meisten Kunden sind Firmenkunden, daher hatte ich das so eingestellt. Meinst Du, ich solle das einstellen und dann wieder zurückstellen?

    Ja, das meine ich so.

    Ist auch nur ein Versuch, aber wer weiß schon genau, was in der Software genau eingestellt ist.


    Jetzt bleibt dann nur noch, genau zu beobachten, was auf Deinem Rechner genau vorher abgelaufen ist, wenn diese "automatische" Änderung wieder auftreten sollte.


    Nur um sicher zu sein: Ein Zugriff auf die MB-Datenbank durch eine andere Software ist ausgeschlossen?

  • Ja, ich exportiere die Kundendaten, lösche dann alles weitere, füge eine zweite Spalte hinzu mit der Kundenart und importiere das. Dabei weise ich auch die zwei Spalten zu.


    Es ist übrigens nicht immer so, dass Newsletter und Serienbrief deaktiviert werden. Da konnte ich aber noch kein Muster erkennen.


    Zitat


    Nur um sicher zu sein: Ein Zugriff auf die MB-Datenbank durch eine andere Software ist ausgeschlossen?

    Das kann ich nicht garantieren. Das Programm ist auf der gleichen Festplatte installiert wie Windows. Und legt Ordner an in versteckten Progammdateien, auf die Windows auch Zugriff hat. Was dort im Hintergrund geschieht, kann ich überhaupt gar nicht überblicken. Windows fährt ja auch ohne mein Zutun einfach den Rechner runter, obwohl ich diese Funktion deaktiviert habe. Wer weiß, ob es dann nicht auch in der MB-Datenbank herumpfuscht.

  • Moin,

    sind wirklich immer alle Privatkunden auf einen Schlag Firmen Kunden oder gibt es auch Ausnahmen?

    Was bei mir vorkommt, dass bei Onlinebestellungen auch das Feld Firma zweckentfremdet wird und dann durch einen Bestellimport aus vorhandenen Bestandskunden Firmenkunden werden.

    Dann müsste allerdings die Privatadresse unter weiteren Anschriften in MB weiterhin zu finden sein. Einen Zugriff des Betriebssystems auf die Datenbank halte ich für sehr unwahrscheinlich, dann gäbe es das Problem häufiger und es gäbe ein massives Problem mit dem Datenschutz.

    Erkundige Dich doch mal, ob es die Möglichkeit gibt, die Datenbankzugriffe zur Firebird Datenbank zu protokollieren.

    Einen aktuellen Virenscanner und Firewall wirst Du doch haben oder?

  • Ich habe noch nie alle Kunden durchgeklickt, aber wenn es passiert, sind alle Stichproben, die ich nehme, betroffen. Ich klicke immer einige Kunden an, von denen ich weiß, dass es Privatkunden sind und daran teste ich, ob es mal wieder zurückgesetzt wird. Die Adresse etc. bleibt übrigens korrekt, auch die Daten sind weiterhin richtig hinterlegt. Es ändert sich nur das Häkchen. Wenn ich das manuell oder per Import wieder richtig setze, steht da ganz normal Frau Gabi Mustermann, wohnhaft in Musterstraße 1, Musterhausen etc.


    Die Online-Bestellungen funktionieren bei mir übrigens. Da wurde bisher immer korrekt Privat- oder Firmenkunde importiert. Das Einzige, was fehlt, ist bei Firmenkunden die Anrede. Aber die weise ich einfach zu, wenn ich die erste Rechnung an einen Kunden versende und dann passt das auch und wird in den Stammdaten gleich richtig hinterlegt.


    Virenscanner und Firewall sind aktuell. Von Firebird habe ich noch nie gehört, da muss ich mich mal erkundigen.


    Danke für Eure Hilfe! Ihr seid echt super!

  • Firebird ist die Datenbank-Software, auf der Mein Büro basiert.

    https://de.wikipedia.org/wiki/Firebird_(Datenbank)


    Dass Windows von sich aus in die Datenbank schreibt, halte ich für so gut wie ausgeschlossen.

    Den Hinweis von Maus bezüglich der Online-Bestellungen halte ich da für potentiell ergiebiger.

    Da könnte es etwas an der Schnittstelle zu deinem shop sein.


    Treten denn diese magischen Änderungen möglicherweise in Verbindung mit Shopabrufen auf?

  • Ich mache täglich Shopabrufe und täglich sind da sowohl Privat- als auch Firmenkunden dabei, die dann neu erfasst werden. Das Zurücksetzen geschieht aber nur alle paar Wochen. Gerade erst habe ich Bestellungen abgerufen. Aber in den Stammdaten sind nach wie vor alle Privatkunden auch so geblieben.

  • Moin, wenn irgendetwas "von alleine" passiert, würde ich sehr genau hinsehen. Waren bei Dir nicht auch schon einmal angehängte Dokumente o. ä. ohne Dein Zutun verschwunden?

    Ich würde empfehlen, wie oben geschrieben, eine Protokollierung der Datenbankzugriffe zu realisieren.

    Dazu müsstest Du Dich in Firebird-Foren informieren. Denn von alleine ändert sich an einer Datenbank nichts.

    Alternativ, falls möglich MB auf einem anderen Rechner installieren und beobachten. Ein solcher Fall ist jedenfalls weder im MB noch im Orgamax Forum beschrieben.

  • Zitat

    Moin, wenn irgendetwas "von alleine" passiert, würde ich sehr genau hinsehen. Waren bei Dir nicht auch schon einmal angehängte Dokumente o. ä. ohne Dein Zutun verschwunden?

    Ja, das ist tatsächlich mal passiert. Allerdings passierte das in einem anderen Mandanten. Im dem Mandanten, in dem sich die Kundenart ändert, ist das noch nicht vorgekommen.


    Einen anderen Rechner habe ich leider nicht und der hier ist noch nicht einmal 2 Jahre alt.