Paypal Umsätze abrufen funktioniert nicht / Bankkontakt fehlt

  • TobiTrouble Hast du schon eine Lösung, was du 1. mit den vielen alten Buchungen machst? Bei mir hat es 5 Buchungen aus Dezember 2017 und dann vermutlich lückenlos ab Januar 2018 abgerufen. Wie du ja auch gemerkt hast, bringt löschen nichts.

    Und 2. wie bucht man nun die "neuen" Buchungen. Eine Splittbuchung ist ja nicht möglich, da ja nur der Rechnungsbetrag angezeigt wird. Eigentlich bleibt ja nur die monatliche Gebührenbuchung, oder?

  • Hi Zusammen,



    "Die Sache hat (k)einen Haken"



    tatsächlich habe ich eine Lösung für die Thematik, wobei ich mich allerdings frage, warum das Support-seitig nicht einfach kommuniziert wird oder wurde, da die Lösung an sich seeeehr einfach ist und notfalls für Personen die vielleicht nicht so technisch affin sind, mit einem kleinen Update auch zugänglich gemacht werden könnte, aber es geht auch „händisch“...



    Konstruktives Feedback für die Anleitung erwünscht 😉 – Gerne verbessere ich inhaltlich nochmal.



    Das Ganze hat bei mir funktioniert - da man mit der Direktfunktion von MB arbeitet - bitte gewissenhaft und auf eigene Gewähr hin handeln!



    Thema: Abruf ALLER PP-Buchungen der letzten Zeit (Jahre):



    Problem:

    Nach Eingabe der neuen API-Daten werden über den Umsatzabruf nicht nur die aktuellen Buchungen abgerufen, sondern auch rückwirkende (teils über Jahre) alte Buchungen.


    Lösung:

    - manuelle Löschung aller (neu/alt) abgerufenen Buchungen

    - "Dirketfunktion" in MB aufrufen:

    - ltconvert eingeben und anschließend unter eurem "PayPal" den Haken bei "LT-Umsatzabgleich" (der aktuell bei euch fehlen dürfte) setzen:


    - mit OK bestätigen - fertig


    Der Umsatzabruf funktionierte daraufhin für die letzten Umsätze seit "Generierung" der neuen API-Daten im PayPal Developper Portal.


    Das zur eigentlichen Lösung des Themas - vorher sollte aber u.U. folgendes getan werden, es könnte aber auch im Nachgang funktionieren, da ich aber überhaupt keine Lust hatte, das mehrmals zu probieren kann ich dazu nichts sagen...

    Thema: Lücke der Umsätze zwischen MB-PP-Problem und Generierung der API-Daten:


    Die Umsätze die davor (seit ca. Anfang Oktober, bis man eben die neuen API-Daten erstellt hat) nicht abrufbar waren, ruft die Schnittstelle auch nicht mehr ab ("PayPal Schnittstelle füllt keine Lücken").


    Problem:

    Zeitraum der Buchungen/Umsätze ab Zeitpunkt des Problems im Oktober bis zur Generierung der neuen API-Daten werden über die Schnittstelle nicht abgerufen.


    Lösung:

    - In den Bankingeinstellungen Konto von „Online“ auf „Offline“ stellen

    - Bei PayPal für diesen Zeitraum in den Berichtseinstellungen eine CSV der Umsätze generieren lassen und speichern

    - Über den Dateiimportassistent die PayPal CSV einlesen und die Umsätze hinzufügen (Ich habe dazu Buchungs- und Valutdatum als gleiche Spalte gesetzt, Empfängername usw. ist sicher selbsterklärend


    WICHTITG: Nicht die Brutto-Umsätze/Beträge importieren sondern Netto! (ohne PP-Gebühr) - Dadurch könnt ihr die Umsätze über eine Splittbuchung in voller Höhe einer Rechnung zuordnen und die Differenz im gleichen Zuge als Gebühr auf „Nebenkosten des Geldverkehrs“ verbuchen - sonst stimmt nach dem nun folgenden Umsatzabruf, nachdem Ihr das Konto wieder auf Online gestellt habt, der Kontostand nicht!


    Nun solltet ihr einen korrekten Kontostand haben (MB macht automatisch eine Saldenkorrektur), die vergangenen Umsätze seit API-Generierung automatisiert wieder im System haben und könnt künftig die Umsätze wieder ganz regulär abrufen.



    Thema: PP-Buchungen werden als voller Betrag abgeholt und PP-Gebühr wird nur im Text ausgewiesen:



    Problem:

    Die Gebühr wird nach Abruf mit den neuen API Daten nur im Text ausgewiesen, aber nicht als separate Position angezeigt, wie zuvor, um die Verbuchung zu splitten.


    Lösung:

    Aktuell keine, liegt beim Support von Buhl nicht vor, der MA hat sich ebenfalls gewundert und gesagt dass diese Thematik weitergegeben werden muss und MB leider auch nicht beeinflussen kann, was und wie über die Schnittstelle abgerufen wird…


    Lösungsvorschlag meinerseits an Buhl: Wenn man die Buchungen nach Möglichkeit nicht mit dem Bruttobetrag, sondern Netto abrufen würde, können (wie von mir eben beim manuellen Import beschrieben) die Umsätze mit einer Splittbuchung vernünftig verbucht werden.


    Bis dahin - Lösungsvorschlag vom Buhl-Support: Die Gebühren einmal monatlich bei PP über den Bericht speichern und manuell in einer Summe verbuchen.



    Ich hoffe für alle, dass mit dieser Lösung die meisten wieder "normal" arbeiten können und Monatsabschlüsse usw. ohne größere Probleme hinbekommen.



    Bis dahin - Have Fun ;)

    • Offizieller Beitrag

    Was habe ich schon wieder falsch gemacht?

    ltconvert

    hat er geschrieben.

  • UPDATE: 04.02.2021 -> Nach Update auf 21.00.03.004 funktioniert wieder alles bestens.

    ----------------------------------------------------------------------------------------------------------------------------------
    Hallo Leute,
    mich hat es leider die letzten Tage auch erwischt.
    Bei meinem Paypalkonto fehlten ein paar Buchungen im Q4-20, die ich händisch nachtragen musste.

    Nach Umstellung des Kontos wieder auf Online kam der Fehler mit dem fehlenden Bankkontakt, welchen ich nachfolgend einfach als den "Fehler" bezeichne.

    1) API Daten neu erzeugt -> Fehler
    2) REST API Daten angefordert, neues PP Konto angelegt, Eingabe der Daten erfolgreich -> Fehler
    3) Mein Büro neu installiert und eine frische Firma angelegt, neue Konten sowohl per API als auch per REST API angelegt -> Fehler

    Bei allen Versuchen war bereits das neuste Update 20.03.128.007 installiert.

    Gibt es bereits eine Lösung des Problems, welches ich im Forum übersehen habe?

  • Hallo,
    wir konnten das Problem durch Eure Tipps (fast) lösen. Der Support ist ja nur bedingt zu gebrauchen.


    Auf den meisten Sueraccounts funktioniert die Abfrage wieder. Lediglich auf dem Account, über den das Update durchgeführt wurde, funktioniert die Abfrage nicht mehr. Es kommt weiterhin der Hinweis, dass das Konto angeblich nicht existiert.
    Das passiert auch, wenn das Profil auf einem anderen Rechner ausgeführt wird.

    Habt Ihr eine Idee?