Bundesbank Umsatzabfrage nicht möglich

  • Hallo,


    ich erhalte beim Aktualisieren der Umsätze meines Kontos bei der Bundesbank Zentrale über HBCI Chipkarte folgende Fehlermeldung:
    "Zugriffsverletzung bei Adresse 058BD438 in Modul HBCIXM~1.DLL. Lesen von Adresse 00000000 HKKAZ"
    Die erste Adressangabe variiert bei jedem Aufruf der Umsatzabfrage. Ich hab auch schon anhand der Anleitung bei den FAQs die LetsTrade Komponenten neu installiert, leider ohne Erfolg. Vorher sah die Fehlermeldung leicht anders aus, aber mit selbem Effekt:
    "Zugriffsverletzung bei Adresse 0E62D438 in Modul HBCIXMLAdapterLib.dll. Lesen von Adresse 00000000 HKKAZ"


    Normalerweise erscheint beim Aufruf der Umsatzabfrage auch immer gleich die Software des Kartenlesers, aber soweit kommt Mein Geld hier gar nicht. Hatte auch schon die Kartenleser-Software in Verdacht, aber wenn ich den HBCI-Kontakt synchronisiere, funktioniert es einwandfrei!


    Weiß mir leider keinen Rat mehr. Kann jemand helfen?


    Viele Grüße
    Dominik

  • Hallo,


    mal 'n Schuss ins Blaue. Ist vielleicht die Datenausführungsverhinderung aktiv?


    <!-- l --><a class="postlink-local" href="http://forum.buhl-data.com/mgforum/viewtopic.php?f=16&t=3263">viewtopic.php?f=16&t=3263</a><!-- l -->


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

  • Die "DEP" steht bei mir auf "Datenausführungsverhinderung nur für erforderliche Windows-Programme und -Dienste aktivieren", sollte also passen, oder? Möchte es nicht für alle Programme aktivieren, nur um dann eine Ausnahme einrichten zu können.


    In den letzten Tagen konnte ich die Umsätze ja abrufen, auch die von anderen Konten bei anderen Banken funktionieren, allerdings über HBCI PIN/TAN. Ich habe so die Vermutung, dass es mit dem letzten LetsTrade Update zusammenhängen könnte...

  • So, nach fast einem Monat regem E-Mail Verkehr mit dem Support habe ich das Problem selbst lösen können. Innerhalb meines HBCI-Kontakts waren zwei Konten eingetragen, wobei bei dem einen Konto lediglich mein Name und die Benutzerkennung hinterlegt war, sonst nichts. Lösche ich dieses "Geisterkonto", funktioniert wieder alles. Seltsamerweise kommt es beim Synchronisieren des HBCI-Kontakts immer wieder hinzu. Liegt sowas an der Chipkarte oder an der Bank? Oder doch wieder an der Software?!?

  • An der Bank natürlich, an was sonst? :wink:


    Grob erläutert: die im Kontakt hinterlegten Konten und die dafür erlaubten Geschäftsvorfälle teilt die Bank in der Userparameter-Datei mit. Da für das Geisterkonto keine Geschäftsvorfälle übermittelt werden, darfst du natürlich auch keine nutzen. Die Umsatzabfrage scheitert. Eine Änderung dieses Zustands kann nur die Bank vornehmen. Schick denen zur Auswertung einfach mal eine Kopie der UPD-Datei.


    Bis zur Lösung des Problems kannst du dir damit behelfen, das Geisterkonto zu löschen und die UPD-Datei per Rechtsklick --> Eigenschaften als schreibgeschützt zu markieren. In das Verzeichnis gelangst du über den Ausführen-Dialog im Windows Startmenü mit dem Befehl ...


    %appdata%\datadesign\ddbac


    Die UPD hat das Format 280_BLZ_Benutzerkennung_220.upd. Gegebenenfalls musst du vorher auf deinem System noch die Dateierweiterungen einblenden. Nach Korrektur durch die Bank muss der Schreibschutz dann wieder entfernt werden.


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •