Problem mit Vorlagen Designer - Fehlermeldung: Schweiz_AnschriftPositionieren konnte nicht kompiliert werden

  • Hallo zusammen,


    als Neukunde und User von Mein Büro 2013 habe ich begonnen, per Modul "Vorlagendesigner" meine Word Templates für alle Arten von Dokumenten in Mein Büro zu übersetzen.
    Den Designer habe ich kapiert, allerdings resigniere ich jetzt an einer Fehlermeldung, die beim Wechsel von der Bearbeiten-Ansicht auf die Vorschau (und damit auch beim PDF-Export) erscheint:
    "Fehler - Programm: Schweiz_AnschriftPositionieren konnte nicht kompiliert werden."
    Ich kann diesen Fehler auf zwei verschiedenen Rechnern (Windows 7 64 Bit, deutsche Version) sogar mit den inkludierten Standardvorlagen reproduzieren:
    Dazu muss ich z.B. in der "Standardvorlage Rechnung" nur das vorgegebene Feld "P_PROJECTNOTES" löschen und auf Vorschau klicken: Beschriebene Fehlermeldung.
    Der technische Support hat es sich per Fernwartung angesehen, kennt den Fehler aber nicht und weiß keine Lösung.
    Er hat auch festgestellt, dass im Anzeigemodus "Berechnungen" des Designers bei mir weniger Formeln liegen als in seiner Vergleichsinstallation. Also Installationsfehler?
    Glaube ich nicht, denn ich kann diesen Fehler auf zwei verschiedenen Rechnern (Windows 7 64
    Bit, deutsche Version) mit frischen Installationen reproduzieren.


    Das habe ich bisher gemacht:
    - 1 frische Testinstallation auf Win7-64
    - 1 frische Kaufinstallation auf anderem Win7-64 Rechner
    - Arbeit an einer eigenen Vorlage (Kopie auf Basis der "Standardvorlage Angebot") --> Fehlermeldung, ohne dass ich wüsste, ab welchem Schritt sie genau auftrat (auf beiden Rechnern)
    - Test mit "Standardvorlage Angebot" --> gleiche Fehlermeldung bei Vorschau, z.B. wenn ich das Feld "P_PROJECTNOTES" (rechts unter Datumsheader) lösche (auf beiden Rechnern)
    - Vorlagen nochmals wiederhergestellt --> keine Wirkung
    - Alternative Online-Vorlagen probiert --> keine Wirkung
    - Neuinstallation komplettes Paket und Neuanlage des gesamten Mandanten --> keine Wirkung


    Meine Vermutung ist, dass es kein "Designproblem" ist, sondern dass Berechnungen nicht korrekt durchgeführt werden / Formeln in der Installation fehlen?


    Kennt jemand ein vergleichbares Problem? Eine Lösung?
    Kann jemand helfen? (SAMM, Burki?) Gerne auch per Teamviewer o.ä.


    Danke im voraus...



    Daryl

  • Hallo


    Vorab mal:
    Du bist Schweizer ? - lese ich mal aus Deiner Wortwahl heraus....
    Du brauchst die Schweizer Spezifikationen der Software für die Adressanschrift? Du sitzt in der Schweiz?


    Meines Wissens ist WISO Mein Büro nicht installationsfähig für die Schweiz. Nur für Österreich und Deutschland

  • Hallo,


    nein, ich bin Deutscher und sitze in Deutschland an deutschen Win7 Rechnern (deutscher Zeichensatz, anderweitig keine Umstellungen).
    Die Testinstallationsdateien stammen direkt von Buhl, bzw. eine Kaufinstallation von Amazon.
    Deswegen irritierte mich und den technischen Support die Fehlermeldung ja auch.
    Ich habe kein spezifisches "Schweizer" Feld oder Adressfeld o.ä. verwendet.
    Lässt sich bei mir wie gesagt auch mit den integrierten Standardvorlagen reproduzieren...


    ?

  • Also wenn Du online Vorlagen neu runterlädst, wie kann diese dann sich vom Support unterscheiden? Wenn eine online Vorlage diesen Fehler produziert, dazu noch auf 2 Rechnern, sind es vielleicht Hausgeister.

  • Hallo,

    Zitat

    Also wenn Du online Vorlagen neu runterlädst, wie kann diese dann sich
    vom Support unterscheiden? Wenn eine online Vorlage diesen Fehler
    produziert, dazu noch auf 2 Rechnern, sind es vielleicht Hausgeister.

    Ok... -
    ich schildere hier nur, was der ratlose Support mir dazu gesagt hat.
    Wie die Vorlagen korrekt aussehen sollen, kann ich nicht beurteilen, jedenfalls erzeugen sie (nach Löschen einzelner von mir nicht benötigter Felder) diesen Fehler, und ich bin jetzt etwas "lost", wie ich denn mit meiner bezahlten Kaufversion weiterarbeiten soll.
    Meine Hoffnung war, dass evtl. jemand schreibt: "Kenne ich, hatte ich auch schon, mach mal Folgendes:..."


    Vielleicht gibt es ja noch Ideen zur Fehlereingrenzung / Lösung?

  • Mit ist nicht klar nach dem letzten und ersten Post, ob Du nun - ohne an den Vorlagen gearbeitet zu haben - diesen Fehler schon bekommst??
    Denn wie kannst Du sonst schreiben, beim Löschen von ... läßt sich der Fehler produzieren - wenn er generell auftritt?


    Zudem lassen sich die Fehler auskommentieren = ignorien und es geht irgendwie weiter. Vielleicht helfen paar Erklärungen und Sreen's.


    Denn ohne den VD zu nutzen, sollte das erstmal klappen.

  • Ich habe eine Kopie einer Standardvorlage gemacht und darin gearbeitet.
    Das hat ab irgendeinem Zeitpunkt den Fehler in der Vorschau und auch beim PDF-Export erzeugt.
    Ich konnte den Fehler aber auch erzeugen, wenn ich zum Testen in einer frischen Standard-Vorlage beispielhaft Felder gelöscht habe (Beschreibung s.o.).


    Seit einer erneuten Neuinstallation heute tritt der Fehler nun merkwürdigerweise NICHT mehr auf, obwohl alle Vorlagen und Formeln genauso aussehen und ich meine Backup-Daten aus der vorherigen "Fehlerversion" eingespielt habe. Keine Ahnung warum, am Rechner ist alles unverändert.
    ?


    Ich betrachte das Problem damit allerdings noch nicht als "gelöst", sondern experimentiere mal weiter und sehe, was passiert.

  • Ich habe exakt das gleiche Problem. ich habe die Standard-Rechnungsvorlage mit dem Vorlagendesigner verändert. Nach dem Löschen einiger ungewünschter Bereiche bekam ich plötzlich die gleiche Fehlermeldung beim Umschalten auf Vorschau : Programm: Schweiz_AnschriftPositionieren konnte nicht kompiliert werden.
    Keine meiner Einträge in der Rechnung hat irgendwelche Infos in Sachen Schweiz drin.


    Heißt das für mich jetzt auch Neuinstallation oder wie bekomme ich den Fehler weg?


    P.S.: (Damit evtl. verbunden) habe ich ein weiteres Problem:


    Ich habe beim Entwurf in der Zusammenfassung eine DBMemo eingetragen, mit dem DataField M_TEXT2. Das sieht in meiner Vorlage exakt identisch aus zur Standard Rechnungsvorlage. benutze ich bei der Rechnungserstellung die Standardvorlage, schreibt er das richtige hin, was in der Variablen steht.
    Schalte ich bei der Rechnung auf meine eigene Rechnunsgvorlage um, schreibt er für M_TEXT2 nur was Wirres: {\rtf1\ansi\ansicpg0\uc1\deff0\deflang0\deflangefe0{\fonttbl{\f0\fnilArial;}} ....usw.


    Wie kann das sein? Der Variableninhalt sollte doch gleich sein, egal welche Vorlage ich verwende?!


    Für mich sieht das Ganze ziemlich buggy aus, sorry.


    Edit2: Wenn ich die fertige Rechnung drucken will oder als PDF exportieren will, bringt er die gleiche Fehlermeldung:


    Programm: Schweiz_AnschriftPositionieren konnte nicht kompiliert werden.


    Ich nehme an, dass da was im Tab "Berechnen" falsch eingetragen ist?!

  • Für mich sieht das Ganze ziemlich buggy aus, sorry.


    Sorry da sollte man vorsichtiger mit solchen Äußerungen sein. Als Anfänger sollte man immer Bedienungsfehler vermuten. Mich wundert einfach wie schnell User mit Begriffen wie Buggy um sich werfen. Denn aus buggy lernst du nichts, da sollte man doch ruhig gestehen, daß man nichts weiß; und hier fragt. :)

  • Ich habe auch lange Bedienungsfehler vermutet bevor ich mich an das Forum gewandt habe.
    Wenn ich dann allerdings lese, dass jemand das gleiche Problem hatte und es sich löste, indem er die Software neu installierte, kann ich durchaus zu der Folgerung gelangen, dass es sich hier um einen Bug handelt. Denn selbst wenn es sich ursprünglich um einen Bedienungsfehler gehandelt haben sollte: wenn die Lösung dafür eine Neuinstallation bedeutet, ist es trotzdem ein Bug, denn so etwas müsste dann abgefangen werden. Ich bin selbst Softwareentwickler.


    Nun würde ich mich trotzdem freuen, wenn mich jemand eines Besseren belehren könnte, indem er mir zeigt, was ich denn (wenn es denn so sein sollte) falsch gemacht habe.

  • In diesen nicht näher genannten Veränderungen ist der Grund für solche Störungen zu suchen. Es gibt keinen Support für den Vorlagen Designer. Aus dem guten Grunde: Entweder man ist vorsichtig beim Herantasten.
    Um zu vermeiden, als Support in Situationen zu geraten, sich rechtfertigen müsse, gibt es keine offizielle Beratung/Support. Das ist zu diffiziell...


    Wer aber sich was zutraut, dem liegen viele Möglichkeiten zur Nutzung offen. Wer was verändert oder löscht muß mit allem rechnen.
    Hinter jeder sichtbaren Variablen etc können auch un-/sichtbare Berechnungen stehen, die letzlich auch unzugänglich bleiben.


    Ahnte schon, daß Du erfahren bist. Diese Leute vom Fach, IT Informatiker usw trauen sich schneller Urteile zu: statt von einem Bedienungsfehler wird schnell von einem Bug gesprochen. :)


    Mein Rat: statt Felder & Regionen zu löschen - gerade was den Kopfbereich Nähe der Adresse anbelangt - auf unsichtbar zu setzen. Denn diese 'Schweizer Anschrift' Fehlermeldung beruht auf alle möglichen gelöschten Kopfvariablen.


    Statt DataField M_TEXT2 neu einzusetzen, erhalte das Original und verschiebe es nur.


    Liebe Grüße