Lagerbestandsaktualisierung MB -> Webshop (xtc 4.2) schlägt fehl

  • Moin moin miteinander.


    Ich stehe gerade vor einem Rätsel. Ohne irgendwelche Änderungen an MB oder meinem Webshop bekomme ich seit gestern bei der Webshopaktualisierung - also dem Übertragen der aktuellen Lagerbestände von MB in den Shop) die Fehlermeldung "Beim Export der Daten ist ein Fehler aufgetreten"


    Das Abholen der Artikelliste und die Prüfung auf offene Bestellungen klappt problemlos (was auf eine funktionierende Anbindung an die Datenbank des Webshops schließen läßt), nur wenn ich dann den Lagerbestand dann setzen will, klappts nicht. Komischerweise hat es Anfang der Woche noch funktioniert und nun geht's nicht mehr. Wenn ich denn wenigstens irgendwas geändert hätte, dann hätte ich einen Ansatzpunkt für die Fehlersuche. Aber so bin ich echt ratlos.


    Hat das Jemand auch schon mal gehabt und einen kleinen Tipp für mich? ?(

  • Nee, nicht dass ich wüßte Mausko. Mein Server läuft mit PHP 5.6.


    Am Mittwoch war der Server mal kurz down und ein Anruf bei der Hotline meines Providers brachte zu Tage, dass das Problem bekannt ist und die Technik schon daran arbeitet. Nur kann ich mir nicht vorstellen, was das mit meiner Datenbank zu tun hat. Wenn da was geändert worden wäre, dürfte ja gar kein Zugriff mehr funktionieren. Bestellungen abholen und den Bestellstatus ändern geht ja aber problemlos - der Datenbankzugriff für MB ist also gegeben. Ich weiß mir momentan keinen Rat.


    Ich werde den Shop heute Nacht mal kurz offline nehmen und eine Datenbanksicherung von Dienstag einspielen. Mal sehen, ob es dann wieder geht. Ich kann ja schlecht bei jedem Wareneingang alle Artikel manuell aktualisieren... ;(

  • Ich weiß nicht, welche Datei das sein soll Mausko, aber es sind alle Dateien da, die schon immer in dem Ordner waren.


    Ich habe es jetzt mit einer zweiten Installation von MB probiert - leider der gleiche Fehler.
    Ich habe den Onlineshop testweise auf den Stand 20.10. zurückgesetzt - der gleiche Fehler.
    Ich probiere das jetzt nochmal mit einer Sicherung vom 13.10. (da lief der Export definitiv noch) und werde mal schauen, was passiert. Geht aber nur spät nachts, wenn keiner im Shop rumwuselt. :)


    Gibt's eigentlich irgendwo ein Logfile, wo MB den Vorgang protokolliert? Da könnte man den Fehler ja exakt eingrenzen. ?(

  • Die Datei sollte im Ordner ImportFiles
    sein. Ist sie dort vorhanden, stimmt etwas mit der Übertragung in den nicht, ist sie nicht da, liegt der Fehler bei MB. Ich vermute aber, dass der Fehler durch den Server verursacht wird. Hast Du mal die Errorlog Einträge angesehen?

  • Alles da Mausko, also die Exportdateien und die sehen auch genauso aus wie immer.


    Datenbank-Restore auf 13.10. (ein älteres Backup habe ich nicht mehr) hat auch nichts gebracht. Aber ich habe in den MB-Logs gesehen, dass am 09.10. ein Update von MB durchgeführt wurde. Ich bin zwar der Meinung, dass ich nach dem Update noch den Lagerbestand aktualisieren konnte, aber schwören möchte ich da jetzt nicht drauf. Am Ende liegt der Fehler vielleicht am Update? Aber dann müßten alle hier mit xt:Commerce 4.2 den Fehler haben. Andererseits finde ich im Errorlog meiner Webshop-Datenbank keine Fehler in den letzten Tagen. Und jetzt raucht mir vom vielen Probieren und Überlegen der Schädel und außerdem klingelt in ein paar Stunden schon wieder der Wecker... ;(


    Webserver und Datenbank möchte ich eigentlich ausschließen, da dort definitiv keine Änderungen vorgenommen wurden.


    Ach sch.... ich mach die Kiste jetzt aus. Ich dreh mich grad eh im Kreis und wird wohl morgen mal bei Buhl anklopfen.

  • Moin Heiko,
    ich meinte auch nicht den Errorlog der Datenbank, sondern des Servers. Ich kann bei meinem Provider die aktuellen Error- oder Warning- Meldungen aufrufen. Eigentlich müsste ein vergeblicher bzw. fehlerhafter Versuch den Lagerbestand zu aktualisieren, dort einen Eintrag zu hinterlassen. Aber eine Anfrage bei Buhl kann nicht schaden.
    PS.: hab gar nichts von einem Update mitbekommen, bist Du sicher, dass es nicht nur ein LetsTrade Update war?

  • So, ich nochmal. Hast ja Recht Mausko, den access_log hatte ich außen vor gelassen. Ein Fehler, denn genau hier bin ich jetzt in über 1 Million Einträgen im Oktober fündig geworden.


    Laut meinem Monitoring gab es am 21.10. gegen 11:14 Uhr einen 30-minütigen Serverausfall.
    Eine halbe Stunde vorher hat die Lagerbestandsaktualisierung noch funktioniert und als ich das am 23.10. wieder tun wollte, ging es nicht mehr.


    Den Grund findet man in diesen beiden Zeilen.
    Hier gings noch:

    Code
    2.166.236.174 - - [21/Oct/2015:10:44:42 +0200] "POST /mein_buero/mb_osc_sync.php?shp_system=veyton&sync=stockvalue_to_shop HTTP/1.1" 200 259 "-" "mb_sync"


    Hier nicht mehr:

    Code
    [23/Oct/2015:17:49:13 +0200] "POST /mein_buero/mb_osc_sync.php?shp_system=veyton&sync=stockvalue_to_shop HTTP/1.1" 500 623 "-" "mb_sync"


    Ein lausiger "Internal Error" ist es, der mir schon hat graue Haare wachsen lassen.
    Ich habe jetzt also nicht Buhl, sondern meinen Provider angeschrieben. Da ich einen Managed Server habe, sollen die sich gefälligst darum kümmern. Ich bezahl ja schließlich dafür. :thumbup:


    Danke für deine Unterstützung bei der Fehlersuche.
    :beer: