Webshopschnittstelle und modified 2.0.5.1

  • Da mir der Support von Buhl bisher nicht helfen konnte, stelle ich hier mal meine Frage in der Hoffnung jemand hat eine Idee:

    Modified Shopversion 2.0.5.1

    neueste Webshopschnittstelle und neueste MB-Version

    Das Abholen von Bestellungen klappt einwandfrei.

    Leider das Hochladen (Webshop-Aktualisierung) nicht.

    Die Artikel werden alle alle zum Export eingelesen, aber leider kann ich keine Hochladen. Beide xml-Dateien werden erstellt.

    folgende Fehlermeldung gibt es im MB-Log:

    Code
    01.08.2020 17:25:02: Error - System.IndexOutOfRangeException: Der Index war außerhalb des Arraybereichs.
    bei de.deltra.ShopConnector.helperclass.ColorTable.getColor(String colorStr)
    bei de.deltra.ShopConnector.helperclass.ColorTable.CreateApplicationColors()

    Auf dem Server sind keine Fehlermeldungen.

    Vielleicht hat ja jemand dieselbe Konstellation laufen und bei ihm geht es ?

  • Moin,

    Du schreibst, beide xml Dateien werden erstellt. Meinst Du damit den Export aus MeinBüro? Falls ja, sind dort alle Artikel aufgeführt oder findet sich dort auch ein Hinweis auf den Fehler. Ich nutze noch die 2.04 und stelle nur im Shop die Artikel ein,da der mehrsprachig ist. Mit welcher Modified Version hat es denn letztmalig geklappt?

  • Erstmal danke für Deine Antwort.

    Ja, denm Export aus Mein Büro. Es sind dort alle aufgeführt; sowohl beim Abgleich (Artuikelliste##.xml) als auch beim Export (Artikelexport##.xml) und fehler finden sich keine darin, jedenfalls ich kann keine entdecken bis auf den durchgeführten Rollback im Export (weil es eben nicht geht...):


    Letzmaliges gab es nicht, die Konfiguration ist neu; Ich kann mich aber an 1.05 und Orgamax vor ein paar Jahren erinnern dass es da noch ging...

  • Danke, den habe ich schon gefunden, denke aber nicht dass es damit was zu tun hat, weil der slug zur virtuemart gehört und in der xtcommerce nicht drin ist, ich habe ihn aber mal eingebaut um zu sehen was passiert ("In der Not frisst der Teufel Fliegen").

    Leider ohne Erfolg.


    Die Entwicklung der Schnittstellen hinkt halt etwas...Ich könnte jetzt ja wider eine Schimpftirade losheulen angesichts der Webshopschnittstellen, aber das lass ich ma lieber - die armen Entwickler...

  • Moin,

    ich habe gerade keinen Zugriff auf die Schnittstelle, aber wenn ich das auf die Schnelle richtig verstanden habe, wird der Upload schon blockiert, wenn Artikel den gleichen Namen haben. Was ja bei Artikeln mit Varianten mal passieren kann.

    Wenn Du zum Test mal einen Artikel anlegst, den es sicher nicht im Shop gibt und dann mal schaust, ob es funktioniert.

  • Moin,

    wahrscheinlich hast Du das auch schon probiert, aber mir sind noch 2 Sachen eingefallen:
    1.In der Exportdatei steht:

    Code
    <MwStCode>1</MwStCode>
    <MwStValue>16</MwStValue>

    Hast Du in Modified die Umstellung auf die 16% schon durchgeführt? Es könnte zum Fehler und Abbruch führen, wenn Du eine anderen als im Shop hinterlegten Mehrwertsteuersatz exportierst.

    2. Hast Du mal versucht einen Artikel ohne Umlaute zu exportieren?

  • Einen Versuch war es wert.;)

    Darf ich fragen, warum Du überhaupt MeinBüro als Master für die Artikelanlage nehmen willst?

    Ich finde, es hat Nachteile, weil die Schnittstelle die Möglichkeiten des Shops nicht ausschöpft. Sobald eine 2. Sprache hinzukommt, wird der Export scheitern. Auch bei den Varianten bzw. Optionen, für die MB ohnehin schlecht gerüstet ist, wird es noch schwieriger.

  • Einen Versuch war es wert.;)

    Darf ich fragen, warum Du überhaupt MeinBüro als Master für die Artikelanlage nehmen willst?

    Ja, das frage ich mich mittlerweile auch schon.

    ;)Ich glaube das liegt an mir. Wenn ich zu wenig Probleme habe dann suche ich mir welche.....

    ;)Ausserdem habe ich immer noch die Hoffnung, dass durch diese Beiträge und die Tickets sich mal irgendwas bezüglich der Schnittstellen ändert. Leider bin ich kein Programmierer, sonst würde ich die individuelle Schnittstelle mal angehen.