Fehlermeldung

  • Moin,
    beim erstellen des Javascriptshop bekomme ich am ende immer diese Fehlermeldung:


    Shopsoftware
    Boolean expression expected, but `íd` found at line 1, column 28 - Native error: 30066



    :?:


    Kann mir jemand erzählen was das zu bedeuten hat.
    Benutze WWS 2.92

  • Jepp, Volltreffer.
    Das gehört zu den Dingern, die ich auch noch lösen will. :roll:


    Es hängt mit dem Artikelimport zusammen und betrifft nicht alle Artikel. Der Shop wird übrigens trotzdem erstellt.


    Ob in allen Punkten 100% richtig habe ich noch nicht kontrolliert.


    Ich habe dass Problem soweit eingekreist, dass es wahrscheinlich mit den Warengruppen zusammenhängt.
    Ich habe Artikel im Shop direkt angelegt ohne zu importieren und die Meldung kam nicht.
    Ich habe importiert und alle Artikel bis auf ein paar gelöscht bis ich einen definieren konnte, bei dem der Fehler wieder auftrat.
    Diesen habe ich im WK geändert (WGR) und schwups . . .es ging.
    weiter bin ich noch nicht. Bin noch am testen.


    also@ Kleines Helferlein


      HIIILFE !!!


    Der Anfang war sooo schön.
    Könnten wir eine Zuordnungstabelle der Felder bekommen ? Damit wir wissen, was exakt an Inhalten im WK zum Shop geschickt wird.


    Das würde erstens helfen, möglichst wenig im Shop nachbearbeiten zu müssen,
    und zweitens die Fehlerquelle zu finden und evtl. zu umschiffen.
    Da werden anscheinend auch zwei vorgesehen Felder nicht übergeben.

  • Moin,
    habe dir (kleines Helferlein) mal eine Backupdatei gesendet (pn), normalerweise würde ich den Fehler ja selber suchen, da ich aber zur Zeit ganz wenig Zeit habe entschuldige ich mich dafür, daß ich warscheinlich selbst einen Fehler verursacht habe und den nicht wieder weg bekomme. :cry:

  • Ich würd ja auch was schicken,
    aber jetzt habe ich das Anmeldeproblem, was overkiller auch hatte. :?


    Also permanent FEHLER 002 bei der Import-Anmeldung.
    Kleiner Hinweis: wenn ich die Fehlermeldung nicht wegklicke meldet sich WK,

    Zitat

    Diese Instanz von Kaufmann ist zur Zeit als SERVER aktiv und die
    nachfolgenden Benutzer haben noch eine aktive Verbindung:
    <unbekannt> auf <unbekannt>: Mandant <unbekannt>


    Das einzige, was sich bei mir geändert hat, ist ein Update des WK auf Version 8.97 nach Empfehlung der Hotline.
    Es liegt aber sicherlich nicht an der Version des WK, da bei overkiller vorher war und bei mir auh unter bestimmten Konstellationen auftauchte.
    Jetzt geht nichts mehr, ega was ich mache. :evil:


    Nur den WK habe ich noch nicht neu installiert, will das aber auch vermeiden.

  • Moin,
    gut zu lesen das man den WK am besten nicht Updaten sollte :roll: .
    Mit der Meldung die du hast chris, bedeutet es eigentlich, daß ein Datentransfer zwischne dem WK und WWS stattfindet.
    Am besten brichste die vorgänge im Task Manager irgendwann ab, wenn nichts mehr geht.

  • Klar, die Meldung bedeutet, dass der Webshop eine Verbindung zum WK hat.
    Allerdings sollte da dann ja wohl nicht stehen:
    "<unbekannt> auf <unbekannt>: Mandant <unbekannt>"
    da der Webshop sich eigentlich mit einer Identifikation und Anmeldedaten zu erkennen gibt.
    Scheinbar kommen die Anmeldedaten nicht richtig über.


    Ich bin mir sicher, das es nicht an der neuen Version des WK liegt, da du bei der alten dasselbe Problem
    hattest. . . . .bis zur kompletten Neuinstallation.


    kleines Helferlein :
    Ich schick das backup per mail.

  • Hm... welche WISO Kaufmann Version setzt ihr aktuell in Zusammenhang mit dem WISO WebShop ein?


    Ich prüfe dies aktuell, aber drängt nicht, hier muss ich einige Informationen zusammentragen und mich mit einigen Leuten an den Tisch setzen. Das dauert vielleicht ein paar Tage. Ist aber weder vergessen noch verdrängt. :wink:

  • Seit ein paar Tagen Kaufmann 2007 - 7.0.897


    Während der ganzen Tests und Problemchen Kaufmann 2007 - 7.0.871.


    So kleine Zwischenergebnisse wären interessant zu hören.


    Wenn's geht auch eine Info, welches Feld vom WK in welchem Feld des Webshop erscheinen soll.


    Für die letztere Info braucht's ja nicht so viele Leute an einem Tisch :wink: :lol:

  • Hat er doch gesagt (siehe oben), dass die sich mit einigen Leuten an einen Tisch setzen müssen.
    Ich hatte meine Testdaten ja auch geschickt und hoffe......


    Wobei....
    die Info, welches Feld vom WK in welchem Feld des Webshop erscheinen soll, hätte ich auch gern vorab.
    Dann könnte ich wenigstens einiges mehr vorbereiten !!!


    Übrigens, meine Anmeldung funktioniert wieder, nachdem ich WK in der Version 871 wieder reinstalliert habe.

  • Moin Leute,
    jetzt ist bei mir die Scheiße hier am Dampfen,
    gerade ist mir aufgefallen das die Kunden bei mir nichts über den Online Shop bestellen können. es kommt immer diese Fehlermeldung am ende einer bestellung:


    Warning: fopen(database/orderm.csv): failed to open stream: No such file or directory in /web/pages/mailer.php on line 168


    Warning: fwrite(): supplied argument is not a valid stream resource in /web/pages/mailer.php on line 169


    Warning: fclose(): supplied argument is not a valid stream resource in /web/pages/mailer.php on line 170


    Warning: fopen(database/orderd.csv): failed to open stream: No such file or directory in /web/pages/mailer.php on line 174


    Warning: fwrite(): supplied argument is not a valid stream resource in /web/pages/mailer.php on line 175


    Warning: fclose(): supplied argument is not a valid stream resource in /web/pages/mailer.php on line 176


    Warning: file(database/orderm.csv): failed to open stream: No such file or directory in /web/pages/mailer.php on line 179


    Warning: file(database/orderd.csv): failed to open stream: No such file or directory in /web/pages/mailer.php on line 182


    Warning: fopen(database/orderm.csv): failed to open stream: No such file or directory in /web/pages/mailer.php on line 291


    Warning: fwrite(): supplied argument is not a valid stream resource in /web/pages/mailer.php on line 292


    Warning: fclose(): supplied argument is not a valid stream resource in /web/pages/mailer.php on line 293


    Warning: fopen(database/orderd.csv): failed to open stream: No such file or directory in /web/pages/mailer.php on line 295


    Warning: fwrite(): supplied argument is not a valid stream resource in /web/pages/mailer.php on line 317


    Warning: fclose(): supplied argument is not a valid stream resource in /web/pages/mailer.php on line 320
    No recipient addresses found in header No recipient addresses found in header
    Vielen Dank für Ihre Bestellung!


    Sie sollten in wenigen Augenblicken eine Email erhalten, in welcher noch einmal alle Daten aufgelistet sind.



    Hat dies etwa etwas mit dem ersten Post den ich hier ins Thema reingegeben habe etwas zu tun???



    Über eine schnelle antwort wäre ich dankbar

  • hab ich grad auch mal getestet. Bei mir in meiner "Testumgebung online" ist das ähnlich.


    nur die"Warning: fopen" Fehler tauchen bei mir nicht auf.


    Bei der Bestellung erhält keiner ne Mail.
    Die Seite zum Ausdrucken für den Kunden taucht nicht mehr auf.
    Der Warenkorb leert sich nicht nach der Bestellung,
    sondern die gesamte Bestellung bleibt vollkommen erhalten. . .


    Das ist jetzt wohl ein Thema , welches auf Priorität 1 gesetzt werden sollte.
    Jetzt ist gar keine Funktionalität mehr gegeben.


    Ich habe ja GottseiDank noch einen Bereich mit einem Alten Shop stehen.


    So wie ich gehört habe ist der Fehler auch bekannt und in "Reparatur". Vielleicht macht es Sinn vorerst 2.90 wieder zu nutzen, damit überhaupt etwas geht.

  • Ich überbrücke das gerade mit Trick 17.


    Das ganze .\Webshop2 Verzeichnis kopiert in .\webshop2a.


    Webshop2 deinstalliert und neu installiert bis 2.90


    das Programm unter \webshop2a nutze ich jetzt zum import aus WK kopiere die data.abs rüber zum 2.90er und erstelle meinen Shop.


    Die erste Testserie funzt prima. Ich teste den Rest noch aus.


    Ist zwar ein bisschen durch die Brust ins Auge, aber es tut's.


    Anscheinend ist an der Datenstruktur der data.abs nichts geändert worden, so dass sie für beide Versionen eingesetzt werden kann.


    Ich nehme an, dass ein paar Verbesserungen, so wie die doppelte email-eingabe bei der Bestellung u.ä. das chaos ausgelöst haben.


    Der Import in die Datenbank scheint einwandfrei, da die Datenbank mit den importierten WK-Daten bei 2.92 nicht funktioniert, bei 2.90 jedoch top.