Import aus individuellem Webshop in WISO Mein Büro mit Modul Webselling funktioniert nicht

  • Hallo,


    ich programmiere für einen Kunden die Schnittstelle für seinen individuellen Webshop, um die Bestellvorgänge in WISO Mein Büro mit dem Modul "Webselling" zu übertragen. Leider funktioniert der Import überhaupt nicht. Ich habe eine sehr vereinfachte Schnittstelle eingerichtet, die bei Aufruf nur
    eine Fehlermeldung mittels xml_error_ausgeben soll:


    function starten(){
    mail("MAILADRESSE","Test MB-Schnittstelle","..."); /* MAILADRESSE ist natürlich meine Mailadresse */


    die(xml_error_ausgeben("TEST Error", "FILE","FUNCTION","LINE")); /* genau so */
    }


    Alle anderen Funktionen (daten_holen, status_aendern, etc.) sind vorhanden aber leer.


    Soweit ich das verstanden haben, sollte meine Fehlermeldung auch in WISO Mein Büro angezeigt werden. Wenn ich im WISO MB die Bestellungen abrufe, erhalte ich nur die Fehlermeldung "Die vom Webshop übertragenen Daten konnten nicht verarbeitet werden". Die mit mail() ausgelöste Mail erhalte ich, die Verbindung steht also.


    Laut der mitgelieferten Dokumentation "MB Webshop-Schnittstelle einrichten und Problembehandlung.pdf" (letzte Seite) soll ich mich in diesem Fall an den Support
    wenden: „Bei dieser Fehlermeldung ist in den meisten Fällen die XML Datei im Verzeichnis “...\Mein Büro\Webshop\ImportFiles“ defekt oder leer. Anschließend kann Mein Büro die falschen Daten nicht weiter verarbeitenund keine Webshop-Bestellung heraus generieren. Bitte wenden Sie sich an den Support.“.


    Tja, das Verzeichnis “...\Mein Büro \Webshop\ImportFiles“ existiert auf meinem lokalen PC gar nicht (oder ich habe an der falschen Stelle gesucht) und der Support schreibt u. a. "Es ist so, dass individuell angepasste Systeme nicht unserseits supportet werden. Bei individuell angepassten System haben wir keine Möglichkeit Ihnen bei der Schnittstellen-Programmierung zu helfen, da sind externe Entwickler auf sich alleine gestellt.".


    Wer kann mir bitte helfen?


    Vielen Dank im Voraus!


    Gruß,
    René Carl

  • Hi,


    ich muss leider nochmal stören ;-)


    Das Abholen der Bestellungen funktioniert an sich schon, aber die so importierte XML-Datei im oben genannten Import-Ordner enthält kein XML. Daher erhalte ich immer noch die Fehlermeldung "Die vom Webshop übertragenen Daten konnten nicht verarbeitet werden". Der XML-Code scheint irgendwie verschlüsselt zu sein, also statt <xml>code</xml> nur "JD6DhdnhghDIxyLD387d6...". Soll die Import-Datei verschlüsselt sein? Und am Anfang der Datei befindet sich eine Leerzeile. Kann diese Leerzeile auch Probleme verursachen?


    PHP Version ist 5.2.17