Update von Version 16.0.1.100 auf 16.0.1.101 wird nicht durchgeführt

  • Hallo zusammen,


    habe ein Problem mit dem Online-Update von Version 16.0.1.100 auf 16.0.1.101. Update wird mir über das Programm angeboten. Download läuft bis zur MV2017.exe. Dann bleibt der Balken kurz vor Schluß eine Weile stehen. Dann verschwindet das Update-Fenster wieder und Programm springt auf Startseite von Mein Verein wieder zurück. Nichts passiert. Betriebssystem siehe Anhang. Kann mir da vielleicht jemand helfen? Herzlichen Dank schon mal vorab.

  • Danke. Ordner in Programme "Mein Verein" existiert schon. Umbenannt auf "_alt". Anschließend kommt Fehler wie im Anhang. Ich habe ignoriert, weil wiederholen nichts gebracht hat. Ist das jetzt ein Problem? Weil nach Ende der Installation Mein Verein nicht startet.....

  • Doch nicht alles gut. Jetzt habe ich vermutlich ein größeres Problem. Nach Rückspielen der Datensicherung kommt Meldung:

    Es wird mir auch nicht die alte Datenbank mit dem Namen "RSC Köngen e. V." angezeigt, sondern nur "Demodaten", "Mein Verein" und "Mein Verein 2". Zudem weiß ich das Passwort nicht mehr. Gibt's da noch eine Chance?

  • Danke. Ordner in Programme "Mein Verein" existiert schon. Umbenannt auf "_alt". Anschließend kommt Fehler wie im Anhang. Ich habe ignoriert, weil wiederholen nichts gebracht hat. Ist das jetzt ein Problem? Weil nach Ende der Installation Mein Verein nicht startet.....

    Diese Tatsache alleine macht mich schon stutzig. Das kann eigentlich nur kommen, wenn er versucht das Programm zu installieren, weil er in der Registry (HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall) keinen Eintrag für das Programm findet. Jedes Programm was in Windows installiert wird, ist dort mit einem Key und den Pfadangaben hinterlegt. Kann mir also beispielsweise Cleantools vorstellen, die da gewütet haben, wo sie nicht sollen. Ich bin eh kein Fan von Cleantools. Windows bringt schon alles mit, völlig unnötig.


    Wenn also der Installer da keinen Eintrag findet, wird er das Programm neu installieren wollen. Und da die Ordner aber ja noch da sind, findet er diese und meldet das auch. Wenn da bei der Installation also schon Abfragen kommen, weil was nicht überschrieben werden kann, stimmt da schon was nicht.


    Die Meldung, dass keine Versionsnummer enthalten ist, würde ich nicht zwingend wörtlich nehmen oder zumindest nicht auf die richtige Vereinsdatenbank beziehen. Ich vermute eher, dass in der Datensicherung immer die Demodatenbank mitgeschleppt wurde und die ein Problem hat, bzw. beschädigt ist.


    Aber du sagst ja auch, dass du beim Start die Abfrage kriegst, welchen Verein zu starten. Wähle dann dort "Mein Verein" aus. "Mein Verein 1" ist noch immer in der Programmroutine enthalten, wurde aber nie freigeschaltet. War eigentlich mal geplant, dass man einen weiteren Verein verwalten kann. Die Datenbank ist nämlich da.


    Die Tatsache aber, dass beim Anmeldemenü nach einem simplen Update nicht der gewohnte name dort steht, lässt mich auch vermuten, dass deine Datenbank überschrieben wurde, eben wegen oben erwähntem Umstand, dass scheinbar eine Neuinstallation versucht wurde vom Installer, weil er es ja nicht anders wusste.


    Was ich auch glaube:
    Wenn das Programm früher die Datenbank nicht gefunden hat, kam die Meldung, dass man die Datenbank nur von einem Rechner aus starten kann. Unsinnig eigentlich, weil er fand die Datenbank einfach nicht. Die Meldung war ohnehin schon seit längerem obsolet. Nun scheint vielleicht diese Meldung dafür zu erscheinen. Man sollte diese fehlermeldungen überhaupt mal überarbeiten, dass die Wortlaut auch genau auf den Fehler hinweist. Das ist eben nicht immer der Fall.


    Der Pfad zu den Datenbanken ist in der MV.ini zu finden, die im Programmverzeichnis liegt.


    Ich würde das Programm deinstallieren, die Ordner löschen, sofern was übrigbleibt und dann ganz neu installieren mit der MV2017 Datei. Dann Datensicherung einspielen.


    Anleitung:
    https://www.buhl.de/faqs.html?article=1090

  • Herzlichen Dank für die Anweisungen. Neuinstallation ohne Problem erfolgt. Nur beim Wiederherstellen der Daten trat folgender Fehler auf :( :


    Mein Verein Restore
    Fehlerprotokoll vom 20.11.2016 11:45:22:
    --------------------------------------------------------------


    Schritt 1: Entpacken der Dateien in temporäres Verzeichnis


    Bei der Durchführung des ersten Schrittes sind keine Fehler aufgetreten.



    Schritt 2: Wiederherstellen der Datenbanken


    Die Datenbank Demodaten (MANDANT 0) konnte nicht erzeugt werden
    (gbak: ERROR:could not drop database Demodaten (database might be in use)
    gbak:Exiting before completion due to errors)


    Bei der Durchführung des zweiten Schrittes ist ein Fehler aufgetreten.



    Schritt 3: Wiederherstellen der Dateien



    Druckvorlagen:
    --------------
    Abschnitt fehlerfrei durchgeführt



    Gespeicherte Dokumente:
    -----------------------
    Abschnitt fehlerfrei durchgeführt



    Rechnungsarchiv:
    -----------------------
    Abschnitt fehlerfrei durchgeführt



    Bei der Durchführung des dritten Schrittes sind keine Fehler aufgetreten.




    --------------------------------------------------------------


    Wenn ich dann auf die Datenbank Mein Verein über "Datei==> Mein Verein" umschalten möchte, kommt Meldung:

    :(

  • Bei mir läuft das Update auch nicht.
    Da ich das E-Porto nicht nutze, laß ich es sein.


    Hast Du es mal mit OPERATOR (Name), operator (Kennwort) versucht?


    Wenn es für Dich wichtig ist, wende dich an den Support. Der ist vom Hersteller und kostet Dich nichts.
    Herumprobieren kann die Sache höchstens verschlimmbessern (scheint bei Dir schon geschehen zu sein, aber Du hast ja Deine Datensicherung). Wenn die fehlerhaft ist, können sie die beim Support meistens reparieren, wenn nur die Demo defekt ist, ganz bestimmt.


    Also mein Tipp: 02735 90 96 20 anrufen.

  • Die Datenbank Demodaten (MANDANT 0) konnte nicht erzeugt werden


    (gbak: ERROR:could not drop database Demodaten (database might be in use)
    gbak:Exiting before completion due to errors)

    Alles gut. Mandant 0 sind nur die Demodaten und die kannst du sogar zur Not wiederherunterladen oder durch eine leere ersetzen. War also scheinbar wirklich defekt.
    Bei der Anmeldemaske mal operatoranmeldung eingeben. Ansonsten hast du das mal geändert, dann solltest du die Anmeldung wissen. Wenn nicht, kann der Support die Anmeldedaten in der Datenbank wieder zurücksetzen.