Probleme mit Anlage von Artikel-Sets

  • Es gibt so kleine Unannehmlichkeiten im Programm über die man sich immer wieder ärgert, die aber zu klein sind, um deswegen den Aufwand eines Tickets zu betreiben. Häufig kennt man Workarounds, aber trotzdem nervt es jedes Mal wieder neu, weil es Zeit kostet oder fehleranfällig ist. Ich hatte überlegt, einen Sammelthread aufzumachen, in der jeder mal kleine lästige Fehler oder merkwürdige Bedienkonzepte nennt, die möglicherweise recht einfach zu ändern wären, aber es nie auf die Updateliste schaffen, weil andere Änderungen wichtiger sind. Bei denen man aber davon ausgehen kann, dass sie längst weg wären, würden die Programmierer selbst mit dem Programm arbeiten. Manchmal kann ich mir Fehler auch nur damit erklären, dass der Punkt nach der Programmierung nie neutral getestet wurde. Vielleicht liest doch jemand von Buhl mit und nimmt ein paar Kleinigkeiten beim nächsten Update mit. Die Hoffnung stirbt zuletzt. :thumbsup:


    Da ich mir nicht sicher bin, ob so ein Sammelthread wirklich ein gute Idee ist, habe ich das Thema (zumindest vorerst) nur auf Artikel-Sets bezogen. Ich habe mich jetzt mal etwas intensiver damit beschäftigt, d.h. habe welche angelegt, und wundere mich über die Art der Umsetzung.


    Der wichtigste Punkt ist der, dass völlig programmuntypisch die Sets nicht über einen eigenen Menüpunkt anzulegen/bearbeitbar sind. Weder als eigener Menüpunkt (wo auch die Artikel-Bundles sind) noch in den Kleinstammdaten oder anderen Einstellungen ist der Punkt erreichbar. Man kommt nur über das Anlegen oder Öffnen eines Vorganges dorthin.


    Also gehe ich in einen Vorgang und stelle über den in der Hilfe genannten Weg (Button "weitere Funktionen") fest, dass man dort keine schon bestehenden Artikelsets findet. Man kann dort nur in völliger Leere Sets anlegen und hofft, dass man sie nicht schon mal angelegt hat. Doch glücklicherweise gibt es auch den Button "Artikelset" über den man diese Funktion komplett nutzen kann. Der Button ist eindeutig benannt und sofort sichtbar - ein klarer Pluspunkt an dieser Stelle.


    Jetzt kommt das Unverständliche für mich. Möchte ich ein Set anlegen oder bearbeiten, so speichert das Programm das auf Dauer nur ab, wenn ich das Set im geöffneten Vorgang übernehme und den Vorgang dann auch abspeichere. Es ist nicht möglich, sich mal hinzusetzen und Sets so wie alle anderen Stammdaten anzulegen mit der Absicht sie später zu verwenden. Sie sind beim nächsten Vorgang nur vorhanden, wenn ich sie jetzt verwende. Natürlich kann ich den nicht benötigten Vorgang anschließend löschen, trotzdem frage ich mich, ob das je getestet wurde.


    Und jetzt kommt der Bug, der nervt. Möchte ich beim "Artikel hinzufügen" Artikel filtern um sie leichter zu finden, wird immer der erste Artikel mitmarkiert und auch wenn er anschließend bei der Filterung in der Ansicht verschwindet bleibt er markiert und wird stets mit hinzugefügt. Blöd wenn einem das nicht auffällt. Also löscht man nach jeder Filterung auf's Neue diesen Artikel aus dem Set.


    Ich nehme natürlich alles zurück, wenn ich die einzige Installation habe mit den genannten Eigenheiten.

  • Du hast recht, das ist total nervig.
    wir nutzen zb. die Bundels.
    Jetzt kann man ja endlich eine Variable nutzen um die einzelnen Artikeltexte einzublenden, vorher hat man immer alles doppelt geschrieben.
    Trotzdem wieder nicht fertig gedacht. Wir nutzen Individuelle Felder um den Lagerplatz und Sondertext im Artikel zu haben.
    diese Variablen werden nicht im Bundle eingeblendet, bzw ausgeblendet. Also entweder Variable im Artikel, dafür keine Variable im Bundle, oder alles als Text im Artikel, dafür keine Spalte in der Übersicht. Buhl hat dafür einfach kein Auge... Die sollten ihre Software mal Betatesten damit Unzulänglichkeiten auffallen.

  • Thema: Artikel werden fälschlich angehakt bei Anklicken der Filterzeile

    Und jetzt kommt der Bug, der nervt. Möchte ich beim "Artikel hinzufügen" Artikel filtern um sie leichter zu finden, wird immer der erste Artikel mitmarkiert und auch wenn er anschließend bei der Filterung in der Ansicht verschwindet bleibt er markiert und wird stets mit hinzugefügt. Blöd wenn einem das nicht auffällt. Also löscht man nach jeder Filterung auf's Neue diesen Artikel aus dem Set.

    Ich kannte das Problem bereits mit der Einführung dieses Features. Habe es reklamiert und bei mir ist es seitdem behoben und tritt nicht mehr in MB auf.

  • Thema Artikelset unabhängig von einem geöffneten Vorgang anlegen:

    Jetzt kommt das Unverständliche für mich. Möchte ich ein Set anlegen oder bearbeiten, so speichert das Programm das auf Dauer nur ab, wenn ich das Set im geöffneten Vorgang übernehme und den Vorgang dann auch abspeichere. Es ist nicht möglich, sich mal hinzusetzen und Sets so wie alle anderen Stammdaten anzulegen mit der Absicht sie später zu verwenden. Sie sind beim nächsten Vorgang nur vorhanden, wenn ich sie jetzt verwende. Natürlich kann ich den nicht benötigten Vorgang anschließend löschen, trotzdem frage ich mich, ob das je getestet wurde.

    In der Tat werden Artikset nicht im Artikelstamm angelegt, sondern über einen offenen leeren Vorgang.


  • Und jetzt kommt der Bug, der nervt. Möchte ich beim "Artikel hinzufügen" Artikel filtern um sie leichter zu finden, wird immer der erste Artikel mitmarkiert und auch wenn er anschließend bei der Filterung in der Ansicht verschwindet bleibt er markiert und wird stets mit hinzugefügt. Blöd wenn einem das nicht auffällt. Also löscht man nach jeder Filterung auf's Neue diesen Artikel aus dem Set.

    Habe mir das jetzt nochmal genauer angeschaut wo der Fehler sitzt. Er besteht Fehler weiterhin und ist jetzt reproduzierbar HIER