Probleme mit Vorgangsseitenlayout

  • Hallo,
    ich habe gerade einen Wechsel von WK2006 auf WK2007 vollzogen. Habe auch die MwSt Umstellung ohne Probleme durchlaufen können. Nur jetzt möchte ich eine Rechnung drucken, egal ob auf Bildschirm oder einem echten Drucker, es kommt immer eine Fehlermeldung, dass das Vorgangsseitenlayout "Positionen" nicht gefunden werden kann. Ich habe einen Screenshot der Meldung angehangen. Über Listen->Vorgänge->Vorg. verwalten->Vorgangsseiten habe ich aber in dem Feld "mit Positionen" einmal "Position LS" und einmal "Positionen" stehen. Wie kann ich das Problem beheben??

  • Hallo,


    habe dasselbe Problem und kann seit 2007 keine Vorgänge mehr ausdrucken. Der WISO Kaufmann 2007 Business Server läuft auf einem Windows 2003 Server und ich kann dort die Druckererweiterung nicht auf Version 10.x updaten. Kann es damit zusammen hängen?


    Danke schonmal für Hilfe!

  • "KOFAST" schrieb:

    Hallo,


    habe dasselbe Problem und kann seit 2007 keine Vorgänge mehr ausdrucken. Der WISO Kaufmann 2007 Business Server läuft auf einem Windows 2003 Server und ich kann dort die Druckererweiterung nicht auf Version 10.x updaten. Kann es damit zusammen hängen?


    Danke schonmal für Hilfe!


    Hallo Kofast und matze,
    vielleicht, aber viel wichtiger ist zu pruefen ob dieses Layout (achtet auf die genau Schreibweise mit den Klammern) auch vorhanden ist.


    Bei Matze fehlen diese offenschtlich, daher den Vorgaengen die "geanderten" Layouts zuweisen.


    Auf Version 10 sollte auf jeden Fall eine update durchgefuehrt werden.


    Ihr wisst ja, wie es geht. DB-Manager > Layout > update


  • Das update hatte ich ganz am Anfang direkt durchgeführt, sonst wäre eine fehlerfreie Umstellung auf die neue mwst gar nicht möglich gewesen. sagte wenigstens der Testlauf. Ich hatte zumindest das Glück am Tag vorher einen richtigen Testlauf auf einem anderen PC gemacht zu haben. Gleiche Einstellungen, Daten usw.. Dort hatte ich das Problem auch, dann habe ich einfach das Positionen Layout (das was angeblich nicht da ist) kopiert und danach war der Fehler weg. Habe dann jetzt einfach die Fehlerhafte IOLayouts.bpd auf meinem aktiven PC durch die vom Testsystem ersetzt (die Dateigrößen waren übrigends bis aufs byte gleich) und tada..bis jetzt scheint es so zu klappen wie es sollte. Trotzdem würde mich mal interessieren wie ich das Problem gelöst bekommen hätte.

  • Hallo,
    ich bin neu hier und habe das gleiche druckproblem. leider versteh ich die lösungswege nicht ganz.
    kann man mir mal erklären wie das abstellen des fehlers geht?
    habe die 2007 version erst frisch ausn netz gezogen.


    gruß

  • Habe das gleiche Problem.
    Bei mir kommt beim Rechnungsdruck dann folgende Meldung:
    Im Layout "Positionen" wurden folgende Umsatzsteuervariablen nicht gefunden:
    4 Mehrwertsteuer 19% (AktVog.GPreisM17[Nt/St/Bt])
    Da diese Steuerwerte im Beleg "2007001" benutzt wurden, erfolgt hochwahrscheinlich eine fehlerbehaftete Auweisung!
    Zu Ihrer Information:
    Sie sollten in jedem Fall den ausgegebenen Beleg auf diese Sachlage hin prüfen, um die Richtigkeit des Belegs zu gewährleisten.
    Gegebenenfalls ist das obenbenannte Layout entsprechend zu erweitern, so das die Steuerwerte (Netto/Steuer/Brutto) ausgewiesen werden.

    Wenn ich dann lese, was in den Layouts bzw. Positionslisten alles geändert werden soll(wobei die Beschreibung für Laien absolut ungenügend ist, bedingt durch den unübersichtlichen Aufbau) bekomme ich einen Hals.


    Wenn ich Programmierer hätte werden wollen, hätte ich das gemacht.


    Gibt es keine neuen Layouts und Positionslisten, die diese Werte schon beinhalten???
    Diese könnte man doch dann den eigenen Bedürfnissen anpassen (Logo usw.)


    Gruß
    Fipps

  • @ all


    anbei die Datei fuer Positionen. Auf den Desktop herunterladen und entpacken.


    WisoKaufmann oeffen. > Modul Auftrag > Bearbeiten > Listen > Vorgaenge > Vorgaenge verwalten > Vorgangsseiten.
    Im neuen Fenster "Vorgangsseiten" die entpackte Datei vom Desktop mit drag&drop in das Fenster rechts unter "mit Positionen" ziehen.
    Das wars.


    Edit: Datei entfernt 20.11.07

  • also da muss ich mal fipps recht geben. dachte die wollen hier was verkaufen und keine programmierer rannzüchten. grrrrrrrrrrrrrrr


    modul auftrag ..... prima und wo ist denn das in den programm????


    :twisted: :twisted: :twisted: :twisted: :twisted: :twisted: :twisted:

  • "Fipps" schrieb:

    Erst mal ein Dank für die Hilfe.


    Das Problem besteht aber leider immer noch.


    Gruß
    Fipps


    Hallo Fipps,
    hast Du das neue Layout auch dem Vorgang "Rechnung I" zugeordnet?


    > Auftrag > Listen > Vorgaenge > Vorgaenge > Register Vorgang im rechten Fenster

  • Hallo Franco,
    um jetzt erst mal weitere Fehler auszuschließen:
    Was ist das "Modul" Auftrag beim Kaufmann 2007?


    Wie mache ich die Zuordnung der layouts?
    "Kopie von Rechnung I (ab 2007)" steht als Standard und unter den Vorgangsseiten steht die "Kopie von Positionen" (das war die ZIP-Datei) als Standard. Sonst sehe ich keine Zuordnung die ich einstellen kann.


    Gruß
    Fipps

  • ich glaube die Zuordnung habe ich jetzt gefunden.
    Bei einer Testrechnung kommt dann die Meldung:
    Im Layout "Kopie von Positionen" wurden folgende Umsatzsteuervariablen nicht gefunden:
    4 Mehrwertsteuer 19% (AktVog.GPreisM17[Nt/St/Bt])
    Da diese Steuerwerte im Beleg "2007001" benutzt wurden, erfolgt hochwahrscheinlich eine fehlerbehaftete Auweisung!
    Zu Ihrer Information:
    Sie sollten in jedem Fall den ausgegebenen Beleg auf diese Sachlage hin prüfen, um die Richtigkeit des Belegs zu gewährleisten.
    Gegebenenfalls ist das obenbenannte Layout entsprechend zu erweitern, so das die Steuerwerte (Netto/Steuer/Brutto) ausgewiesen werden.


    Gruß
    Fipps

  • Das ist ja zum Verzweifeln - kann denn keiner helfen?????????


    Ist die einizige Möglichkeit das Programm,samt Daten, in die Tonne zu kloppen????


    Kennt sonst einer ein vernünftiges, funktionstüchtiges Programm, mit dem man Rechnungen schreiben kann und den Umsatz/Roherlös feststellen kann. Für die Buchhaltung benutze ich eh etwas anderes.

  • Hallo Fipps,


    pass das Layout doch einfach an. So kompliziert ist das gar nicht wie es aussieht. Aber wieso steht da bei dir (AktVog.GPreisM17)? Das M17 habe ich in sämtlichen Formularen bei mir nicht gefunden. Sicher das es nicht M19 heissen müsste? Überprüf das mal.

  • Ja - das ist eine gute Frage:
    wieso steht da (AktVog.GPreisM17)?
    Das ist jetzt mit der runtergeladenen Datei von Franco.


    Ich sag ja - ich blicke jetzt überhaupt nicht mehr durch!
    Ich muss Rechnungen schreiben und es funktioniert nicht.


    Das Layout selber anzupassen kappiere ich nicht - ich finde die passenden Felder erst gar nicht (mit ändern und hinzufügen usw.).


    Gruß
    Fipps

  • Mal eine Anmerkung dazu:


    Was sich geänder hat, ist daß der Suffix der neuen Umsatzsteuer M19 heißen dürfte, und die alten Formulare verwenden diesen Suffix nicht
    (Der Suffix wird bei den Umsatzsteuersätzen angegeben)


    Also kopiert nicht einfach neue Formulare in Eure Programme, falls ihr eure Layouts angepaßt habt, sondern sucht einfach nach den Sätzen bei den Positionen, wo es M16 heißt, kopiert diese und fügt sie darunter ein, in den eingefügten ändert ihr noch die Zahl von 16 auf 19 und schon gehts wie gewohnt weiter.


    Neue Layouts von der Stange bedeutet, daß Eure ganzen händischen Änderungen in den Formularen weg sind, ist mir natürlich auch passiert, dann durfte ich nochmal von vorne beginnen


  • Hallo cdfcool,
    da hilft es immer, wenn Du Deine eigenen Layouts umbenennst und diese dann den Vorgangsarten zuordnest. Dann wird erst einmal nicht ueberschrieben.

  • Hallo,


    ich habe folgendes Problem:


    Der Kaufmann-Server ist auf einem Windows 2003 sbs installiert, parallel läuft auch der Exchange Server auf diesem Gerät.


    Wenn ich den Kaufman auf dem Server starte erhalte ich die hier bereits erwähnte Fehlermeldung mit der Druckererweiterung. Ein Drucken ist somit vom Server aus nicht möglich.
    Ich habe eine selbstgestaltete Rechnung, womit das Update an dieser Stelle nicht funktioniert. Wenn ich jetzt nach der Anleitung vorgehe habe ich 2 Probleme. 1. Ich kann das Update auf 10.x nicht vom Client aus machen und 2. auf dem Server kann ich das Update auf 10.x nicht machen, weil ich eine Fehler mit der Druckererweiterung erhalte.
    Die Software ist bereits neuinstalliert worden und auch auf einem anderen 2003er Server erhalte ich den gleichen Fehler.
    Da ich ein Ladengeschäft habe, bin ich derzeit recht geladen, denn ordentliche Rechnugnen kann ich nicht drucken und die Hotline kann mir auch nicht helfen. Aussage: Kaufen Sie das original Produkt (tausende von Euros) oder installieren sie auf einer XP Workstation.


    Es kann ja nun eigentlich nicht sein, das ich eine solche Aussage bekomme.


    Kann mir hier jemand helfen, wie ich diese SW sauber zum laufen bekomme?


    Danke.
    Mufadza