MG2010 Support verweigert Unterstüzung

  • (ich habe mehrere Rechner zu Hause)


    Greifst du von jedem dieser Rechner auf dieselbe Datenbank zu?


    Die ODBC Einstellungen sind nach wie vor die selben und auch die Fehlermeldungen erscheinen bei einem Doppelklick wieder.


    MG2010 ist eine 32-Bit Anwendung und greift daher auch explizit auf die 32-Bit Treiberversionen zu. Daher muss es nach meinem Verständnis auch fehlerfrei möglich sein mit der 32-Bit Version des ODBC-Datenquellenadministrator unter %windir%\SysWOW64\odbcad32.exe Einträge hinzuzufügen. Das scheint bei dir warum auch immer nicht zu funktionieren.


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

  • MG2010 ist eine 32-Bit Anwendung und greift daher auch explizit auf die 32-Bit Treiberversionen zu. Daher muss es nach meinem Verständnis auch fehlerfrei möglich sein mit der 32-Bit Version des ODBC-Datenquellenadministrator unter %windir%\SysWOW64\odbcad32.exe Einträge hinzuzufügen. Das scheint bei dir warum auch immer nicht zu funktionieren.


    Jepp, darüber sollte es funktionieren.


    Viele Grüße


    Sandro


    PS: Ich weiß auch warum du das HF1 nicht über das automatische Update angeboten bekommen hast - du hattest es bereits installiert (11.00.01.30 ist das Hotfix1) - insofern kann man das als Ursache ausschließen. (Danke an den Hinweisgeber ;) )

  • Hallo,
    ich verfolge diesen Thread seit Tagen mit großem Interesse: Ich bin sehr beeindruckt über die Mühe, die sich Sandro und Jürgen hier geben, um das Problem von Charkow in den Griff zu bekommen. Ihr Motiv? Inschutznahme des Supports? Aber ich denke es ist sicher auch der Ehrgeiz, das jetzt (gemeinsam) zu schaffen. Und wir können ja auch alle nur daraus lernen.


    Aber ich frage mich schon seit Tagen, warum installiert Charkow nicht einfach Windows 7 mal neu? Da scheint doch wirklich irgendwo der berühmte Wurm drin zu stecken, oder? Jetzt haben sie beide das ja vorgeschlagen, vielleicht sagt uns Charkow mal, warum er das nicht als erstes selbst getan hat?


    Nun mal zu seiner Bitte um Information: Ich habe auf meinem Rechner nicht sehr viel, eine TV-Karte (Terratec), Nuance für die PDF-Erstellung, Druckertreiber, Norton 360, ein paar weitere Utilities und ein paar Spiele (z.B. Anno 1404) und eben die nachgefragten Office-Anwendungen (allerdings nur MS Office 2003). Alles lief unter Vista 64 und jetzt unter Windows 7 (64bit) von Beginn an ohne ein Problem. Die gesuchten DAO-Programme habe ich aber nicht (zumindest findet die normale Suche nichts).


    Herzl. Gruss und viel Erfolg weiterhin. Ich könnte alle diese Dinge als "nur" - Anwender gar nicht umsetzen und staune nur, über das, was da bisher so vorgeschlagen und umgesetzt wurde. Ich weiß ja gar nicht was das alles so ist.


    Gruss Allzeit

    Windows 7 HE (64bit); 8 GB RAM; Intel (R) Core(TM)2 Quad CPU Q6600 2.40GHz; ATI Radeon HD 5770

  • Ich bin sehr beeindruckt über die Mühe, die sich Sandro und Jürgen hier geben, um das Problem von Charkow in den Griff zu bekommen. Ihr Motiv? Inschutznahme des Supports?


    Ich bin kein Mitarbeiter von Buhl und nehme daher auch niemanden von Buhl in Schutz. Das ist nicht der Anreiz, wobei ich absolut kein Verständnis dafür habe den Namen des Supporters in einem öffentlichen Forum und darüber hinaus noch im Zusammenhang mit Verweigerung einer Supportleistung zu nennen. Ich frage mich ob der Supporter hier um Einwilligung gebeten wurde!? Man stelle sich einmal vor, die Ursache liegt - wie vom Support vermutet - tatsächlich auf Betriebssystemebene. Dann ist der Hersteller des Betriebssystems der richtige Ansprechpartner. Der negative Eintrag nach den Suchwörtern "MG2010 Support" in den Google-Ergebnissen jedoch bleibt. Ziemlich ärgerlich für Buhl und den betroffenen Mitarbeiter, nicht wahr?


    Aber ich frage mich schon seit Tagen, warum installiert Charkow nicht einfach Windows 7 mal neu?


    Nach meiner Einschätzung könnte dies das Problem zu 99,9% lösen, leider jedoch nicht zwangsläufig. Es gibt viele Gründe, warum sich eine Datenbank merkwürdig verhält. Einige davon sind im Abschnitt "Typische Ursachen für beschädigte .mdb-Dateien" im Microsofts Artikel KB209137 erläutert. Ist auch für einen Laien verständlich. ;)


    Ich könnte alle diese Dinge als "nur" - Anwender gar nicht umsetzen und staune nur, über das, was da bisher so vorgeschlagen und umgesetzt wurde. Ich weiß ja gar nicht was das alles so ist.


    Aus der Ferne ist es in der Tat nicht leicht das technische Know-how seines Gegenüber einzuschätzen. Daher tasten wir uns da vorsichtig genug heran. Den Antworten von Charkow entnehme ich dass er weiß was er tut. Dementsprechend fallen meine Antworten aus.


    Und hier die Auflösung:
    Uns treibt - wie du richtig erkannt hast - der Ehrgeiz ein schwieriges Problem zu lösen. Nix anderes. ;)


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Jürgen ()

  • Hallo zusammen,


    erst einmal die Antwort nach meinem Background; ich bin seit Jahren in der IT in einem großen Unternehmen tätig, war selbst auch mehrere Jahre als 2nd Level Support für Client Server Anwendungen, die in unserem Entwicklungsbereich verwendet wurden tätig. In unserer Firma wird sehr viel Embedded Software hergestellt, die in unseren Produkten eingesetzt wird (keine Windows Anwendungen). Ich habe Informatik studiert und bin leidenschaftlicher Computeranwender und arbeite bereits seit Jahren mit Windows, daher habe ich auch durchaus gutes allgemeines Windows Know-how, kenne allerdings nicht alle Spezialitäten.


    Warum ich mich an dieses Forum wandte ist die Tatsache, dass ich mich vom Mein Geld 2010 Support im Stich gelassen fühle. Ich erwähnte bereits einige male warum, sage es jetzt noch einmal explizit.


    Vom Support erwarte ich grundsätzlich folgende Fragen:


    a) Welche Programmversion wird verwendet (damit meine die Release- oder Versionsnummer, also hier z.B. 11.00.xx)


    b) Welches Betriebssystem wird genutzt


    c) Schicken Sie uns bitte folgendes Analyse File zu


    Diese Fragen wurden immer als erste gestellt, sobald ich mich bei Anwendungsproblemen an den Hersteller wenden mußte - im Beruf, als auch im Privatleben. Selbst bei Unzulänglichkeiten des Betriebssystems, die für eine Betriebsstörung der Software verantwortlich waren, wurde Support geleistet.


    Ich weiß auch nicht genau, was ich von diesem Forum erwartet habe. Vielleicht dachte ich, daß ein Entwickler von Buhl mal in die Foren reinschaut und weiterhilft.


    Jürgen ,
    die Datei %windir%\SysWOW64\odbcad32.exe kann ich starten, kann damit auch eine Testdatenbank.mdb erstellen; diese habe ich umbenannt in Testdatenbank.mgd und in den Mein Geld Datenbankordner verschoben. Anschließend wollte ich die Thematik mit den Universal Data Link File angehen. Eine Textdatei erstellen und in .udl umbenennen ist einfach. Schwieriger ist es allerdings den Data Link herzustellen. Ein Doppelklick öffnet leider den 64bit UDL Ersteller und der kennt keinen MS Jet Ole DB Provider, da es diesen nicht in der 64bit Version gibt. Im Internet nachgesehen und herausgefunden, dass das 32bit Pendant folgendermaßen aufgerufen werden muss:


    c:\Windows\syswow64\rundll32.exe "C:\Program Files (x86)\Common Files\System\Ole DB\oledb32.dll",OpenDSLFile C:\test.udl


    Die Verbindung zur Datei Testdatenbank.mgd brachte die Meldung: Das Testen der Verbindung war erfolgreich.


    Ich habe MG 2010 nur auf einem Rechner installiert, dort allerdings 2mal, wie berichtet. Nur von diesen Installationen wird auf die DBs zugegriffen und auch nie gleichzeitig.


    sandro ,
    leider ist Virtual PC nicht in der Lage ein 64bit OS zu hosten, VMWare möchte ich mir nicht antun.


    Ich habe Windows 7 vor kurzem auf diesen Rechner installiert und außer MG 2010 habe ich noch keine Software deinstalliert und neuinstalliert. Ich bin nicht der Ansicht, daß mein Betriebssystem nicht richtig funktioniert. Alle anderen Programme funktionieren einwandfrei.


    MG 2010 war schon immer in der Lage eine neue DB auf meinem Rechner zu erzeugen, hat allerdings bei bestimmten Situationen Datenbanken zerstört. Dies passierte immer dann, wenn ich das Programm zwangsweise beenden mußte was meistens der Fall war, nachdem ich meine Konten aktualisieren wollten. Der Dialog "Aktive Aufträge senden" wurde nicht eingeblendet und das Programm hat dann nicht mehr reagiert.


    Das Update, das mir angeboten wurde habe ich nicht abgelehnt - ich habe es einmal durchgeführt, es hieß aber immer nur, dass die LetsTrade Komponente aktualisiert wird. Und ob ihr mir es glaubt oder nicht, war dann nach einem Neustart von MG 2010 der Tabulator "Startseite" auf der rechten Seite oben links verschwunden. Die einzige Möglichkeit ihn wieder zu sehen war entweder die DB vom Vortag herzuholen, oder ihn in den Menüs irgendwo aufzurufen. Inwieweit das mit dem Update zusammenhängt weiß ich nicht.
    Ich glaube ich habe alles gesagt - Fakt ist, daß ich das Gefühl habe, daß MG 2010 stabiler läuft seitdem ich den Hotfix1 explizit angewendet habe.


    Ich möchte mich an dieser Stelle noch einmal ausdrücklich bei dir Jürgen und bei dir Sandro bedanken, für eure Hilfe.


    Gruß Charkow

  • Die Verbindung zur Datei Testdatenbank.mgd brachte die Meldung: Das Testen der Verbindung war erfolgreich.


    Sehr gut. Damit können wir defekte Datenbanktreiber so gut wie ausschließen. Den Tipp mit der *.udl habe ich notiert. Danke dafür. :thumbup:


    MG 2010 war schon immer in der Lage eine neue DB auf meinem Rechner zu erzeugen, hat allerdings bei bestimmten Situationen Datenbanken zerstört. Dies passierte immer dann, wenn ich das Programm zwangsweise beenden mußte was meistens der Fall war, nachdem ich meine Konten aktualisieren wollten.


    Siehe KB209137 Stichwort "Task-Manager".


    Der Dialog "Aktive Aufträge senden" wurde nicht eingeblendet und das Programm hat dann nicht mehr reagiert.


    Es wäre sehr hilfreich gewesen, wenn du dieses Detail im ersten Beitrag erwähnt hättest. Es handelt sich um ein Problem, welches in äußerst seltenen Rechnerkonfigurationen auftritt, bisher jedoch nur in Versionen vor MG2010 beobachtet werden konnte. Demnach lag bei dir der Dialog "Aktive Aufträge senden" unerreichbar hinter dem Hauptfenster des Programms. Merkt man daran, dass man nach jedem Mausklick auf eine beliebige Stelle der (scheinbar) eingefrorenen Anwendung den Windows Standard-Warnton - hier unter Vista "Windows-Ping.wav" - hört.


    Mit Alt+TAB spielen oder Windowstaste+D / Umschalt+Windowstaste+M kann man versuchen den Dialog in den Vordergrund zu holen. Etwas Linderung verschafft als Betroffener das Aktivieren der Option "Fenster nach dem Senden automatisch schließen". Leider gibt es derzeit für dieses Phänomen keine andere Lösung.


    Und ob ihr mir es glaubt oder nicht, war dann nach einem Neustart von MG 2010 der Tabulator "Startseite" auf der rechten Seite oben links verschwunden.


    Gab es zwischen dem letzten Beenden von MG2009 und der Konvertierung nach MG2010 einen Datumswechsel? Werden in der aktuellen DB automatische Gegenbuchung aus der Zahlungsverwaltung erzeugt?


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Jürgen ()

  • Demnach lag bei dir der Dialog "Aktive Aufträge senden" unerreichbar hinter dem Hauptfenster des Programms. Merkt man daran, dass man nach jedem Mausklick auf eine beliebige Stelle der (scheinbar) eingefrorenen Anwendung den Windows Standard-Warnton - hier unter Vista "Windows-Ping.wav" - hört.


    Auf die Idee bin ich nicht gekommen, da ich standardmäßig den Ton ausschalte und ihn nur einschalte wenn ich Musik hören will oder ähnliches. Werde ich beim nächsten mal versuchen.
    Noch eine Sache habe ich festgestellt. Da ich mehr als nur ein Konto habe, wird bei einer Kontenaktualisierung auch mehr als nur ein Konto abgefragt, bzw. die Unterkonten einzeln abgefragt. Manchmal (nicht immer) tut sich nach dem Erscheinen der Meldung "Verbindungsaufbau ..." zu einem Konto nichts mehr. Ein Klick auf Senden abbrechen bewirkt, dass bei allen nachfolgenden Umsatzabragen der Informationstext von "bitte warten ..." auf "Ausführung abgebrochen." wechselt und der Text des Dialogbuttons von "Senden abbrechen..." auf "Senden abgebrochen..." und nicht auf "Schließen" geht und damit kann der Dialog nicht beendet werden - es muss schon wieder der TaskManager ran. Das konnte ich auch erzwingen, indem ich während der Kontenabfrage auf Senden abbrechen geklickt habe - ich habe es allerdings noch nicht geschafft eine Systematik zu finden.
    Im XP Mode habe ich dieses Phänomen noch nicht beobachtet.


    Gab es zwischen dem letzten Beenden von MG2009 und der Konvertierung nach MG2010 einen Datumswechsel?


    Ich denke schon dass ein paar Tage dazwischen gelegen haben.


    Werden in der aktuellen DB automatische Gegenbuchung aus der Zahlungsverwaltung erzeugt?


    Meinst du mit automatisch, dass die Gegenbuchungen bei der Kontenaktualisierung oder beim Umbuchen von z.B. Barabhebungen vom Giro- auf das Haushaltskonto erzeugt werden ? In beiden Fällen lasse ich die Gegenbuchungen automatisch erzeugen, allerdings werde ich immer gefragt, ob ich das so haben will.
    Weißt du was der Unterschied zwischen dem Format .mgz und .mgd ist? Kann es sein, dass Mein Geld 2010 die Informationen über die Anzeige irgendwo in der Datei .mgz mit abspeichert?

  • Um das Problem mit dem Fenster "Aktive Aufträge senden" zu umgehen aktiviere einfach die Option "Fenster nach dem Senden automatisch schließen". Sollte sich der Dialog wieder einmal hinter dem verdunkelten Hauptfenster befinden, wird er nach einer gewissen Zeit selbstständig beendet. Vermeide aber in jedem Fall das Beenden der Anwendung durch den Task-Manager.


    Weißt du was der Unterschied zwischen dem Format .mgz und .mgd ist? Kann es sein, dass Mein Geld 2010 die Informationen über die Anzeige irgendwo in der Datei .mgz mit abspeichert?


    1. im *.mgz-Format ist die Datenbank verschlüsselt.
    2. Dazu kann ich leider nichts sagen.


    Zurück zum Startseiten-Problem.
    Gibt es unter %appdata%\Buhl Data Service GmbH\WISO Mein Geld 2010 Professional\Log eine MgException.txt ?


    Ach ja, bezüglich der erhaltenen Fehlermeldung aus diesem Beitrag ("Bei der Datenbankpflege wurden Fehler festgestellt.") wende dich mit der Bitte um Ansicht noch einmal an den Support. Erwähne dass dich ein Moderator darum gebeten hat. Verweise ggf. auf diesen Beitrag.


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

  • Lösche im Verzeichnis einmal die MgException.txt oder verschiebe sie an einen anderen Ort. Öffne danach die aktuelle Datenbank [1] und bewege dich wie auch sonst üblich durch die verschiedenen Bereiche. Beende das Programm. Falls eine neue MgException.txt erzeugt wird lade diese bitte zur Ansicht hoch.


    Gruß
    Jürgen


    [1] Info für den interessierten Mitleser: es handelt sich hier um ein Backup der Datenbank ohne sichtbare Fehlermeldung. Dies teilte mir Charkow per PN mit.

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •