cyberJack RFID komfort unter MG 2012

  • Hallo zusammen,


    ich habe Probleme bei der Einrichtung meines Commerzbank-Kontos mit HBCI und Chipkarte: Das Konto ist für HBCI freigeschaltet und der Zugang über eine Schlüsseldatei auf einem USB-Stick funktioniert einwandfrei. Wenn ich versuche, den Zugang auf Chipkarte umzustellen, gelingt dies aber nicht.


    Ich benutze den cyberJack RFID komfort und die mit diesem mitgelieferte FinTS 3.0 Chipkarte. Der Kartenleser ist mit aktuellstem Treiber (6.9.13) installiert. Der Funktionstest von Kartenleser und Chipkarte unter dem Gerätemanager des Kartenlesers verläuft erfolgreich. Auch in WISO MG Professioanl 2012 verläuft der Funtionstest des Kartenlesers zunächst einwandfrei: Der Kartenleser wird gefunden, die Chipkarte wird erfolgreich erkannt und mir wird mitgeteilt, dass die sichere Pin-Eingabe nach Klasse 2 unterstützt wird. Bei der Einrichtung der Chipkarte als Sicherheitsmedium erhalte ich dann jedoch folgenden Hinweis: "Die eingelegte Chipkarte wurde nicht erkannt und kann nicht verwendet werden." Hieran hat auch eine vollständige Deinstallation des Kartenlesers mit anschließender Neuinstallation und Treiberaktualisierung nichts geändert. Woran kann das liegen? Der Online-Support von ReinerSCT konnte bislang nicht helfen und bescheinigte mir nach Übermittlung der log-Daten eine einwandfreie Funktion von Leser und Karte. Als letzte Antwort erhielt ich von ReinerSCT folgendes:


    "Schauen Sie bitte mal nach, ob die Datei HBCIKRNL.INI mehrfach auf Ihrem PC vorhanden ist.
    Diese sollte es nur einmal geben, und zwar im Verzeichnis c:\windows .
    Mehr Möglichkeiten unsererseits habe ich nicht. Fragen Sie doch bitte auch bei Buhl nach, vielleicht wissen die eine Lösung."


    HBCIKRNL.INI ist bei mir nur einmal vorhanden. Vom Buhl-Support bekam ich nach Übermittlung der Log-Datei folgende Antwort:


    "Aus der, von Ihnen zur Verfügung gestellten, Logdatei geht hervor, dass der Zugang zum Kartenleser durch einen anderen Prozess blockiert wird. Unserer Erfahrung nach handelt es sich dabei um ein Dienstprogramm von Reiner-SCT. Um den Kartenleser dennoch in WISO Mein Geld verwenden zu können genügt es in der Regel den Kartenleser für etwa 10 Sekunden von System zu trennen und neu anzuschließen.


    Unsere Entwicklungsabteilung steht bereits mit der Firma Reiner-SCT in Verbindung um gemeinsam eine zufriedenstellende Lösung für diesen Sachverhalt zu finden."


    Ich hab jetzt mal über den Windows-Gerätemanager so ziemlich alle Prozesse beendet, die mir verdächtig vorkamen. Weder das noch ein Trennen und Wiederanschließen des Kartenlesers hat aber geholfen.


    Weiß hier jemand Rat?


    VG
    Jonny

  • Das ist schön für Dich...


    Benutzt Du ihn mit der von Reiner mitgelieferten Karte?


    Mein Leser wird ja auch erkannt und der Funktionstest verläuft sowohl im Gerätemanager des Lesers als auch unter MG erfolgreich. Auf der Reiner-Seite kann ich die mitgelieferte Karte auch initialisieren und die PIN ändern. Auch den Personalausweis kann der cyberJack lesen und die PIN-Änderung über die Lesertastatur funktioniert. Aber das Zusammenspiel Karte, Leser und MG klappt in der Praxis einfach nicht.


    Würde mich über - noch - hilfreichere Antworten freuen.


    VG
    Jonny

  • Was soll ich bei HBCI mit der von Reiter-SCT mitgelieferten Karte? Für Onlinebanking per HBCI benötigst Du m.E. nur und ausschließlich die HBCI-Karte Deiner Bank bzw. Deines Kreditkarteninstitutes.


    Und eine etwas nettere Reaktion, wenn Dir jemand in seiner Freizeit hilft, wäre auch angenehm.

  • Danke und sorry, war nicht böse gemeint.


    Die Karte ist als FinTS 3.0-Karte deklariert und von der Bank habe ich keine bekommen. Allerdings habe ich sie über den Link zum Reiner-Shop auf der CoBa_Homepage bekommen. Hier war sie als HBCI-Karte bezeichnet.


    Vielleicht muss ich einfach nochmal bei der Bank fragen?


    VG
    Jonny

  • Ich selber kenne es nur so, dass einem das eigene Kreditinstitut die HBCI-Karte zur Verfügung stellt.


    Falls es an Deinen Einstellungen liegen sollte such doch mal hier im Forum zu HBCI und Commerzbank. Z.B. hier: Benutzerkennung der Commerzbank bei HBCI-Chipkarte

  • Ok, danke nochmal. Ich vermute, dass Du recht hast und ich eine zusätzliche HBCI-Karte meiner Bank brauche. Habe ich jetzt bestellt. Mal abwarten. Ich werde berichten. Hätten mir die bei der CoBa aber auch mal sagen können als ich HBCI beantragte. Das Know-How über HBCI schien aber zumindest in meiner Filiale nicht sehr groß zu sein. Mir wurde fast der Eindruck vermittelt, sowas hätte vorher noch niemand beantragt...


    VG
    Jonny

  • Whisker
    Meine erste Antwort war sehr wohl hilfreich, weil es zeigt, dass es nicht am RFID Komfort im Grundsätzlichen liegt, sondern an anderen Dingen liegen muss. Und die zweite war die Antwort auf seine Antwort. Abgesehen davon hat sich ja bisher kein anderer dieses Problems angenommen, Du auch nicht.


    Und was mischt Du Dich ein? Wenn Du weiter gelesen hättest, dann wäre Dir aufgefallen, dass Jonny75 und ich dies einvernehmlich geregelt haben, wenn es überhaupt etwas zu regeln gab, und schon ein paar schritte weiter sind. Dein Post war für ihn in der Sache übrigens auch nicht hilfreich.

  • So, jetzt bin ich schon mal einen Schritt weiter: Tatsächliche HBCI-Karte erhalten, Entschuldigung von Reiner für das Versehen, Zugang fast eingerichtet. Nur bei der Synchronisierung des Zugangs erhalte ich nun folgende Fehlermeldung: "Der von Ihnen verwendete Signaturschlüssel ist im System unbekannt (9331)." Habe mich deswegen an den CoBa-Support gewandt, aber die sind am Wochenende nicht erreichbar. Hat hier jemand vielleicht einen Lösungsvorschlag?


    Habe mich bei der Umstellung von Schlüsseldatei genau an die verfügbaren Anleitungen gehalten: Zugangsart für Konto auf offline gestellt, alten Kontakt entfernt, Kontakt neu angelegt, neue Zugangsart eingerichtet. Bis dahin funktionierts, aber dann hakts. Alternativ habe ich in der HBCI-Kontaktübersicht die Option "Sicherheitsprofilwechsel" gewählt und bin dann den Menuanweisungen gefolgt. Leider mit dem gleichen Ergebnis.


    Vielen Dank schon mal für hilfreiche Antworten.


    VG
    Jonny

  • Danke Jürgen. Leider bringen mich die Anleitungen aber nicht weiter.Wie gesagt, bei abschließender Synchronisierung des Kontakts erhalte ich die Fehlermeldung, dass mein Signaturschlüssel im System unbekannt ist. Muss ich vielleicht meinen alten Zugang per Schlüsseldatei erst sperren und dann eine neue Erstinitialisierung des Zugangs per Chipkarte durchführen?


    VG
    Jonny

  • So, Problem gelöst: Die Coba musste meinen alten Zugang mit der auf dem USB-Stick gespeichert Schlüsseldatei sperren und ich einen neuen Schlüssel auf der Chipkarte erzeugen. Dieser musste dann wieder über einen Ini-Brief freigeschaltet werden. Jetzt läufts. Keine Ahnung, ob das so sein musste und ob dies der einfachste Weg war. Hauptsache jetzt klappts.


    Trotzdem Danke für alle Ratschläge!


    VG
    Jonny