2 (kleine) Fehler und Erfahrungen mit dem PreRelease 10.00.03.66

  • Habe das PreRelease einmal installiert und folgende Fehler gefunden:


    -nach Einlesen neuer Kontoumsätze "springt" die Kontoanzeige auf den Anfang der Kontodaten und man muß ordentlich scrollen, bis man wieder beim aktuellen Datum (unten) angelangt ist. Nicht weiter tragisch, aber immerhin lästig...


    -beim Kontowechsel zeigt das Programm häufig für einige Sekunden eine leere weiße Seite, bis dann zum Zielkonto gesprungen wird.


    Und nun auch mal was Positives: PayPal-Umsätze werden einwandfrei eingelesen. Beim Erstellen eines neuen Beleges gibt's nun keine "Kunstpause" von einigen Sekunden mehr, bis dann der Cursor bei Empfängernamen angelangt ist.


    SUPER, Danke!


    Falls ich noch einen Wunsch frei habe:


    Bitte endlich die allgemeine Geschwindigkeit von MG verbessern. War schon die 2008er Version nicht gerade ein "Läufer", so ist die aktuelle Version wirklich ein "Schleicher".


    Hier einmal ein paar Meßergebnisse unter Windows XP SP3 (mit einer frisch defragmentierten HighEnd U160 Server SCSI Platte mit 15.000 U/min):


    1. Programmstart bis zum Erscheinen des Anmeldefensters: 22 Sekunden, weitere 11 Sekunden vergehen nach der Anmeldung bis die Startseite angezeigt wird


    2. Programmstart (aus dem RAM, aber kaum besser): 17 Sekunden und weitere 10 Sekunden bis zur Startseite


    Zudem reagiert das Programm im Allgemeinen sehr träge.


    MG2009 ist mit diesen Werten die unangefochtene Nr.1 auf meinem Rechner und läßt selbst den " üppigen Brennkaiser" um Längen hinter sich.


    Hier muß sich doch mal etwas verbessern lassen, oder liegt's am MS DotNet-Framework???



    Viele Grüße, Bauzel

  • Und nun auch mal was Positives: PayPal-Umsätze werden einwandfrei eingelesen. Beim Erstellen eines neuen Beleges gibt's nun keine "Kunstpause" von einigen Sekunden mehr, bis dann der Cursor bei Empfängernamen angelangt ist.

    Das kann ich leider nicht bestätigen, ich kann auch mit diesem PreRelease mein PayPal-Konto nicht abrufen (auch das Neuanlegen in einer nackten Datenbank schlägt fehl). ;(

  • Hallo,


    mir ist da seit dem Patch auch ein Verhalten in Sachen markieren von Buchungen aufgefallen, das sich in früheren Versionen anders verhalten hat.
    Ich markiere in der Buchungsübersicht eine erwartete Buchung und sofort danach die reale Buchung, der ich die erwartete zuweisen möchte. Allerdings bleibt die Funktion manuell zuweisen grau. Ich muss erst die erwartete Buchung nochmals markieren und kann die Zuweisung dann durchführen.
    Es îst zu ertragen, aber 1 klick mehr, den ich mir auch nicht logisch erklären kann, halte ich für unnötig.


    Gruß
    Oliver

  • Hallo Bautzel,

    -nach Einlesen neuer Kontoumsätze "springt" die Kontoanzeige auf den Anfang der Kontodaten und man muß ordentlich scrollen, bis man wieder beim aktuellen Datum (unten) angelangt ist. Nicht weiter tragisch, aber immerhin lästig...

    auf welche Art genau aktualisieren Sie Ihre Umsätze? Wir können dieses Verhalten hier nicht reproduzieren.

    -beim Kontowechsel zeigt das Programm häufig für einige Sekunden eine leere weiße Seite, bis dann zum Zielkonto gesprungen wird.

    Sie meinen im Buchungscenter? Wieviele Buchungen haben Sie und welche Ansicht benutzen Sie (mit oder ohne Splitbuchungen)?

    Leider können wir auch diesen Schverhalt hier nicht reproduzieren. Auf einem 2GHz Dual Core mit langsamer 80Gig Platte und einer ca. 8MB (mehrere 1000 Buchungen) großen Datenbank dauert der komplette Start inkl. Startseite ca. 6 Sekunden. Kann es sein, dass hier evtl. noch eine Sicherheitssoftware wie z.B. ein Virenscanner Mein Geld ausbremst?


    Mit freundlichen Grüßen
    Ihre Buhl Data Service GmbH

  • Hallo Oliver,

    mir ist da seit dem Patch auch ein Verhalten in Sachen markieren von Buchungen aufgefallen, das sich in früheren Versionen anders verhalten hat.
    Ich markiere in der Buchungsübersicht eine erwartete Buchung und sofort danach die reale Buchung, der ich die erwartete zuweisen möchte. Allerdings bleibt die Funktion manuell zuweisen grau. Ich muss erst die erwartete Buchung nochmals markieren und kann die Zuweisung dann durchführen.
    Es îst zu ertragen, aber 1 klick mehr, den ich mir auch nicht logisch erklären kann, halte ich für unnötig.

    das war nicht beabsichtigt und birgt auch keinen tieferen Sinn, sondern hat sich durch die Umbauarbeiten bezüglich der vorgemerkten Umsätze eingeschlichen. In der nächsten Version (nach 10.00.03.69) wird das wieder geändert sein.


    Mit freundlichen Grüßen
    Ihre Buhl Data Service GmbH

  • Hallo,


    besten Dank für Ihre schnelle Stellungnahme. Ich freue mich, daß die Beiträge hier gelesen werden und Sie um Hilfe bemüht sind.


    Hier die gewünschten Antworten:




    Zitat

    auf welche Art genau aktualisieren Sie Ihre Umsätze? Wir können dieses Verhalten hier nicht reproduzieren.


    Für die Aktualisierung wähle ich auf der Startseite die Direktverbindung. Das Problem tritt dann (und nur dann) auf, falls neue Kontoumsätze vorliegen und ich nach dem Einlesen und Beenden der Verbindung auf der Startseite auf das Konto klicke. Anschließend wird zu diesem Konto gewechselt, allerdings wie beschrieben zum Anfang des Datensatzes gesprungen und nicht (wie normalerweise) die letzten Buchungen angezeigt. Falls keine neuen Umsätze vorliegen, tritt dieses Problem nicht auf.




    Zitat

    Sie meinen im Buchungscenter? Wieviele Buchungen haben Sie und welche Ansicht benutzen Sie (mit oder ohne Splitbuchungen)?


    Auch dieses Problem erfolgt, wenn ich auf der Startseite ein Konto per Mausklick auswähle um zu diesem zu wechseln. Häufig erhalte ich als Reaktion dann für einige Sekunden zunächst eine weiße Seite auf dem Bildschirm, bis dann der Wechsel tatsächlich stattfindet und das Konto mit den Details angezeigt wird. Buchungsanzahl ist rund 1.100, die Größe der Datenbank ist 4,6 MB.




    Zitat

    Leider können wir auch diesen Schverhalt hier nicht reproduzieren. Auf einem 2GHz Dual Core mit langsamer 80Gig Platte und einer ca. 8MB (mehrere 1000 Buchungen) großen Datenbank dauert der komplette Start inkl. Startseite ca. 6 Sekunden. Kann es sein, dass hier evtl. noch eine Sicherheitssoftware wie z.B. ein Virenscanner Mein Geld ausbremst?



    Ihre Angaben zur Startzeit sind traumhaft und ich hätte diese auch gerne! Leider konnte ich solche Werte selbst mit den Versionen 2007 und 2008 nie erreichen.


    Nun zu Ihrer Frage: Natürlich läuft bei meinem Test kein Online-Virenscanner im Hintergrund. Das System wurde "frisch" gestartet, keine anderen Programme im Hintergrund, natürlich bis auf die normalen Windows Dienste, die das Betriebssystem selbst benötigt.


    MG ist das einzige Programm auf meinem Rechner, bei dem solche Zeitverzögerungen auftreten. Sebst andere komlexe Anwendungen, die zunächst 50, 80 MB oder mehr in den Arbeitsspeicher schaufeln müssen, sind bereits nach wenigen Sekunden geladen und betriebsbereit.


    Wenn Sie sich hier im Forum umschauen, werden Sie sehen, daß scheinbar viele Anwender ähnliche Probleme haben.


    Woran das liegt, kann ICH leider nicht sagen...., an der Hardwareaustattung oder der Konfiguration liegt es jedenfalls nicht.


    PS. Habe gerade gesehen, daß ein neues PreRelease vorliegt. Vielleicht beseitigt dies ja schon einige Schwierigkeiten!


    Nochmals besten Dank für die Hilfe und Unterstützung!


    Viele Grüße und allen ein schönes Wochenende!


    Bauzel

  • Hallo Bauzel,

    besten Dank für Ihre schnelle Stellungnahme. Ich freue mich, daß die Beiträge hier gelesen werden und Sie um Hilfe bemüht sind.

    selbstverständlich liest die Entwicklungsabteilung permanent mit was hier passiert. Viele Verbesserungen sind durch Vorschläge hier entstanden. Es ist allerdings auch richtig, dass wir uns nicht zu jedem Sachverhalt äußern, denn zwischendurch müssen wir ja auch entwickeln ;-).


    Für die Aktualisierung wähle ich auf der Startseite die Direktverbindung. Das Problem tritt dann (und nur dann) auf, falls neue Kontoumsätze vorliegen und ich nach dem Einlesen und Beenden der Verbindung auf der Startseite auf das Konto klicke. Anschließend wird zu diesem Konto gewechselt, allerdings wie beschrieben zum Anfang des Datensatzes gesprungen und nicht (wie normalerweise) die letzten Buchungen angezeigt. Falls keine neuen Umsätze vorliegen, tritt dieses Problem nicht auf.

    Klingt merkwürdig, wir werden das am Montag prüfen.


    Auch dieses Problem erfolgt, wenn ich auf der Startseite ein Konto per Mausklick auswähle um zu diesem zu wechseln. Häufig erhalte ich als Reaktion dann für einige Sekunden zunächst eine weiße Seite auf dem Bildschirm, bis dann der Wechsel tatsächlich stattfindet und das Konto mit den Details angezeigt wird. Buchungsanzahl ist rund 1.100, die Größe der Datenbank ist 4,6 MB.

    Die wichtigste Frage ist aber welche Ansicht Sie benutzen. Die Ansicht inkl. Splitbuchungen ist erheblich langsamer als die "normale" Ansicht. Dies liegt daran, dass die Abfragen im Hintergrund deutlich komplizierter sind.


    Solche Einbrüche in der Performance haben wir bis jetzt in der Entwickling nie beobachten können, was die Ursachenforschung ein wenig schwierig macht. Wir nutzen teilweise Datenbanken mit mehren 10.000 Buchungen und Empfängern ohne dieses Problem zu beobachten. Dass auch andere User dieses Problem haben, haben wir sehr wohl wahr genommen, wobei "viele" hier im Forum immer relativ ist.


    Woran das liegt, kann ICH leider nicht sagen...., an der Hardwareaustattung oder der Konfiguration liegt es jedenfalls nicht.

    Da haben Sie sehr wahrscheinlich recht, ich glaube auch nicht dass es an der Hardware liegt. Wahrscheinlich liegt es an "Besonderheiten" in der Nutzung von Mein Geld.


    PS. Habe gerade gesehen, daß ein neues PreRelease vorliegt. Vielleicht beseitigt dies ja schon einige Schwierigkeiten!

    Das wäre schön, allerdings glaube ich es nicht. Wenn dem so wäre ist diese Veränderung ohne unser bewusstes Zutun geschehen. Ein paar Optimierungen haben wir allerdings beim Auftragsformular und den Regeln vornehmen können.


    Mit freundlichen Grüßen
    Ihre Buhl Data Service GmbH

  • Hallo, hier die Antwort auf Ihre Frage:



    Zitat

    Die wichtigste Frage ist aber welche Ansicht Sie benutzen. Die Ansicht inkl. Splitbuchungen ist erheblich langsamer als die "normale" Ansicht. Dies liegt daran, dass die Abfragen im Hintergrund deutlich komplizierter sind.


    Die Ansichtsoption "Splitbuchungen anzeigen" ist nicht aktiviert.


    Viele Grüße, Bauzel

  • Hallo Bauzel,


    mir ist da eine spontane Idee gekommen: Kannst du mal testweise unter Optionen > Sicherheitseinstellungen die Verschlüsselung der Datenbank deaktivieren. Bringt das Besserung?


    Viele Grüße


    Sandro


    PS. Bezgl. der Performance: Meine Datenbank ist 9 MB groß, MG startet (auf verschiedenen DualCore Systemen) in ca. 6 Sekunden - vom USB-Stick. Ist zwar kein langsamer Stick, aber an deine Platte dürfte er nicht ganz rankommen ;)

  • Nachdem das "Rücksprung"-Problem heute Morgen auch nach Installation des PreReleases 10.00.03.69 noch auftritt, hier zur leichteren Nachvollziehbarkeit eine etwas umfangreichere Beschreibung:


    -Einlesen der neuen Umsätze


    -zum Abgleich der erwarteten Umsätze mit den eingelesen Umsätzen Aufruf des Abgleichassistenten


    -Abgleich mit Hilfe des Assistenten


    -Schließen des Assistenten


    -direkt danach erfolgt der erwähnte Sprung an den Konto-Anfang, anstatt wieder zu den Tagesumsätzen zurückzukehren


    Viele Grüße, Bauzel

  • Hallo Oliver,


    das war nicht beabsichtigt und birgt auch keinen tieferen Sinn, sondern hat sich durch die Umbauarbeiten bezüglich der vorgemerkten Umsätze eingeschlichen. In der nächsten Version (nach 10.00.03.69) wird das wieder geändert sein.


    Mit freundlichen Grüßen
    Ihre Buhl Data Service GmbH

    Hallo,


    wollte nur melden, dass in 10.00.03.70 das Verhalten wieder der alten Gewohnheit entspricht.
    Danke für das schnelle Fixing.


    Oliver