Update 20.02.30.001 - Performance unterirdisch

  • Hallo,


    gestern Abend haben wir MB von 20.01.34.003 auf 20.02.30.001 aktualisiert.

    Heute haben alle Mitarbeiter regelmäßige Kaffeepausen, weil die Performance sich derartig verlangsamt hat, dass es leider kaum noch möglich ist zu arbeiten.

    Ich weiß leider nicht, welche tollen neuen Features dafür verantwortlich sind... ;(;(;(


    Beispiel:

    Filter zurücksetzen bei Rechnungen:

    VOR dem Update: 12 Sekunden

    NACH dem Update: 140 Sekunden (ca. 2,5 Minuten, das reicht zum Kaffee holen!)


    Ich gehe jetzt erst mal nen Mega-PC kaufen in der Hoffnung, der ermöglicht uns wieder zu arbeiten.

    Dann beginnt die Suche nach einer Alternative zu Mein Büro, weil 2,5 Minuten pro Arbeitsschritt kann ich leider nicht mehr "arbeiten" nennen.


    Habt Ihr ähnliche Beobachtungen?

    Lösungsansätze oder Ideen?

    Kann ich irgendwelche Features wieder abschalten oder downgraden?

  • Kann ich bestätigen, die Reaktionszeiten beim Umschalten sind oft sehr quälend. Da sin gerade dann sehr negativ, wenn ein Kunde anruft und man mal schnell den Vorgang wechseln will. Nicht so lange, dass ich ne Kaffeepause einlegen könnte, aber spürbar langsamer.


    Was mir schon etwas länger aufgefallen ist, sind die eigen Ladezeiten, wenn ich einen Filterbegriff eintrage. Wo sonst ein Filterwort quasi in Echtzeit angewendet wurde, braucht MB heute bei manchen Begriffen sehr lange - hier auch zwar keine 2,5 Minuten, aber nervig ist es trotzdem, vor Allem, weil es schon mal besser geklappt hat.

  • Hast Du das Ganze auf einer HDD oder SSD?

    Ich könnte mir vorstellen, dass ein flotte SSD was bringen könnte. Die Rechnungen sind ja alle in der Datenbank. Bei 160.000 Rechnungen ist das alles recht Datenbanklastig. In Bezug auf Datenbank wären bei einer SSD insb. die IOPS wichtig. Je mehr, desto besser.


    Ansonsten: Ram hast Du genug?


    Viele

  • Kann ich so nicht bestätigen.

    Wieviele Datensätze, wie viele Filter?

    Viel Spaß mit der neuen Maschine!

    - 160.000 Rechnungen

    - 1 Filter "zurücksetzen"

    Hast Du alle Rechnungen aktiv, oder einen Großteil archiviert? Das hat mir beim Laden der jeweiligen Bereichen schon was gebracht.

  • - 160.000 Rechnungen

    - 1 Filter "zurücksetzen"

    Hast Du alle Rechnungen aktiv, oder einen Großteil archiviert? Das hat mir beim Laden der jeweiligen Bereichen schon was gebracht.

    Das nützt nach meine Erfahrung nur bedingt, weil:

    - Die Seite öffnet schneller, weil er nur die nicht archivierten öffnet

    - Jede Suche dauert deutlich länger, weil er sowohl in ausgeblendeten als auch archivierten Datensätzen sucht, und diese nicht im Speicher hat.


    Mit ner HDD würde ich nur noch in Minuten und Stunden rechnen. :censored:

    Obwohl alle Parameter zwar anzeigen, dass sie "arbeiten", ist kein Parameter am Limit.

    Trotzdem ersetzen wir jetzt mal die Hardware mit dem neuesten Schxxx, setzen zwei Festplatten ins RAID, alles andere mehr und schneller, und hoffen...




    Vielleicht sind mein Wissensstand ja unvollständig, aber m.W. ist

    - Mein Büro eine 32 bit Anwendung und nutzt daher so oder so max. 4 GB RAM

    - arbeitet Mein Büro nur in einem CPU-Kern, insofern nützen mehrere Kerne ebenfalls nichts

  • Habe es vielleicht überlesen, wenn, bitte ich um Verzeihung.

    Wie sind die Arbeitsplätze verbunden? LAN (Kabel) oder WLAN?

    Die Hauptinstallation läuft auf einem internen Server, die Client-PCs sind per LAN verbunden.


    Der Support fühlt sich mit solchen Fragen leider überfordert, außer "Neuinstallation" fällt den nicht viel ein.

    Und genau das werden wir jetzt tun, die Serverarchitektur weitestgehend auflösen, damit alle mögliche Flaschenhälse verschwinden und zumindest EINE Installation so schnell wie möglich läuft.

  • Ich komme seit einer Weile gar nicht mehr übers Netzwerk in die Datenbank. Nur noch direkt auf dem Server kann ich arbeiten. Wenn man das so nennen will.

    Ist vielleicht auch was ganz anderes, aber ich habe seltsames beobachtet.


    Bei den ersten Schwierigkeiten habe ich in der mb.ini den Namen gegen die IP der Servers getauscht und konnte wieder arbeiten. Bei einem anderen Rechner war die IP schon drin, habe ich gegen den Namen getauscht und man konnte wieder arbeiten.

    Jetzt kann kein Rechner mehr übers Netz drauf zugreifen.


    Entweder heißt es in den Meldungen "Der Datenbank dienst konnte nicht gestartet werden" oder er konnte nicht gefunden werden.

    Firwall, Anti-Virus und so Dinge habe ich alles schon Probiert und auch deaktiviert.

    Alles andere im Netz Funktioniert.


    Aber bei Euch ist es einfach nur langsamer geworden ja? Keine komplett Ausfälle?

  • Auch ein neuer Mega-PC hat keine deutliche Verbesserung gebracht.


    Filter zurücksetzen bei Rechnungen:

    VOR dem Update: 12 Sekunden

    NACH dem Update: 140 Sekunden (ca. 2,5 Minuten, das reicht zum Kaffee holen!)

    NACH dem Update mit "Super"-PC: 80 Sekunden


    Was auch immer bei dem Update schief gegangen ist, wenn das nicht gefixt werden kann, muss ich leider "Mein Büro" abschalten, was mir sehr leid tut, denn das Preis-/Leistungsverhältnis ist unschlagbar.


    Aber 80 Sekunden pro Arbeitsschritt ist leider nicht akzeptabel.

  • Da würde ich mal einen Netzwerktechniker dranlassen der sich mit Netzwerken auch wirklich auskennt.

    Im Netzwerk war das Programm aber schon immer etwas überfordert mit größeren Datenbanken....

    Ist es ein Windows-Netzwerk ?

    Sind die Cache alle richtig eingerichtet ?

    Sind die Kabel (Stichwort:gigabit) alle auf schnelle Verbindungen ausgelegt (da reicht ein altes Kabel im Netzwerk als Bremse) Gibt es im Netzwerk einen älteren Switch (älter z.B. als 4 Jahre) ?

  • das hat erst mal nix mit dem Netzwerk zu tun, wenn die Software als Einzelplatzversion nach einem Update sich verlangsamt. Zugriffszeiten verdoppeln sich und Fensterwechsel werden quälend langsam.


    Und wir haben schon einen guten i7 Rechner mit 64GB RAM auf SSD.

    Zwar haben wir nicht die Werte wie oben, aber mal umklicken, ob ein Artikel noch da ist, wird dann bei einem Kundentelefonat nervig.

  • joeschwarz

    Zitat: "Die Hauptinstallation läuft auf einem internen Server, die Client-PCs sind per LAN verbunden."

    Wiso hat das nix mit dem Netzwerk zu tun ? Ich versuche nur dem Threadersteller zu helfen...


    Dass es langsamer (Auch Einzelplatz) geworden ist habe ich ja nicht bestritten sondern bestätigt. Wir dürfen hier nicht alles über einen Kamm scheren, der Threadersteller arbeitet im Netzwerk.

    Wenn bei Dir im Einzelplatz was quälend langsam wird, würde ich mir auch mal alles genauer ansehen, was da noch so alles rumrennt. Quälend langsam ist bei uns nichts (alter i5 - 8GB ram, datenbank 5 GB) Bei uns dauern die Wechsel statt 1 Sekunde ca. 2 Sekunden.

    Dein Zitat: "Ich kann auch eine Verschlechterung feststellen. Zwar nicht soo langsam aber merklich. Vorher habe flüssig ich die Seiten gewechselt in einer Sekunde, jetzt dauert es drei." Von qüälend langsam kann man da aber auch nicht sprechen....Da eher bei Denen die im Netzwerk arbeiten....


    Buhl Support C. Diel könnte ja mal bei der "Entwicklung" nachfragen und hier schreiben.


    PS: Bei den Tickets hartnäckig bleiben

  • Richtig, unsere Hauptinstallation arbeitet im Netzwerk.


    ABER, jetzt haben einen ganz neuen PC gekauft, ca. 2,000 netto, schon was gutes denke ich, und als Test eine Sicherungskopie als Einzelplatz installiert, um alle Netzwerkprobleme vorerst auszuschließen.


    Ergebnis:

    VOR dem Update: 12 Sekunden

    NACH dem Update: 140 Sekunden (ca. 2,5 Minuten, das reicht zum Kaffee holen!)

    NACH dem Update mit "Super"-PC: 80 Sekunden


    Ist jetzt auch keine Erleuchtung.

    Und jetzt alle Datensätze zu löschen und jedes Jahr mit einer "sauberen" Datenbank anzufangen ist auch keine richtige Lösung.

    Aber sonst fällt mir als Alternative nur noch eine andere Software ein, es muss doch möglich sein, eine Firma mit einer 5-6 stelligen Anzahl an Rechnungen und Kunden zu verwalten.