Differenz zwischen Umsatz- und Saldoabfrage

  • Hallo,


    ich habe seit einigen Tagen das Problem, dass bei der Umsatzabfrage meines Kreditkartenkontos bei der Landesbank Berlin die Buchungen korrekt sind, aber ein völlig falscher Kontostand geliefert wird. Mache ich eine Saldoabfrage erhalte ich hingegen den richtigen Kontostand (aber natürlich keine Buchungen). Eine Kontoprüfung brachte ebensowenig eine Besserung wie eine Synchronisation oder das Aus- und Wiedereinschalten als Online-Konto.


    Gruß
    drum58

  • Differenzen zwischen dem von der Bank gelieferten Kontensaldo und dem aus den gelieferten Umsätzen berrechneten Programmsaldo (denn darum geht es hier in Wirklichkeit) sind nichts Ungewöhnliches und wurden hier schon oft besprochen. Nutze einfach mal die erweiterte Suche des Forums und lass nach "Diffenrenz" suchen (dann findest Du z.B. diesen Beitrag). Wenn es dann noch Fragen gibt, dann melde Dich noch einmal.


    Gruß
    Dirk

  • Hallo Dirk,


    es geht mir nicht um eine Differenz zwischen Programm- und Bank-/Kontosaldo (wie die entsteht ist mir klar), sondern um unterschiedlichen Kontostand je nachdem, ob ich eine Umsatzabfrage oder eine Saldoabfrage mache. Das kann eigentlich gar nicht möglich sein, denn die Bank muss doch den gleichen Stand liefern, und dennoch bekomme ich nach einer Umsatzabfrage einen positiven Kontostand (als Banksaldo, abweichend vom Programmsaldo), bei einer Saldoabfrage hingegen einen (richtigen) negativen Saldo (identisch zwischen Bank und Programm) angezeigt.


    Gruß
    drum58

  • Den selben Fehler habe ich bei meinen Landesbank-Kreditkarten auch beobachtet - mich stört er allerdings nicht so sehr, da ja die Umsätze im Einzelnen stimmen.
    Aufgetreten ist der Fehler seitdem die Landesbank ihre Webseite ein klein wenig aufgefrischt hat, ich glaube Ende Januar/Anfang Februar. Vielleicht muss der Screenparser ein klein wenig korrigiert werden.


    Dirk:
    Lesen die Entwickler das selbst hier mit, oder muss das manuell an sie gemeldet werden? Wenn ja, wie? Über Ticket?

    Gruß Uwe
    ___________________________________________________________________________________________
    WISO Mein Geld Professional 365 .Net / REINER SCT cyberJack RFID comfort / Windows 10 Pro 64 bit

  • Aufgetreten ist der Fehler seitdem die Landesbank ihre Webseite ein klein wenig aufgefrischt hat, ich glaube Ende Januar/Anfang Februar. Vielleicht muss der Screenparser ein klein wenig korrigiert werden.

    Hm, das wäre dann aber ungewöhnlich (aber nicht unmöglich), daß der Screenparser nicht in einen Fehler läuft, wenn eine Änderung des Internetbankings der Ursache ist. Insofern habt Ihr ja noch Glück. ;)
    Könnt Ihr denn im Webbanking diese beiden unterschiedlichen Salden sehen?
    Und diese auch im Logfile so unterschiedlich finden (Konten - Onlineverwaltung - Administration - HBCI Kontaktübersicht - Über DataDesign Banking ... Einfache FinTS... Protokolldatei anzeigen (natürlich nach Aktivierung und vor Anzeige die Umsatz- und Saldenabfrage machen):



    Lesen die Entwickler das selbst hier mit, oder muss das manuell an sie gemeldet werden? Wenn ja, wie? Über Ticket?

    Bei Fehlern im Onlinebanking ist es immer besser, ein Ticket einzureichen, da dann oft auch Logflies benötigt werden.


    Gruß
    Dirk

  • Die Protokollierung kann ich heute nicht mehr umfangreich testen, da ich gleich weg muss...
    Eingeschaltet habe ich sie aber schon mal.


    Es gibt im Onlineportal zwei "Unterseiten": Die Seite "Kontostand" - deren Inhalt deckt sich mit den im Protokoll aufgelisteten Zeilen der Saldoabfrage, welche ja letztlich auch den korrekten Kontostand zurückgibt.


    Die zweite Unterseite ist "Kartenumsätze", diese deckt sich im Protokoll mit den von der Umsatzabfrage gelieferten Einzelumsätzen, allerdings kommt hier der falsche Kontostand (bei mir 40,47 € Guthaben). Der Wert "40,47" ist im Protokoll auf den ersten Blick nirgends zu finden.


    An was ich mich noch erinnere - bzw. zu erinnern glaube: Auf der Seite "Kartenumsätze" stand früher, also vor Januar 2011, im oberen Bereich noch immer der aktuelle Kontostand mit drin. Das ist jetzt weggefallen, dort steht jetzt ein längerer Text zur Ratenzahlung.


    Zum Ticketeinreichen komme ich heute nicht mehr, vielleicht kann das ja auch drum58 auch mit übernehmen, wenn er mal die von Dirk gegebenen Hinweise durchtestet.

    Gruß Uwe
    ___________________________________________________________________________________________
    WISO Mein Geld Professional 365 .Net / REINER SCT cyberJack RFID comfort / Windows 10 Pro 64 bit

  • Ich kann diesen Fehler bestätigen, bei mir werden allerdings auch nicht mehr alle Umsätze von MG2011 eingelesen.


    Ein Ticket an den Support habe ich heute erstellt.


    Gruß
    Fred :)


    UPDATE: Die Abbuchungen werden alle eingelesen, aber keine Zahlungseingänge.

  • Auch bei mir werden Abbuchungen eingelesen, Zahlungseingänge nicht. Entsprechend habe ich eine Differenz zwischen Bank- und Programmsaldo (nach Umsatzabfrage), bei einer Saldoabfrage stimmen die Beträge hingegen überein.
    Ein Ticket erstelle ich erstmal nicht, da Fred ja schon eines erstellt hat.


    Gruß
    drum58

  • Ein Ticket erstelle ich erstmal nicht, da Fred ja schon eines erstellt hat.

    Natürlich erstellst Du ein Ticket!


    Jeder mit diesem Problem sollte ein Ticket erstellen. Ich habe jetzt seit 10 Tagen Diskussionen, weil ich der Einzige schien mit dem Problem. Sollte dann als "Verbesserungsvorschlag" an die Entwicklung gehen. Nur mit Hartnäckigkeit konnte ich erreichen, dass es als aktuelles Problem und Fehler weiter verfolgt wird.


    Es werden keine Gutschriften auf dem Kreditkartenkonto durch den Screenparser abgerufen. Auch wird seit dem letzten Update nicht mehr die Wertstellung des Kontoausgleichs abgerufen, sondern fälschlicher Weise das Datum der Erstellung der Kreditkartenabrechnung. Hängt wahrscheinlich beides zusammen.

  • Hallo,


    inzwischen geht bei mir einiges mehr nicht mehr:
    Saldenabfrage: ok,
    Umsatzabfrage: Fehlermeldung bei der Kontoabfrage "Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt."
    neu synchronisieren: ok
    neue Kreditkarte anlegen: Fehlermeldung: Verarbeitung nicht möglich (9010), (9210)


    Ist das bei euch - vor allem mit der Umsatzabfrage - auch der Fall?


    Grüße
    ibro

  • Neue Kreditkarte hat mit dem hier geschilderten Problem nichts zu tun. Die geht immer erst mit dem Folgemonat abzurufen bzw. mit dem ersten vollen Monat nach Abruf der bisherigen Kreditkarte. Natürlich nur, sofern beide LBB.

  • Hallo miwe4,


    Neue Kreditkarte hat mit dem hier geschilderten Problem nichts zu tun. Die geht immer erst mit dem Folgemonat abzurufen bzw. mit dem ersten vollen Monat nach Abruf der bisherigen Kreditkarte. Natürlich nur, sofern beide LBB.


    Das Anlegen als Konto sollte doch funktionieren auch wenn noch kein Umsatz vorhanden ist. Hat zu mindestens bei der ersten LBB-Karte funktioniert. Bei der zweiten Kreditkarte bei der LBB geht es gerade nicht mehr überhaupt ein Konto anzulegen.


    Grüße
    ibro

  • Hallo zusammen,


    ich habe gerade ein Ticket erstellt.


    Gruß
    drum58


    Hallo zusammen,


    ich habe inzwischen Antwort vom Support:


    Die Bank hat eine Änderung im Zugang ausgeführt. Da wir die Webseite der Bank ansteuern und auslesen, bedeutet dieses in jedem Fall, dass die Schnittstelle modifiziert werden muss.
    Eine Anpassung an die Änderungen ist zurzeit mit Nachdruck in Bearbeitung. Wir sind zuversichtlich, dass die Funktionalität in Kürze wieder hergestellt werden kann. Bitte haben Sie etwas Geduld.


    Die Anpassung wird Ihnen im Rahmen eines Updates der Letstrade Komponenten geliefert.


    Das Update ist allerdings noch nicht erfolgt.


    Gruß
    drum58

  • Ich häng mich auch mal mit den eigenen Erfahrungen dran.


    Betrifft ADAC- und AirBerlin-Kreditkarten.
    Gleiche / ähnliche Beobachtung: Abbuchungen werden angezeigt, Gutbuchungen nicht. Kontoprüfung bringt richtigen Saldo aber keine richtigen Buchungen, jeder normale Abruf bringt den falschen Saldo. Einzig funktionierend ist die Anzeige von Buchungen und Saldo nach einer Abrechnung, also wenn die PDF-Rechnung erstellt wurde. Allerdings wird dann der Wert der Lastschrift als Buchung erzeugt, was auch nicht korrekt ist, weil ja in Zwischenzeit eine Positivbuchung kommen könnte. Diese Buchung darf erst erstellt werden wenn Sie (im neuen Abrechnungszeitraum) wirklich im Konto steht.


    Das erste Ticket dazu habe ich bereits am 8.2. aufgemacht, zwischendurch stimmten die Beträge wieder nach der Abrechnung. Seit dem besteht aber das Problem ohne dass es eine Lösung gibt :cursing:

  • So, das Update ist jetzt da.
    Der Saldo stimmt nun wieder und die neueren Zahlungseingänge werden auch eingelesen.
    Allerdings fehlen mir jetzt noch einige ältere Eingänge, wie kann ich diese jetzt ohne große Handarbeit in mein MG2011 bekommen?


    Gruß
    Fred :)

  • Sieht auf den ersten Blick gut aus.
    Danke dafür an die Entwickler.


    Die Kontoprüfung liefert aber immernoch das Ergebnis der Abrechnung (anstehende Abbuchung) direkt als Buchung zurück.
    Das ist falsch!
    Diese Buchung darf erst auftauchen, wenn sie durchgeführt wird.

  • Die Kontoprüfung liefert aber immernoch das Ergebnis der Abrechnung (anstehende Abbuchung) direkt als Buchung zurück.

    Meinst Du jetzt wirklich die Funktion "Kontoprüfung" oder einfach eine Umsatzabfrage?


    Diese Buchung darf erst auftauchen, wenn sie durchgeführt wird.

    Reden wir hier von einer "erwarteten" Buchung?


    Gruß
    Dirk

  • Ich machs mal deutlicher:



    Die LBB erstellt zu Zeitpunkt X (kann verschieden sein) eine Abrechnung. Auf dieser Abrechnung steht unten drauf: "Wir ziehen den Betrag von Y,ZZ € von Ihrem Konto ein".
    Mit diesem Datum erscheint in der Übersicht der Buchungen in der Kontoprüfung eine Positiv-Buchung von Y,ZZ €.



    Das ist aber falsch. Diese Buchung erscheint in Wirklichkeit erst laufend im Kreditkartenkonto bzw. bei der nächsten Abrechnung. Wenn ich nämlich inzwischen manuell Y,ZZ € hinüberweise, wird dieser Betrag gar nicht abgebucht.


    Es ist also gar nicht nötig, diese Buchung aus der Abrechnung zu generieren, sondern erst dann wenn sie wirklich durchgeführt wird und dementsprechend auch vom Screenparser auf der Website erfasst werden kann, nicht aus der Abrechnung.


    Das ist definitiv ein einprogrammierter Fehler.



    ----------------------------


    Hinzu kommt, dass jetzt, mit Update, der normale Kontoabruf den Saldo zeigt, der diese Y,XX Euro enthält, auch wenn sie beim Abruf nicht als Buchung erfasst wurden.



    Fazit: es ist besser geworden, aber richtig noch lange nicht!


    ----------------------------



    Kurze Ergänzung:


    Fehler besteht nach wie vor. Konto aktualisieren = Falscher Saldo. Kontoprüfung durchführen ohne etwas zu ändern = richtiger Saldo.