Installation WISO steuer:Sparbuch 2021 in WINE

  • Hallo zusammen,

    dies ist mein erster Post hier, der hat natürlich ein Problem zum Anlass.

    Ich hoffe trotzdem auf Hilfe.


    Bisher lief das WISO Sparbuch immer gut unter Ubuntu, nach meinem Upgrade auf Ubuntu 20.04 LTS läuft das neue Sparbuch leider nicht mehr.


    Hier noch mal meine Systemdaten:
    Ubuntu 20.04 LTS

    Wine 6.0 stable


    Die Installation lief wie immer ohne Probleme, nur musste ich nach der Installation in der winecfg die Bibliothek "msvcp140_1" ändern damit die Software überhaupt startet ( diesen Hinweis habe ich an anderer Stelle gefunden ).

    Nun startet die Software zwar, aber es wird anschliessend ein Suchindex gestartet der mein System innerhalb kurzer Zeit dermassen auslastet dass ich den Prozess nur noch auf der Kommandozeile beenden muss. Meine gespeicherten Daten kann ich leider nicht öffnen.


    Hat jemand einen Tipp für mich bzw. hat das jemand schon am laufen?


    Vielen Dank schon mal

    Thomas

  • scottel

    Hat den Titel des Themas von „nstallation WISO steuer:Sparbuch 2021 in WINE“ zu „Installation WISO steuer:Sparbuch 2021 in WINE“ geändert.
  • Moin,


    ja - ich habe auch "msvcp140_1" auf Native, Builtin ändern müssen, ebenso habe ich das mit der "msvcp140" auch gemacht.

    Das gleiche Problem habe ich, das mir /home zugespammt wird. Grund ist hierfür u.a. - wie Du schon vermutest - der wisohilfe Prozess (wisohilfe.exe).


    Der Prozess schreibt das xsession Log (bei mir) voll: "~/.local/share/sddm/xorg-session.log" und zwar mit "fixme:netprofm:connection_GetAdapterId".


    Ich habe jetzt zusätzlich mittels winecfg die netprofm auf deaktiviert gesetzt. Dadurch startet WISO 2021 jetzt, aber der Suchindex wird nicht aufgebaut (oder ich bin zu ungeduldigt) und er bringt nach kurzer Zeit einmal einen WINE-Fehler.

    Ansonsten konnte ich erst einmal mit 2021'er Version arbeitet. Gravierend ist jetzt noch, dass er beim Klick auf den Button "Elster" ohne Fehlermeldung abstürzt.


    Ich habe auch versucht die netprofm.dll neueinzuspielen (siehe https://forum.winehq.org/viewtopic.php?f=8&t=34777) - aber das Resultat ist das gleiche (netprofm muss dann auf Builtin gestellt werden), bis auf die eine oben angesprochene Fehlermeldung. Elster stürzt auch weiterhin ab und der Suchindex wird auch nicht erstellt.


    Interessanterweise gibt es mit jeder neuen WISO Version immer mehr Probleme mit wine.


    Gruß

    Thomas

  • Bei mir stürzt Steuer2020 mit dem gleichen Verhalten ab, daher würde ich davon ausgehen, dass es der gleiche oder zumindest ein ähnlicher Fehler ist. Wenn ich das Programm aus dem Terminal starte, erhalte ich am Ende die Meldung "QMutex: destroying locked mutex". Das bei jeder Interaktion mit Elster.


    Ich habe das Ganze unter einem 64bit und 32bit Wineprefix versucht, leider gleiches Verhalten.


    Vielleicht hilft das ja weiter...


    Viele Grüße

  • So...ich hab jetzt WISO2021 unter Wine 6.3 zum laufen bekommen.


    1.) Ich habe WISO 2021 jetzt unter einem 32 Bit Prefix installiert (env WINEARCH="win32")

    2.) Bedingt durch den 32 Bit Prefix musste ich noch lib32-vulkan-icd-loader nachziehen (Paketname bei Arch)

    3.) Über winetricks habe ich die DLLs für: crypt32, mspatcha, riched20 und vcrun2019 nachinstalliert.

    4.) Mittels winecfg habe ich dann noch crypt32 auf Builtin, msvcp140_1 auf Native, netprofm auf ausgeschaltet, vcruntime140 und vcruntime140_1 auf Native gestellt. Windows-Version ist auf Windows 10 gesetzt.


    Damit läuft jetzt auch der Elsteranteil. Hin und wieder kommt noch ein Fehler bzgl. der wisohilfe.exe - das kann man wegklicken, aber das Programm läuft zum Glück weiter.


    Beim rumexperimentieren hatte ich teilweise das Problem das WISO2021 nicht mehr gestart ist, da half folgender Workaround:

    netprofm unter winecfg wieder rausnehmen, WISO starten und beenden, netprofm wieder auf ausgeschaltet unter winecfg gesetzt.


    HTH


    Gruß

    Thomas

  • Ja, das habe ich auch und grundsätzlich funktioniert WISO 2021 jetzt ja auch.


    Was nicht geht, ist die Abgabe per Elster.

    An der WINE-Version selber dürfte es nicht liegen:

    * im Forum beklagt ein Windows und ein MAC-User die gleichen Symptome

    * WISO 2020 funktioniert mit der gleichen WINE Version und Elster


    Ich habe keine Ahnung was da zwischen 2020 und 2021 geändert wurde - crashen tut die wmain21.dll bei der Voransicht für Elster.

  • ich habe jetzt wine 6.5 staging installiert und kann bestätigen, dass Elster jetzt grundsätzlich funktioniert, ich konnte die Belege abrufen. Leider hängt es bei der Voransicht für Elster auch. Fehler:

    0114:err:virtual:virtual_setup_exception stack overflow 1284 bytes in thread 0114 addr 0x7bc50fe2 stack 0x1df0afc (0x1df0000-0x1df1000-0x1ef0000)

  • Das Problem bei der neuen Elster-Version ist, dass die dort verwendete Version der Xerces_C Bibliothek sehr schlampig editiert und kompiliert wurde. Ich habe es fast nicht hinbekommen das überhaupt nachzustellen, weil es eben so komisch umgesetzt ist. :D Könnte mir vorstellen, dass der Rest nicht wirklich besser ist...

  • Um es einleitend kurz zu machen: Wiso läuft, Daten können eingeben werden. Elster tut (wahrscheinlich) seit Update WISOSteuerSparbuch2021Update282140.exe nicht mehr. Versenden per Elster hängt, mehr dazu weiter unten.


    Ich habe Wiso 2021 mit 6.3 - 6.5 zum laufen gebracht, sowohl in einer 32bit als auch 64bit Umgebung. Installiert mit Playonlinux.

    Installierte Komponenten (mittels playonlinux Menü):

    • Microsoft Core Fonts
    • crypt32
    • FontsSmoothRGB
    • gdiplus
    • mspatcha
    • riched20
    • vcrun2019
    • wine64b (nur in 64bit Installation)

    Es funktioniert soweit alles, auch Index erstellen. Nur beim versenden der fertigen Steuererklärung crasht es.


    Ich poste hier mal ausführliche System- und Logdaten, damit alles beisammen ist. Bitte also die Menge entschuldigen. Man findet leider manchmal im Netz nur Logdaten, oder Fehlermeldungen getrennt und oft hilft das dann nicht, weil die Verbindung zueinander fehlt.


    System:

    • Debian Buster (10.9)
    • Playonlinux 4.3.4
    • Wine 6.5-staging (aber auch 6.3 - 6.4 sowohl 32bit als auch 64bit, mit Playonlinux verwaltet)
    • Grafikkarte: VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / R7 250E]
    • RAM: 16GB
    • CPU: Intel(R) Core(TM) i5-4460 CPU @ 3.20GHz
    • Desktop-Manager: XFCE 4.12.5

    Playonlinux habe ich wegen Debugging mal von Konsole gestartet:

    Nun starte ich Wiso 2021 mittels Auswahl des Starters und Klick auf "Ausführen":

    Code
    [POL_System_CheckFS] Message: Checking filesystem for WISO2021.EXE
    [POL_Wine] Message: Running wine-6.5-staging WISO2021.EXE (Working directory : /home/linux42/.PlayOnLinux/wineprefix/WISO32/drive_c/Program Files/WISO/Steuersoftware 2021)
    [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
    Xlib:  extension "NV-GLX" missing on display ":0.0".
    INTEL-MESA: warning: Haswell Vulkan support is incomplete
    Xlib:  extension "NV-GLX" missing on display ":0.0".
    INTEL-MESA: warning: Haswell Vulkan support is incomplete
    [248:252:0424/134733.147:ERROR:network_change_notifier_win.cc(141)] WSALookupServiceBegin failed with: 8
    [POL_Wine] Message: Wine return: 0
    [248:300:0424/134733.384:ERROR:mf_helpers.cc(14)] Error in dxva_video_decode_accelerator_win.cc on line 379

    Nun öffne ich die bereits fertige Steuererklärung und klicke über "Steuererklärung abgeben" zur Elsterabgabe mit Zertifikat. Die Abgabe ist möglich und ich klicke auf "Weiter". Nun passiert nichts mehr. Manchmal wird der Mauszeiger zu einer Hand. Mit "top -c" sehe ich diesen Prozess:

    Code
    409003 linux42   20   0 2037116   1,0g  75968 R  99,3   6,3   1:21.36 wmain21.dll -BYEXE:WISO2021.EXE -CODE:S -SPECIALVERSION:DOWNLOAD                           
  • und auf der Konsole kommt diese Ausgabe:

    Anhand diesr Meldungen habe ich nichts weiter hilfreiches gefunden.


    Offenbar gibt es aber nicht nur in Verbindung mit Linux Probleme: RE: Steuererklärung kann nicht abgegeben werden - wmain21.dll Fehler



    Von den DLL-Schubsern bei Buhl kann man nichts erwarten. Der Support hat auch keinen Plan und ich überlege nun ernsthaft das Abo zu kündigen und alles direkt bei Elster einzutippen. Ich fand Wiso bisher immer hilfreich, weil es viel abgenommen hat. Aber die Zeit die es kostet, alles zum laufen zu bringen reicht locker, um die Daten bei Elster 3x einzutippen. Zu Windows lasse ich mich von denen nicht zwingen und per Webinterface werde ich meine Daten nicht eingeben. Entweder nur als Installation auf dem Rechner, oder eben direkt bei Elster.



    So, mal abgesehen vom Frustmeckern über die Unfähigkeit beim Hersteller, hat jemand vielleicht eine Idee, um die Software vielleicht doch dazu zu bewegen, die Abgabe mit Elster zu machen? Das hilft dann vielleicht auch anderen.


    Besten Dank.


    ---

    Und wegen:

    Zitat

    Ihre Nachricht ist zu lang. Es stehen maximal 10.000 Zeichen zur Verfügung.

    sind es zwei Beiträge geworden. Erschreckend. Software nicht im Griff und Foreneinstellung aus dem letzten Jahrhundert ....

    • Offizieller Beitrag

    sind es zwei Beiträge geworden. Erschreckend. Software nicht im Griff und Foreneinstellung aus dem letzten Jahrhundert ....

    Das ist Unsinn. Der Softwarehersteller hat die Software für Windows und Mac im Angebot. Wenn Ihr das versucht unter Linux (nichts gegen Linux) zum Laufen zu bringen, dann ist dagegen nichts einzuwenden, aber es ist Euer Problem, denn der Hersteller garantiert nicht dafür.

    Und die Forumseinstellung hat auch ihre Gründe. Ich habe keine Ahnung, was daran erschreckend sein soll.

  • linux42 Könntest du vielleicht einen längeren Log von Wine hochladen?

    @Rokolell, ich nehme das mal als Ironie. Ich denke, ich habe ausreichend begründet, warum ich die Logausgaben mit in den Beitrag gepostet habe.


    sind es zwei Beiträge geworden. Erschreckend. Software nicht im Griff und Foreneinstellung aus dem letzten Jahrhundert ....

    Das ist Unsinn. Der Softwarehersteller hat die Software für Windows und Mac im Angebot. Wenn Ihr das versucht unter Linux (nichts gegen Linux) zum Laufen zu bringen, dann ist dagegen nichts einzuwenden, aber es ist Euer Problem, denn der Hersteller garantiert nicht dafür.

    Und die Forumseinstellung hat auch ihre Gründe. Ich habe keine Ahnung, was daran erschreckend sein soll.

    Die letzten Jahre hat es auch mit Wine funktioniert. Irgendwas wurde kaputt gemacht und offenbar gab es dabei auch unter Windows und Mac Probleme (wenn man sich durch die Beiträge in Foren liest). Das meine ich mit "Software nicht im Griff". Den Rest der Erklärung lasse ich mal weg. Mit etwas Selbstreflektion oder Anwendung des Peter-Prinzip kann man da auch drauf kommen.


    Klar hat die Foreneinstellung ihre Gründe. Sie ist trotzdem erschreckend und auch nachvollziehbar angesichts der DLL-Schubser. :D

  • @Rokolell, ich nehme das mal als Ironie. Ich denke, ich habe ausreichend begründet, warum ich die Logausgaben mit in den Beitrag gepostet habe.

    Tatsächlich nein. Damit man das aber sinnvoll zum Laufen bringen kann, brauche ich mehr Informationen, was genau eigentlich schiefläuft. Ich würde das schon gerne machen, nur müsste ich dafür entweder meine eigene Steuererklärung fertigstellen oder (was natürlich unwahrscheinlich ist) die Datei eines anderen haben oder eben mehr Infos bekommen. 🙃


    (Ein Registerdump und Stackdump wären auch sehr praktisch .)

  • Hallo allerseits.


    Ist es inzwischen jemandem gelungen die Steuererklärung mit dem ELSTER-Modul einzureichen?


    Ich habe noch immer das Problem, dass die ELSTER-Voransicht hängen bleibt. Damit scheitert auch die Abgabe, die ja ebenfalls die Voransicht öffnet.


    Fehler:

    Code
    0144:err:virtual:virtual_setup_exception stack overflow 1284 bytes in thread 0144 addr 0x7bc51792 stack 0x120afc (0x120000-0x121000-0x220000)

    Darüber hinaus folgen dann nur noch:

    Code
    01c4:fixme:wlanapi:WlanEnumInterfaces (00000001, 00000000, 21FEDB74) semi-stub

    (Getestet habe ich mit wine-stable (6.0.1) und wine-devel (6.10).)


    Gezwungenermassen habe ich eine Windows-VM installiert und die Steuererklärung von dort aus verschickt.

    Den nun aktualisierten Steuerfall kann ich jetzt auch nicht mehr unter Linux öffnen. Beim Versuch gibt es ca. alle 8 Sekunden im Terminal nur noch die schon bekannten Fehler:

    Code
    0290:fixme:wlanapi:WlanEnumInterfaces (00000001, 00000000, 21FEDB74) semi-stub
  • Noch ein paar mehr Beobachtungen (wine 6.11):


    Wenn man versucht, die Steuererklärung als Papierversion abzugeben, bleibt das Programm auch erstmal hängen. Wenn man in den Einstellungen für den Druck "PDF nach Ausgabe öffnen" (oder irgendwas in der Art), dann läuft es etwas weiter - die Steuererklärung wird als "abgegeben" markiert - bleibt aber danach wieder hängen. Wenn man so weit ist, hat man allerdings das nächste Problem - das nächste Mal, wenn man auf "Abgeben" klickt, bleibt das Programm wieder hängen.


    Die letzten Jahre hat das Programm immer anstandslos unter Wine funktioniert, jetzt leider nicht mehr ...

  • Die letzten Jahre hat das Programm immer anstandslos unter Wine funktioniert, jetzt leider nicht mehr ...

    ...und was lernen wir daraus?

    Richtig! Systemvoraussetzungen beachten.

    vor 20 Jahren konnte man auch noch mit billigem Salat/Frittenöl Auto fahren, heute nicht mehr .

    Du hast offensichtlich nicht gelernt, die Klappe zu halten wenn du nichts sinnvolles beizutragen hast.