Geschwindigkeit bei MG2009

  • "HenryTT" schrieb:

    Mir fällt jedoch auf, dass einige user diese Verlangsamung feststellen und da von den Mods und von Buhl offensichtlich nicht geglaubt oder ernst genommen wird.


    Tut mir leid, wenn ich deutlich werde, aber das ist Quatsch!
    Es geht hier nicht um eine Glaubensfrage, sondern darum, einen Effekt nachzuvollziehen, um eine Chance zu haben, die Ursache dafür zu finden (und nicht nur das Zustandsbeschreibung zur Kenntnis zu nehmen).


    Gruß
    Dirk

  • Hallo an die Diskussionsrunde,


    ich bin der Meinung, dass zwischen MG2008 und MG2009 kein allzugroßer Laufzeitunterschied besteht. Allerdings gilt es eines anzumerken. Bei meiner Datenbank dauert das speichern von Offlinebuchungen ebenfalls ca. 5 sec. Wenn man sich am Abend an den Schreibtisch setzt und alle Einkäufe - Barausgaben - erfasst kann das zu einer Geduldsprobe werden. Das ist einfach zu lange. Das liegt wie gesagt meiner Meinung nicht an MG2009. Ich kenne dieses Zeitverhalten auch von MG2008. Das liegt einfach an der Anzahl Datensätze in der Datenbank. Bei mir ca. 30.000 Datensätze. Wobei 30.000 Datensätze für eine Datenbank keine Herausforderung darstellen sollte, sofern die Datenstruktur durchdacht aufgesetzt ist. Hier sollte Buhl ansetzen. Vielleicht kann Buhl ja mit dem nächsten SP eine Optimierung anbieten :wink: . Die Mods sind ja auch so eine Art Sprachrohr für Buhl. Macht ja auch Sinn. Buhl sollte in Bezug auf das Nachstellen von Störfällen mal mit großen Datenmengen arbeiten. Also Jungs - leitet das doch einfach mal weiter. Für alle anderen, die MG2009 als zu langsam emfpfinden. Bitte prüft doch Eure Vierenscanner, Plattedefragmentierungen oder sonstige Effekte welche eine Datenbank - viel Schreiben u. Lesen - einfach in die Knie zwingen.


    Das von meiner Seite


    Gruß


    Norbert

  • Hallo in die Runde. Wenn ich eine Version MG2008 nutze, die neue MG2009 Version installiere und das Formular für eine Überweisung plötzlich 17 Sekunden benötigt bis das Fenster überhaupt erscheint ... dann liegt es sicherlich an Microsoft aber bestimmt nicht an der neuen MG2009 Version!
    Ich habe mich heute genau wegen des zu langsamen Öffnens des Formularfensters registriert und hoffe, eine Antwort auf diesen offensichtlichen Fehler zu finden. Auf eine weiterhin konstruktive Diskussion.


    Matthias
    2021 Adressen in MG2009

  • "Pilger" schrieb:

    dann liegt es sicherlich an Microsoft aber bestimmt nicht an der neuen MG2009 Version!


    Hat das hier jemand behauptet?


    Zitat

    2021 Adressen in MG2009


    Das entspricht in etwa der Anzahl die ich auch habe, bei mir tritt das Problem nicht auf. Es muss also noch eine andere Ursache geben.


    Viele Grüße


    Sandro

  • "Pilger" schrieb:

    Hallo in die Runde. Wenn ich eine Version MG2008 nutze, die neue MG2009 Version installiere und das Formular für eine Überweisung plötzlich 17 Sekunden benötigt bis das Fenster überhaupt erscheint ... dann liegt es sicherlich an Microsoft aber bestimmt nicht an der neuen MG2009 Version!
    Ich habe mich heute genau wegen des zu langsamen Öffnens des Formularfensters registriert und hoffe, eine Antwort auf diesen offensichtlichen Fehler zu finden. Auf eine weiterhin konstruktive Diskussion.


    Matthias
    2021 Adressen in MG2009


    Du bist Dir aber schon bewußt, dass du eine andere mg.exe startest, welche unter Umständen von Virenscannern oder andern Werkzeugen beackert wird?


    Gruß


    Norbert

  • Bislang wird immer nur nach Ursachen innerhalb MG 2009 gesucht. Geht bitte mal einen anderen Weg und


    gebt an, wieviel Arbeitsspeicher der PC hat. Früher waren 512 MB viel, aber damit dürfte MG 2009 recht


    langsam sein. Heutzutage hat man 1 bis 2 GB Arbeitsspeicher, dann gibt es keine Geschwindigkeitseinbußen.


    Ohne diese Betrachtung lassen sich die unterschiedlichen Feststellungen nicht erklären.


    Man kann über Hilfe/Support zur Systeminformation gelangen (MG 2009 ist gestartet). Dort lässt sich die Aus-


    lastung des Arbeitsspeichers feststellen. Wenn dieser physikalische Speicher nur noch 20 MB frei hat, muss


    z.B. auf die Festplatte ausgelagert werden. Und diese ist wesentlich langsamer.


    Also mal den Arbeitsspeicher aufrüsten, ist zur Zeit preiswert (1 GB DDR 2 so 25 bis 40 €)


    Hajuschu

  • Hallo,


    ist ja alles gut und schön, was hier diskutiert und vorgeschlagen wird.


    Ich habe nach einer offiziellen Anfrage einen Hotfix von Bul Data bekommen, diesen installiert und nun geht es eben ein gutes Stück schneller.


    Gruß
    KH

  • Ich stelle fest, dass Buchungen je länger man diese hintereinander ausführt immer langsamer werden. Habe mehrere Kontoauszüge per Hand nachgepflegt. Am Anfang ging es normal schnell, dauerte dann aber am Ende teilweise 10 Sekunden, jeweils beim Aufrufen der Buchung und beim speichern. Auch ein schliessen der Software und Neustart der Software hilft nicht.


    Version: Stick-Edition


    Gerät 1:
    2,4GHz Dual Core mit 4GB RAM


    Gerät 2:
    2GHz Dual Core mit 2GB RAM (Notebook)

  • Hallo,
    ich bin froh, in diesem Forum Mit-Leidensträger gefunden zu haben.
    Der Umstieg von MG 2008 auf 2000 hat wunderbar geklappt (Option: kein Parallelbetrieb mit 2008 ).
    Der Rechner ist aktuell (intel dual core), 3GB Hauptspeicher, Win XP prof..


    Leider startet MG2009 nach erst ca. 40 Sek., die Abfrage der Kontostände dauert ewig (bis zum Fenster
    "HBCI-Karte einlegen" können schon mal 90 sek. vergehen). Das Verhalten kenne ich von MG 2008 überhaupt nicht
    und nervt natürlich (erinnert ein wenig an das BTX Verfahren).
    Aufgrund der Tipps habe ich die Windows Firewall sowie das Antivir komplett ausgeschaltet. Hat aber nichts gebracht.
    Die Ursache muß woanders dran liegen.


    Wäre wirklich schön, wenn jemand von Euch einen entscheidenen Tipp hätte.
    Danke schon mal im voraus !! :thumbsup:


    Gruß
    quengel

  • Hallo Ihr alle,


    eine der größten Änderungen ist in MG der Umstieg von LT 1 auf LT 2 und der damit verbundene Umstieg von DDBAC (ich nenne es mal "classic") auf DDBAC.net.
    Dabei wurde auch die Entwicklungsplattform auf .net umgestellt. Daher ist jetzt auch .net 2.0 Voraussetzung.
    Das was Ihr hier berichtet (langer Start, langsamer Abruf) kann mit dem neuen LT zusammenhängen (LT wird beim Start geladen und beim Abruf sowieso benötigt).
    Daher würde ich in Richtung .net Framework suchen - ggf. - wenn jemand die Zeit und Lust dazu hat - wäre es auch eine Option alle .net Frameworks zu deinstallieren und nur das .net Framework 3.5 + alle Sicherheitsupdates neu zu installieren.


    Interessant wäre auch, ob andere .net Programme auch eine schlechte Performance haben. Das könnte man z.B. mit Paint.net testen.


    Viele Grüße


    Sandro

  • Hallo Sandro,


    hatte bereits .net3.0 (germanlanguage) auf meinem Rechner. .net Anwendungen wie TOAD for dataanalysis laufen einwandfrei.
    Habe aber .net3.5 SP1 zusätzlich installiert und siehe da, MG2009 ist doppelt so schnell (nach ca. 20 sek.) da. Bei der Konstostandsabfrage genauso.
    Problem scheint also damit zusammenzuhängen. :P
    Jetzt habe ich alle .net Installationen auf meinem Rechner (1.1, 2.0, 3.0 mit SP´s). Kann man die alle gefahrlos deinstallieren
    [Blockierte Grafik: http://www.wiso-software.de/forum/file:///C:/DOKUME%7E1/Michael/LOKALE%7E1/Temp/moz-screenshot.jpg]und würde das von der Geschwindigkeit her etwas bringen?
    Danke für die Tipps.
    Gruß
    quengel

  • hatte bereits .net3.0 (germanlanguage) auf meinem Rechner. .net Anwendungen wie TOAD for dataanalysis laufen einwandfrei.


    Ok


    Zitat

    Problem scheint also damit zusammenzuhängen. :P


    hab ich fast vermutet, wobei wir jetzt wahrscheinlich die Ursache haben, eine echt Lösung hab ich aber leider nicht ...


    Zitat

    Jetzt habe ich alle .net Installationen auf meinem Rechner (1.1, 2.0, 3.0 mit SP´s). Kann man die alle gefahrlos deinstallieren


    Ab Version 2.0 sind die Frameworks abwärtskompatibel. D.h. eine für .net 2.0 programmierte Applikation sollte auch mit der 3.5 laufen.


    D.h. im Idealfall reichen 2 Frameworks: 1.1 (für ältere Applikationen) und 3.5 für die alle anderen.


    Eine 100%ige Garantie kann ich dir aber dafür nicht geben - dazu kenne ich mich dann doch zu wenig mit .net aus.


    Zitat

    würde das von der Geschwindigkeit her etwas bringen?


    Ausschließen würde ich es nicht. Es ist aber auf jeden Fall einfacher zu warten - du (bzw. dein OS ;) ) musst dann nur noch Servicepacks und Updates für 2 Versionen installieren.


    Viele Grüße


    Sandro

  • Habe aber .net3.5 SP1 zusätzlich installiert und siehe da, MG2009 ist doppelt so schnell (nach ca. 20 sek.) da. Bei der Konstostandsabfrage genauso.


    Hallo quengel,


    vielleicht gewinnen wir mit einer Konfigurationsdatei noch etwas zusätzliche Geschwindigkeit. Sicher bin ich mir nicht, aber ein Versuch wäre es wert. Erstelle für den Test im Programmverzeichnis der MG.exe eine Datei MG.exe.config mit folgendem Inhalt:


    XML
    1. <?xml version="1.0" encoding="utf-8" ?>
    2. <configuration>
    3. <startup>
    4. <supportedRuntime version="v2.0.50727" />
    5. </startup>
    6. </configuration>


    Durch diese Konfigurationdatei wird die Applikation angewiesen .NET 2.0 zu verwenden - unabhängig davon ob sich auf dem Rechner eine höhere Version befindet. Wenn die Datei keinen Geschwindigkeitsvorteil bringen sollte kannst du sie ja wieder löschen.


    Jetzt habe ich alle .net Installationen auf meinem Rechner (1.1, 2.0, 3.0 mit SP´s). Kann man die alle gefahrlos deinstallieren


    Wenn sie nicht stören würde ich die Versionen vorerst nicht deinstallieren.


    Gruß
    Jürgen

    [size=8]• Ich beantworte keine Programmfragen per PN! Fragen gehören ins Forum - dann haben alle etwas davon! •

  • Hallo in die Runde,


    ich hatte mich vor einiger Zeit ebenfalls über den super langsamen Start des Überweisungsträger Fensters geärgert.


    Ich möchte euch nun an meinem Glück teilhaben lassen. Was es nun bewirkt hat, ich kann es nicht sagen. Ob es an einem der Hotfixe lag? Im Moment habe ich jedenfalls nur das .Net 2.0 SP1 installiert. However, MG2009 funktioniert nun wieder in der gewohnten Geschwindigkeit.


    Ein Frohes Neues! Matthias