Mein Geld 2015 - entsetzlich langsam

  • Das war grob geschätzt. Wahrscheinlich war es weniger. Für solch hohe Werte wie von KKD genannt habe ich keine Ursachen-Vermutung, aber Verständnis dafür, wenn man darüber sauer ist. Evtl. wäre eine Art Abstimmung darüber, wer diese Art von Problemen hat ganz sinnvoll um eventuelle Hinweise dann eine direkte Kontaktaufnahme zu ermöglichen bzw. den Anteil herauszufinden.


    Falk

  • Das war grob geschätzt. Wahrscheinlich war es weniger. Für solch hohe Werte wie von KKD genannt habe ich keine Ursachen-Vermutung, aber Verständnis dafür, wenn man darüber sauer ist.

    Das habe ich auch. Allerdings ist damit der letzte Beitrag von mir, der versucht hat, mögliche Hilfe aufzuzeigen, schon wieder im Zeitvergleichen versunken, was keine neuen Erkenntnisse liefert.
    Aus dem Grunde werde ich mich auch schwer hüten, hier eine Liste der Neuerungen in MG 2015 .NET zu posten, denn die würde genauso untergehen.


    Evtl. wäre eine Art Abstimmung darüber, wer diese Art von Problemen hat ganz sinnvoll um eventuelle Hinweise dann eine direkte Kontaktaufnahme zu ermöglichen bzw. den Anteil herauszufinden.

    Was soll das bringen bzw. was soll anderes dabei herauskommen aus bisher in diesem Thread: nämlich daß sich die Leute mit dem Problem bevorzugt melden und nicht die, die es nicht haben (mal von uns im Forum Aktiven abgesehen)?

  • Also ich habe die genannten Probleme auch überhaupt nicht. Vom Start abgesehen läuft MG 2015 .NET sogar teilweise gefühlt etwas schneller als die 2014er Version.


    System: Athlon Dual Core 5050e mit 2,6 GHz, 4 GB RAM, Windows 7 Prof. 32 Bit, Grafikkarte nVidia Geforce 9400 GT mit 512 MB RAM, Festplatten: Systemlaufwerk und Datenlaufwerk je eine Partition auf einer HItachi SATA-Platte von 512 GB Kapazität.


    Der PC wurde in dieser Form im Juli 2009 installiert.

    Gruß Uwe
    ___________________________________________________________________________________________
    WISO Mein Geld Professional 365 .Net / REINER SCT cyberJack RFID comfort / Windows 10 Pro 64 bit

  • Nur mal eine Vermutung!
    Ich habe auf allen meinen Systemen die Leistung von Windows optimiert. Das heißt, alle Windows-typischen grafischen Effekte sind abgeschaltet. mit Tune-Up-Utilities sind die Systeme auf maximale Leistung getrimmt. Kann es an den Windows-Effekten liegen, kann es sein, dass auf den Startseiten von MG2015 zu viele Auswertungen aktiviert sind?
    Meine Datenbank hat ungefähr 10000 Buchungen, ca. 10 Konten und 5 Depots. Das Zeitverhalten ist normal, ich kann bei MG2015 keine Performaceprobleme auf meinen drei System (den Thinkpad 21 von 2002 mal aussen vor) feststellen.
    Liegt die schlechte Performance, die ich nicht bestreiten kann und will, auf anderen Systemen an irgendwelchen Spezialitäten von Windows? Hier sind aus meiner Sicht die Datenbankexperten von Buhl gefragt.


    Gruß
    rowi

  • Zitat


    Ich habe auf allen meinen Systemen die Leistung von Windows optimiert. Das heißt, alle Windows-typischen grafischen Effekte sind abgeschaltet. mit Tune-Up-Utilities sind die Systeme auf maximale Leistung getrimmt.


    Aha, alles klar.

  • Nur mal eine Vermutung! ... Kann es an den Windows-Effekten liegen


    Wohl kaum. Auf meinem o. g. System ist nichts, absolut nichts optimiert. Beim Systemstart werden zahlreiche Dienste gestartet - ich habe sie jetzt nicht gezählt, weiß aber, dass es eigentlich zu viele sind -, der Arbeitsspeicher ist nach dem Systemstart zu 50 % verbraucht. Beim Start von MG geht die CPU-Last mal kurz auf 100 %, vom physikalischen Speicher werden ca. 5 weitere Prozent verbraucht. Also eigentlich nichts ungewöhnliches.


    Vom Startklick für MG bis zum Erscheinen des Anmeldebildschirms der Datenbank vergehen 20 Sekunden, bis der Startbildschirm fertig dargestellt ist nochmals weitere 30 Sekunden. Damit kann ich persönlich durchaus leben, denn der Aufruf der Buchungsliste bei meinem Hauptkonto dauert dann nur 3...4 Sekunden. Allerdings sind in diesem Konto rund 10500 Buchungen, die ich mir alle anzeigen lasse. Insgesamt habe ich 30 Konten in der 25 MB großen Datenbank.


    Und wie bereits geschrieben: Genau dieser Aufruf der Buchungsliste dauerte bei MG2014 mindestens genauso lange.

    Gruß Uwe
    ___________________________________________________________________________________________
    WISO Mein Geld Professional 365 .Net / REINER SCT cyberJack RFID comfort / Windows 10 Pro 64 bit

  • Was soll das bringen bzw. was soll anderes dabei herauskommen aus bisher in diesem Thread: nämlich daß sich die Leute mit dem Problem bevorzugt melden und nicht die, die es nicht haben (mal von uns im Forum Aktiven abgesehen)?

    Das liegt wohl in der Natur der Sache. Oder kennt jemand einen Chef, der immer vorbei kommt, wenn was gut gelaufen ist? Wenn aber was schief gegangen ist, dann steht er eine min. später auf der Matte und regt sich auf. Und im Forum geht es ja noch leichter, immer aufzuzeigen was schlecht ist.

    Übrigens habe ich hier hin und wieder mal positives Feedback gegeben. So schlecht ist die Version, wie man hier meinen könnte, definitiv nicht. Und wer gibt schon gerne zu, dass hin und wieder der "Übeltäter" vor dem Rechner sitzt. Eher ist das Programm schlecht, als der Nutzer. Natürlich gibt es auch schlechte und gute Software => keine Frage. Bei unklaren Situationen mußt das dann erst mal geklärt werden. Und hier gibt es in der Tat extrem abweichende Meinungen und Ausschweifungen. Was hat jetzt Java mit den Startproblemen zu tun. Solche Aussagen kann man hier in die Tonne klopfen, weil es wirklich nichts zur Sache beiträgt und nur vom Thema abweicht.


    Schade, dass es so keine Liste aller Neuerungen hier gibt. Aber dann gehe ich selber auf Entdeckungstour :) . Das macht auch mehr Spaß, als immer danach zu schauen, was nicht geht.


    Nun vielleicht noch einen Hinweis: Vielleicht liegt es auch an der Sicherheitseinstellung>"Automatische Sicherung beim Öffnen der Datenbank erstellen"? Diese Einstellung wird bei Installation ja automatisch gesetzt. Ich habe den Haken mal entfernt und dann war der Startvorgang schneller (wobei er bei mir sowieso recht flott ist). Je nach Größe der DB kann das dann ja unterschiedlich lang dauern. Das Initialisieren des Programmes ist gleich. Die Abläufe danach gehen aber schneller. Wenn dann noch das Backup auf ein "langsames, externes Speichermedium" eingestellt ist, dann könnten sich die unterschiedlichen Startzeiten hiermit zum Teil auch erklären? Wenn mich nicht alles täuscht, dann wurde in der 2014 er Version nicht bei jedem Start ein Backup gefahren. Welche Logik da genutzt worden ist, kann ich nicht sagen. Es entstanden aber am gleichen Tag keine drei Backups, wenn das Programm 3 mal geöffnet wurde.


    Für den privaten Gebrauch ist es nicht notwendig, bei jedem Öffnen ein Backup zu fahren. Vielleicht alle 3 Tage oder einmal in der Woche. Insofern wäre es auch gut, Tage zu wählen, statt nur min. (das ist aber eher unwichtig). Vielleicht wäre es auch zu überlegen, eine Einstellung eines Backups beim Beenden des Programms zu spendieren. Dann wären auch gleich die aktuellen Änderungen gesichert und wenn dann die DB Sicherung im Hintergrund noch etwas dauert, ist ja auch egal, weil man dann schon mit anderen Dingen weiter arbeiten kann.


    Vielleicht noch einen weiteren Tipp: Wenn es um Fehlermeldungen geht, dann wird oft sehr grob beschrieben, was man gemacht bzw. geklickt hat (Missverständnisse sind vorprogrammiert). Oder man weiß bei einer Klickabfolge nicht mehr so genau, was man alles geklickt. Hier gibt es in allen Windowsbetriebssystemen ein kleines schickes Tool "Schrittaufzeichnung" (Start>Suchen>psr eingeben). Ich denke, das kleine Tool erklärt sich von selbst. Aufzeichnung starten, Programm bis zum Fehler klicken und dann die Protokolldatei sichern und z.B. an Support weiter schicken. Die Datei wird gleich gezippt und ist auch nicht besonders groß. Kann auch kurz via Mail/Ticket verschickt werden. Der Nutzer hat groß kein Aufwand und der Entwickler bekommt auch das ein oder andere Detail gemeldet, was der Anwender nie mitteilen würde. Das ist übrigens auch ein Vorteil der NET-Technologie. In der Aufzeichnung werden mehr Informationen aufgenommen. Mit alten Techniken sind hier oft nur Brüchstücke an Informationen da.


    Allerdings solltet man die Protokolldatei einmal anschauen und auch die Texte zwischen den gesammelten Informationen lesen. Beim jedem Klick auf eine Schaltfläche wird z.B. ein Snapshot gemacht. Wenn an der Oberfläche dann Kontendaten sichtbar sind, dann werden die auch aufgenommen. Also hier dann auch nur das aufzeichnen und weiter geben, was jeder auch so weiter geben würde!


    Soviel mal für heute!

  • Hallo cash_2
    ich frage dich mal direkt: Was hälst Du davon?


    Hier ein Beispiel wie sich WISO bei mir verhält:
    .... wenn WISO geöffnet ist und ich dann den Taskmanager starte, warte ich bis
    die CPU Belastung im Taskmanager mit 0% angezeigt wird.
    Dann öffne ich die letzte Buchung z.B. in meinem Haushaltskonto und editiere diese.
    Ich lösche dabei mit backspace den Eintrag 200,- und tippe dafür 55555,- ein.
    Durch diese simple Aktion springt die CPU Auslastung auf über 50% hoch.


    Es dauert dann auch gefühlte Sekunden bis man die gemachten Tastatureingaben im Zahlenfeld sieht.


    An den support habe ich mich natürlich auch gewand. Sehr neugierig auf meine Hard- und Softwareinstallation waren die aber nicht.


    Der lahme Start und das laden der Module stört mich ja eigentlich kaum, aber wenn man warten muß um zu sehen was man eingetippt hat machst keinen Spaß mehr.


    Ich hoffe ja immer noch auf das rettende update.


    Gruß
    Michael

  • Nach dem IOS 8.0-Desaster habe ich es lieber unterlassen, gleich die neue MG2015-Version einzubauen. Wobei Apple den Fix innerhalb weniger Tage parat hatte. Apple hat eine genaue Vorstellung davon, wo ihre Software laufen soll und gewährleistet das auch bisher ganz gut. Natürlich hat es Apple insofern etwas einfacher, weil die eingesetzte HW sehr genau bekannt ist.
    Es wäre aber auch für Buhl ein Einfaches die notwendigen Systemvoraussetzungen zu prüfen - Speicher, Prozessor usw. Aber selbst die schriftlich niegergelegten Voraussetzungen sind eher lächerlich; "Die Verwendung von WISO Mein Geld 2015 . Net und einem alten Rechner
    funktioniert, ist jedoch nicht optimal. Hierbei kann es zu
    Einschränkungen in der Performance kommen." Was ist das für eine bescheuerte Aussage - die beschreibt doch gar nichts. Mein PC ist 3 Jahre alt - ist das zu alt? Der hat 900 Euro gekostet, muss ich die wieder investieren wenn ich MG2015 laufen lassen will? (Das sind keine echten Fragen ans Publikum - die muss mir jetzt hier keiner beantworten)


    Aus dem Thread ist zu entnehmen dass es Anwender gibt, die schlechte Performance haben und andere die das so nicht zu erfahren. Das unterschiedliche Verhalten muss doch Gründe haben. Die zu ergründen wäre doch sogar im Interesse von Buhl; nicht nur der Betroffenen. Auf lange Sicht wird sonst mit den Füßen abgestimmt.
    Ich bin äußerst verwundert, dass es hier keinen Versuch gibt die Ursachen zu verstehen. Statt dessen sollen die Anwender sich zum Systemadministrator ausbilden lassen und selber am System drehen - für eine kleine Anwendung mit einer Datenbank die jeder mehr als hundertmal 1 zu 1 in seinen Hauptspeicher laden kann.

  • Nun vielleicht noch einen Hinweis: Vielleicht liegt es auch an der Sicherheitseinstellung>"Automatische Sicherung beim Öffnen der Datenbank erstellen"? Diese Einstellung wird bei Installation ja automatisch gesetzt. Ich habe den Haken mal entfernt und dann war der Startvorgang schneller (wobei er bei mir sowieso recht flott ist). Je nach Größe der DB kann das dann ja unterschiedlich lang dauern. Das Initialisieren des Programmes ist gleich. Die Abläufe danach gehen aber schneller. Wenn dann noch das Backup auf ein "langsames, externes Speichermedium" eingestellt ist, dann könnten sich die unterschiedlichen Startzeiten hiermit zum Teil auch erklären?

    Na ja, es werden hier zwar oft auch die längeren Startzeiten beklagt, aber das ist nicht wirklich das Problem. Das Problem bei den Betroffenen ist die miese Performance beim eigentlichen Arbeiten im Programm nach dem Laden der Datenbank.


    Wenn mich nicht alles täuscht, dann wurde in der 2014 er Version nicht bei jedem Start ein Backup gefahren.

    Die dem zugrunde liegende Option gab es auch schon in der letzten MG 2014 Version.


    Es entstanden aber am gleichen Tag keine drei Backups, wenn das Programm 3 mal geöffnet wurde.

    Prüfe mal die Auswahl unter Einstellungen -> Programmeinstellungen -> Datenbank -> Automatisches Backup.


    Für den privaten Gebrauch ist es nicht notwendig, bei jedem Öffnen ein Backup zu fahren.

    Das würde ich nicht sagen und auch niemanden raten, das abzustellen. Wenn es z.B. einen Absturz gibt (warum auch immer), würde ich schon auf das letzte Backup zugreifen und wenn das 3 Tage alt wäre und ich gerade am Vortrag einiges eingepflegt hatte, würde ich mich schon grämen (zumal man in der Zwischenzeit auch u.U. Belege wie Tankzettel wegeworfen hat etc.


    Vielleicht wäre es auch zu überlegen, eine Einstellung eines Backups beim Beenden des Programms zu spendieren.

    Dann würde das Programm beenden so lange dauern.


    Dann wären auch gleich die aktuellen Änderungen gesichert und wenn dann die DB Sicherung im Hintergrund noch etwas dauert, ist ja auch egal, weil man dann schon mit anderen Dingen weiter arbeiten kann.

    Nun ja, viele Anwender wollen danach aber auch gleich den Rechner runterfahren.


    Man kann über die Dinge sicherlich diskutieren, aber am Hauptproblem ändern sie meiner Ansicht nach nichts.

  • "Die Verwendung von WISO Mein Geld 2015 . Net und einem alten Rechner funktioniert, ist jedoch nicht optimal. Hierbei kann es zu
    Einschränkungen in der Performance kommen." Was ist das für eine bescheuerte Aussage - die beschreibt doch gar nichts.

    Wenn Du den Thread aufmerksam gelesen hättest, dann wüßtest Du, daß diese "bescheuerte" Aussage aber die Situation treffend beschreibt. :whistling:


    Es wäre aber auch für Buhl ein Einfaches die notwendigen Systemvoraussetzungen zu prüfen - Speicher, Prozessor usw.

    Wie Du den Beiträgen in diesem Thread entnehmen kannst, wäre damit überhaupt nichts gesagt. Tommes z.B. dürfte die Probleme nicht haben (hat er aber) und bei anderen sollten sie auftauchen (tun sie aber nicht).


    Ich bin äußerst verwundert, dass es hier keinen Versuch gibt die Ursachen zu verstehen. Statt dessen sollen die Anwender sich zum Systemadministrator ausbilden lassen und selber am System drehen

    Hier ist ein Anwender-helfen-Anwender-Forum und es können nur Tipps gegeben werden, was man selber probieren könnte.
    Es liegt an jedem Anwender selbst, die Tipps zu probieren. Wem das nicht reicht, wende sich an den Support.
    Wobei ich schon der Meinung bin, daß gewisse Kenntnisse nicht schaden können. Insbesondere auch, um Risiken und Nebenwirkungen des Einsatzes von "Optimierungssoftware & Co." einschätzen zu können.

  • Billy

    Zitat

    Tommes z.B. dürfte die Probleme nicht haben (hat er aber) und bei anderen sollten sie auftauchen (tun sie aber nicht).


    Nein, da hast Du mich vielleicht falsch verstanden.
    Die Umschaltzeiten sind bei mir so, wie bei allen anderen Usern, die schnelle Rechner haben. Hinnehmbar, aber eben etwas träger, als in der 2014er-Version.
    Schon allein meine Startzeiten zeigen ja, dass ich im vergleich zu anderen Usern wohl mit die kürzeste Startzeit habe: 7 Sek. bis Anmeldemaske, 17 Sek. bis die Startseite ganz aufgebaut ist.
    Aber das ist mir trotzdem viel zu lang. Auch die Fensterwechsel mit einem kurzen Aufflackern einer weißen Fläche oder der Aufbau der Auswertungen und die Refreshs.
    Das finde ich alles unschön und ich halte es für eine Verschlimmbesserung.

  • In meinem letzten Beitrag habe ich etwas unglücklich formuliert. Das hat einen Nerv getroffen, daraufhin wurde er entfernt (der Beitrag, nicht der Nerv).
    Um zu vermeiden weitere Empfindlichkeiten zu treffen klinke ich mich wieder aus. Die Diskussion führt eh zu nichts.

  • Ich habe in meiner DB kein Haushaltskonto. Habe aber das selbe in einem Offlinekonto bei mir durchgespielt. Alles reagiert sofort. Die CPU Auslastung geht beim Bearbeiten und Editieren des Betrags im Detailfenster auf maximal knappe 5%. Die Tastureingaben erscheinen direkt im Zahlenfeld. Ich habe auch an anderen Stellen probiert. Keine Probleme mit dem Arbeiten. Ich habe WIN 8.1.


    Das sind auf jeden Fall merkwürdige Phänomene, die nicht leicht zu lokalisieren sind. Warum der Support keine genauen Systeminformationen sammelt, kann ich auch nicht genau beantworten. Zu mindestens sollten die Tastatureinstellungen überprüft werden.


    Weitere Einstellung könnten eventuell auch hiermit zusammen hängen => Überprüfen>Systemsteuerung>Region>Weitere Einstellungen>Zahlenformate. Normalerweise sind diese Einstellung aber auf Deutschland korrekt eingestellt und sollten keine Probleme verursachen.


    Ich hatte aber schon mal ein Problem mit einem anderen Programm, dass bei Dezimaltrennung statt einem Komma ein Punkt eingestellt war (wiso auch immer??). Im Programm wurde versehentlich an einigen Stellen aber nicht die Systemeinstellung abgerufen, sondern immer ein Komma erwartet. Da sind dann derart merkwürdige Dinge bei der Zahleneingabe passiert, das man es fast nicht glauben konnte. Bis man dann die Stelle findet vergeht dann schon einige Zeit,


    Das sind aber jetzt natürlich nur Vermutungen, aber irgendwo muß man mal beginnen, um dem Problem auf die Spur zu kommen. Ich habe mal meine Einstellung der Zahlenformate angehängt.


    Vielleicht hilft das ja etwas weiter....


    PS: Gerade noch bemerkt. Tippt man zwei mal ein Komma ein (hab mich vertippt gehabt), dann wird die Zahl sogar übernommen (siehe Bitmap Zwei Komma). In der Buchung steht dann aber 0,0 € drinnen. Ist aber eher unter Schönheitsfehler einzustufen und dürfte mit diesem Problem eher nichts zu tun haben.

  • PS: Gerade noch bemerkt. Tippt man zwei mal ein Komma ein (hab mich vertippt gehabt), dann wird die Zahl sogar übernommen (siehe Bitmap Zwei Komma). In der Buchung steht dann aber 0,0 € drinnen. Ist aber eher unter Schönheitsfehler einzustufen und dürfte mit diesem Problem eher nichts zu tun haben.

    Ich weiß ehrlich gesagt überhaupt nicht, was Dein Beitrag hier mit dem Thema des Threads und dem von Dir zitierten Beitrag zu tun hat? ?(